No media will play after update

Log uploaded to: akimumugil

After the Nov. 2019 update none my media will play. Kodi attempts to open the media, but then nothing, just back to the home screen. All the media is present and plays just fine when accessed from another PC. I appreciate any help offered.

Please enable debug logging, reboot, and post new logs.

Looks like you mixed up your mount point

/dev/sda2            5.5T  1.4T  3.8T  28% /media/osmc_drive
/dev/sda1            120M  1.6M  110M   2% /media/osmc_drive_

2019-11-28 08:25:18.809 T:3940541152 WARNING: Process directory '/media/osmc_drive_/Media/Movies/' does not exist - skipping scan.

Your movies now seems to be on /media/osmc_drive not /media/osmc_drive_

Thank you. I have no idea how that may have happened.
Also, I have no idea of how to fix it. Can you point me in the right direction?

Well a quick fix would be to just changes the sources you use in Kodi.
On the other hand if this is your final setup question is why you have 2 partitions on that disk. You might want to repartition to only use one.

A fix that wouldn’t require rescaning your library would be to fix it with a path substitution. You could SSH into your machine and…

nano ~/.kodi/userdata/advancedsettings.xml

and copy/paste in the following…


Then press ctrl+x, y, and then hit enter. Type reboot and then hit enter.

That didn’t seem to have any effect. Afterwards I tried rescanning the libraries again and finally got some movies to play, but now there is no sound

If you didn’t move any files on the drive itself i’m very confused on why that wouldn’t have worked. I assume the “some” part was because you didn’t clean your library and you have duplicates. As for the no sound I don’t see where that would come in. The update wouldn’t change anything in that regard and the log your posted show your outputting to two channel LPCM so that should be almost foolproof. This is kind of sounding like random problems and it may be best to just reinstall OSMC and rebuild your library from scratch and see if your issues clear up.