No "Play CD" home menu item, but CD plays

I’m running the 2016.09-1 release and Kodi 16.1 on a Raspberry Pi 2. I have an external Samsung CD/DVD writer connected to a powered hub which is then connected to my Pi. The drive is recognized by the OS and I’m able to rip commercial audio CDs from the command-line. In OSMC I have it set to play audio CDs automatically, and they do so with album and artist info downloaded. However, there is no home menu item that allows me to see the contents of the CD, nor to eject it. What can I do to enable this menu item? I can provide debug logs if needed.

As an additional data point: the “Play Disc” option appears under Confluence, but not the OSMC skin. Is there a way to enable it with the OSMC skin?

The OSMC skin’s menu is easy to edit, so you can add them yourself. ‘Settings’ > ‘Appearance’ > ‘Skin’ > ‘- Settings’ > ‘Customise Home Menu’.

Then ‘Add’ a new menu item from the options on the right and ‘Choose item for menu’. Play DVD and Eject Tray are under ‘Common’ (Play DVD will play an audio cd, too), and there’s a Rip Audio CD option under ‘Kodi commands’.

Hi,
I’m using Unity and found a comparable way to add the PalyDVD() event to the menu.

any idea to add the rip command ?
Sometimes the auto rip does not start at all (no idea why) right after having displayed for fraction of second he was searching for CD data…
Thank

The home menu of the Unity skin is based on the Skin Shortcuts script, the same as the OSMC skin. That means when setting up a new menu item you’ll find the Rip Audio CD command in the same place as with the OSMC skin - under Kodi Commands. Or you can manually set a menu item to the command RipCD.

The Unity skin isn’t specific to OSMC, though, so you may find better support for it on the Kodi forums - http://forum.kodi.tv/forumdisplay.php?fid=244

Thanks so much! This worked perfectly. Is there any reason why this had to be added manually, rather than the menu item coming up automatically upon disc insert, like in the Confluence skin?

Either because the skinner responsible hasn’t included it as one of the default menu items or - if you’ve previously customised the menu on another skin that uses the Skin Shortcuts script - the skinner of that skin didn’t (home menu’s are shared amongst skins using the script once the menu has been edited).

Okay, thanks for the info. This was on the default OSMC skin after a clean install.