No Signal after stopping 3D SBS movies

Hi all,

Got my Vero 4k+ this week, had fun setting it up. I come from shield TV and I am amazed by the difference in picture quality, Vero is a star for 1080p and 720p content. HDR 4K looks great on both devices. It’s great when it works. On that:

I am struggling with 3D SBS files though. Some of them have Atmos True HD audio. The files play fine, TV detects 3D and AVR detects Atmos. It’s when I stop playing, the device goes blank. TV goes back to 2D and then into no signal mode. AVR reports no audio signal. I suspected CEC was to blame, so experimented with enabling and disabling it. I tried changing audio output device from HDMI to PCM, nothing.

I am using Belkin/Amazon certified cables (using the same for Apple TV 4k) going from Vero to Denon to TV. Please help! Here’s a log of the incident -



Glad to hear you’re enjoying the Vero.
I think this may be similar to something we discussed internally the other day on the team. @JimKnopf can clarify.

Rest assured, we’ll get this fixed. We just need to work out a few more details.



Not too much added value I can give here:

  • this issue does NOT happen on the Pi3B+ Leia v18 but only on Vero4k
  • while playing a SBS 3D video you can force the issue by going into the OSD menu and switch from “3D Side by Side” to “Disable”
  • my AVR displays “no stream” while black screen, so it is a complete signal loss
  • even if you SSH to the box and restart the mediacenter, the HDMI signal does not come back … you have to reboot
  • the mediacenter is not dead while the signal loss: If you switch to “3D Disable” mode while playing a video in “3D side by side” mode and videoplayer is still running, you can press the STOP button to get back to the Kodi GUI. In the upper left corner you see then “3D” displayed … so obviously something in the code path disabling “3D SBS” goes nuts
  • changing desktop resolution has no effect
  • adjust refresh was set to always and start/stop while tests

Sorry, that’s all I could find out till here

Has it always been thus, or can you remember a time when it did work as expected?

Thanks Sam and JimKnopf for confirming that the issue is known and being worked on. I have had the same experience when it goes blank, mediacenter ‘stop’ and ‘start’ does not allow the signal the return. The device needs rebooting via SSH.

I can’t recall testing extensively on 3D files, but I do recall having similar issues with 4K HDR (constant stuttering, no signals etc.). This was when I decided to trust the HDMI cable that comes with Vero 4K+ over my tested cables. Once I made the switch to my own tested cables, 4K and every other file plays smoothly (and blazing fast I must add in praise of this little box). However, now 3D switch from 3D->2D gives me jitters (bad pun intended :stuck_out_tongue_winking_eye:).

A suggestion to whoever is facing the no signal and other playback issues on this device, try purchasing Belkin HDMI cables (the ones certified by Apple for their 4k TV). You won’t be disappointed.