No sound for 10 sec when start playing video (Raspberry)

I installed OSMC latest version for Raspberry PI2 (OSMC_TGT_rbp2_20151027).
The Movies are stored on an external USB Disk.
When I start a movie, i takes 8-10 seconds until the sound begins to play,
When I pause (at the start) the movie and wait for 10 seconds the sound plays immediately
(buffering problem?)

Any Ideas, suggestions?



No problems with OSMC skin,
sound problems with confluence and eminence.


Most likely a problem with how quickly your TV syncs up with the Pi when the HDMI audio channel is started - I don’t have any problems like this with my TV but an HDMI PC monitor I test on takes 3-4 seconds before the sound starts when playing video - the delay is so long that I don’t hear GUI sounds for a few seconds either.

A possible solution is to go into Settings->Audio and change the setting which causes the Audio channel to be stopped when idle for 1 minute - change it to never.

I tried the raspberry with the eminence skin on a different TV and it works.
Strange, because with the first TV i tried out different devices, systems (Android TV Box, Raspberry with Openelec, …)
and never had that problem.

Hope the configuration works fine in the enviroment of my brother, for whom I setup the box.


A skin is not going to affect an audio problem during playback. However, you might find that a different skin plays a GUI sound when you press play, thus working around the issue by triggering the audio output to enable earlier.

Do you get the same problem with the analog output ? I bet you don’t… Go back to the original skin, change the audio output to analogue and plug in some headphones…