No Sound with AAC Audio Over HDMI (Logs Added)


Im all setup now on OSMC and its bloody AMAZING. qq though, ive imported all the video from my previous windows install of Kodi and ive noticed that for video with AAC audio I get no sound, ive got passthrough enabled and DD/DTS stuff is fine:

Audio Output Device - PI:HDMI
Number of Channels - 2
Allow Passthrough - Yes
DD receiver- Yes
Transcoding - No (changing to yes does nothing)
Dolby Digital Plus - No
DTS - Yes

My setup is the Pi is connected to my TV which then has an optical SPDIF to my amp.

Im running the Krypton build of OSMC.

Thanks in advance…

I have uploaded logs to hopefully assist:

MediaInfo =
OSMC Logs =

Thanks in advance…

I downloaded some test files from here:

Weirdly, if I enable transcoding, my amp shows “dolby digital” for 5.1 Surround Sound AAC Test.mp4 but theres still no sound.

I can see the amp reacting (the channel lights flicker momentarily) when video starts, but there is no sound. I’ve checked on my windows machine and the files play fine with sounds…


I have a similar setup with a slightly different issue, maybe it’s related?

RPI2 connected over HDMI to a AV Switch which has a optical out to my amp (doing effectively what your TV is doing).
Output: HDMI
Channels 2.0
Passthrough: HDMI
DD, DTS: yes EAC3 No

DD, DTS play fine.
Stereo AAC plays fine
Multichannel AAC (6ch) only gets to my amp as a stereo feed, and the volume seems to be quite low.

I am on latest OSMC (at least from last month)
Until I got the AV Switch last month I was on OSMC from Nov 2015 (I am allergic to updates if things are working), and during that time Multichannel AAC put the rear L/R on the front L/R speakers (I was using HDMI only for video, and I used an external Creative XFI USB soundcard with Optical to take the audio off the PI.

I think this is probably a KODI issue, or your TV settings/my AV switch (devices that handle passthrough and split off the audio to TOSLINK sometimes dont work as we expect they should).

Do I have any options here then? is there an easy way to say convert the files away from AAC to AC3?

Do the logs suggest what is causing the issue?

OK so now I feel like a total moron, so I switched it over to analogue and plugged in headphones, still nothing, then I noticed the mute symbol in the top right, removed the mute and sound in headphones.

But the sound back to HDMI and now there is sound, mental, so appears the sound level impacts AAC but not DTS/DD.

Anyway, good to know its working now!

Mute will not affect passthrough audio of course. So dts and ac3 played fine.

Multichannel aac cannot be passed through. There should be an option to reencode to ac3 on the fly in the audiosettings. Could be that that only works with hd audio streams though.

This is in fact what I did to solve my problem. As soon as I checked the re-encode to AC3 setting, 6 channel AAC started working properly, and at the correct volume.