No video play after November update

Hello,
after the november update, My raspberry pi freezes every time I try to play a video from my NAS (Before the update, it used to work very well)

To get a better understanding of the problem you are experiencing we need more information from you. Please see http://osmc.tv/wiki/general/how-to-submit-a-useful-support-request/ for advice on how to help us.

Ok.
Every time I try to play a video that worked before the update, my raspberry pi freezes. It is connected via LAN to my NAS in which I usually have all my media.

Here is the log at the freeze:
00:40:08 373.505798 T:2622297120 DEBUG: ResolutionUpdateCallBack - change configuration. video:1920x1080. framerate: 23.98. 1912x1038 format: BYPASS
00:40:08 373.507050 T:2655515680 DEBUG: CDVDPlayer::SetCaching - caching state 0
00:40:08 373.507385 T:2655515680 DEBUG: OMXClock::OMXSetSpeed(1.000) pause_resume:1
00:40:08 373.509399 T:2655515680 DEBUG: CDVDPlayer::OMXDoProcessing Resume 0.60,0.28 (A:01 V:01) EOF:0 FULL:0 T:0.20
00:40:08 373.509674 T:2655515680 DEBUG: OMXClock::OMXSetSpeed(1.000) pause_resume:1
00:40:08 373.510345 T:2622297120 DEBUG: CMMALRenderer::Configure - 1912x1038->1912x1038@23.98 flags:10 format:14 ext:0 orient:0
00:40:08 373.510651 T:2622297120 NOTICE: Display resolution USER : 1920x1080 (1920x1080) @ 59.94 - Full Screen (23)
00:40:08 373.510864 T:2622297120 DEBUG: CMMALRenderer::init_vout configured:0 format:0->14
00:40:08 373.513458 T:2622297120 DEBUG: CXBMCRenderManager::Configure - 3
00:40:08 373.667206 T:3024953904 DEBUG: CAnnouncementManager - Announcement: OnPlay from xbmc
00:40:08 373.667694 T:3024953904 DEBUG: GOT ANNOUNCEMENT, type: 1, from xbmc, message OnPlay
00:40:08 373.678436 T:3024953904 DEBUG: Activating window ID: 12005
00:40:08 373.682068 T:3024953904 DEBUG: ------ Window Deinit (MyVideoNav.xml) ------
00:40:08 373.709076 T:3024953904 DEBUG: ------ Window Init (VideoFullScreen.xml) ------
00:40:08 373.709442 T:3024953904 INFO: Loading skin file: VideoFullScreen.xml, load type: KEEP_IN_MEMORY
00:40:31 396.855225 T:2635330592 DEBUG: Thread JobWorker 2635330592 terminating (autodelete)
00:40:31 396.856140 T:2672292896 DEBUG: Thread JobWorker 2672292896 terminating (autodelete)
00:40:31 396.922302 T:2807034912 DEBUG: Thread JobWorker 2807034912 terminating (autodelete)

This snippet is not enough to diagnose your issue.

Please, could you underline what do you need?
Consider that if I try to play to music (also in my NAS), it works.

My raspberry pi is attached over hdmi to an amplifier

Meanwhile, here is all my log:

I’ve tried also to play a video copied in the home of my raspberry pi but it keeps to freeze (I hear a sound repeated in loop)

Please, can someone help me? I’d like to understand why it do so before reinstall everything

No obvious errors in the kodi log.
I’d suggest backing up the sdcard and either reverting to the October image (assuming that was working for your), or installing the November image from scratch.

Thank you for your reply and for your time!
I usually do a dd backup before every update. Try to guess? I didn’t do it this time…
I must backup my db and restore a previuos release

I’ve restored an October backup and then updated… It works

Probably something was wrong during the previous update