No video signal detected after OSMC system update

Hi everyone,
I am totally new to OSMC but used Kodi for several years. Today I got my Vero 4k+ and was really thrilled to test it out… so I played a little with the Kodi settings, installed two video plugins and everything worked like a charm. Well, then I decided to do an OSMC system update, installed all updates and then, no signal detected, red permanent LED lighted up (in front of the Vero 4k+). So far I have no clue what to do.

Here is what I did exactly:

  • Unboxed the Vero 4k+
  • Inserted microSD
  • inserted USB Receiver for the remote
  • Plugged in sound
  • Used the provided HDMI cable to connect Vero 4k+ to my LG Beamer
  • Plugged in power

Voila - OSMC booted, I processed the initial setup and after that adjusted a few Kodi settings, checked that SSH is enabled, set language, adjusted some OSMC skin settings and installed MediathekView Video Plugin as well as Plex Video Plugin. Both worked out of the box.
I then decided to check for system updates of OSMC (system info mentioned version 2020-11-xx to be installed) and detected updates to be available. So I processed update installation which succeeded with 100% BUT after that, screen went black, no signal detected, the red LED in front of the Vero 4k+ stayed lighted up in red permanently. After a few minutes I removed power plug, tried different HDMI cable, nothing. When power plug is inserted, you can see a tiny red light at the rear part of the device next to the digital audio out, so the device itself still got power (or at least it looks like that).

As mentioned before I’m a total noob with OSMC so far and honestly as well with Linux. Please advise what might be the issue and what I can do to resolve the issue as this is a rather frustrating start. Many thx for your assistance!


Sorry to hear this.
The first thing to try would be to reinstall OSMC. See Reinstalling OSMC - Vero 4K - OSMC (and ignore the toothpick method advice).


1 Like

Many thanks Sam_Nazarko, I will give that a try tomorrow and will report back!

Okay, I tried what you suggested Sam_Nazarko without success.
DL’ed the installer, flashed the latest image to USB Stick, inserted USB stick, powered Vero 4k+ on, no signal.
Did the same procedure again but this time flashed to microSD, inserted microSD, powered Vero 4k+ on, no signal.
Even hooked it up to my old Samsung TV, same situation. Any other advice what I can try to get Vario 4k+ to work?

What was the LED doing at that time?

Front LED is completely off. Once I installed all system updates the front LED was red all the time, updates reached 100%, after that, no signal, front LED stayed red. After a few minutes I disconnected power and reconnected power supply, since then, LED does nothing anymore.

So even not shortly on when you plug in power?

Nope, nothing at all. But when i check the backside I can see tiny red light from the optical digital audio output which tells me something is alive there (UPDATE: I just checked again and now even this tiny red light is gone, all dead now). I tried installing OSMC again, this time with 10-01 image (not the latest), same situation.

I unplugged everything again and then only plugged in power supply + HDMI. Now this time TV gets signal, shows 1280x720 but stays black, no red LED on Vero4k+, nothing. Waited 20 minutes, nothing.
Removed power plug, added microSD, powered it on again > no signal
Removed power plug, removed microSD, powered it on again > no signal
The behavior is not consistent and I’m really running out of ideas.

What are the contents of the micro SD card? Is it just a micro SD card you’re using to store external media on?

Do you have another display that you can test on?

The microSD card holds the OSMC image that I wanted to flash, which fails due to the no signal issue.

I have a Samsung TV and a LG Beamer, tested on both, same situation.

I actually turned the Vero 4k+ on again now (it was completely disconnected from power for 4h now) and this time when powering it back on I got a green screen for a couple of seconds which faded to very dark green after 10 seconds. Apart from that, nothing, it stays in this condition.

You understand that you must flash the installation image to the SDcard by use of some other system than the Vero first right?

Maybe I did not make myself clear: the SD card was used to flash the image to it and afterwards inserted to the Vero 4k+.

Can you show a screenshot of the contents of your SD card?

Did you purchase this item from a reseller (Welectron) and raise an email with them (Ticket# 6154709)?

This is the content of the USB Stick, the SD card has the same files on it (but with different file size as I tried the current and an old image as well).

Yes, exactly. I did purchase the device from Welectron and that’s the corresponding support ticket.

Thanks for confirming. They reached out to me.

It looks like you imaged the SD card / USB stick correctly.

Do you have a USB-A to USB-A cable or another 5V, 2A power supply you could power the device with?

I used the provided installer and did not encounter any issue with it so my assumption was, it was correctly flashed.

Yup, they told me about it but I wasn’t aware it’s gonna be you :wink:

I just noticed I have a 5V/2A power supply, most likely I’ll be able to find a USB-A to USB-A cable to test it with this. I assume every USB port can be used to power the device?


If you have a USB A-A cable, just connect it to a desktop or laptop - verify the port works first with another device like a flash drive.


Will try to find the USB cable tomorrow and report back, thx!