No wireless connections after July update

OSMC provides ZERO support for pirate addons. Your thread includes or mentions them and has been unlisted for that reason. Feel free to edit your post and it will be relisted.

Sorry. Edited

You’ll have to provide some debug logs so that we’ll be able to provide a diagnosis.

Login via the command line
Edit the file /etc/apt/sources.list
Add the following line: deb jessie-devel main
Run the following commands to update: sudo apt-get update && sudo apt-get dist-upgrade && reboot
Your system should have have received the update.
Please see if the issue is resolved.

I also recommend you edit /etc/apt/sources.list again and remove the line that you added after updating. This will return you to the normal update channel.

Thank you for your answer. But I have no idea how to do this. How do i get to command line? I havent added no line. Was just prompted to do an update i Kodi, after that wifi stopped working.


This is explained in the Wiki.

1 Like

Thanks. I need to get a keyboard first. Was not able to save changes to sources.list with my remote. No ctrl button

Did an auto update, now no wifi networks are listed. Every other device is still able to see and connect to the two wifi networks I have. No other changes have been made.
This is the log first log after the problem was detected.

Tried to apply this
in the hope that it was the same issue, but still not working. This is the latest log after applying above.
Hope you can help. With thanks…

If you can test the instructions above, then I can proceed with resolving
the situation


Hi guys.

I try the instruction post above. Got some update, reboot but nothing solve. The problem still the same

So SAD!!!

This solved the issue for me - thanks :o)

Thank you for confirming.
I’ve now pushed this out to release so there should be no further
issues for those updating.

For those affected, simply connect an Ethernet cable and check for updates under OSMC. See Keeping your OSMC system up to date - General - OSMC

Not working for me… :frowning:

Post a debug log if this isn’t working.
Did you reboot after updating?

Well then maybe a different problem. Try to explain what the problem is and also upload logs

After the last update wireless connection is not working.

Which wifi dongle are you using?

Also, connect Ethernet and upload logs via grab-logs -A

I suspect he hasn’t updated, so it’s no surprise that it’s not working.