No wireless connections after July update

Which wifi dongle are you using?

Also, connect Ethernet and upload logs via grab-logs -A

I suspect he hasn’t updated, so it’s no surprise that it’s not working.

Well seems to be up to date, but only logs can tell

Ok so problem solved.

Look like after the last update wlan0 when down with the update. (I said this because in one year is the first time I get into kodi through the command line)

What I did was put the wlan0 down then up and “whalla” it work.

–》 after the login
Sudo su
Ifconfig wlan0 down
Ifconfig wlan0 up

Ifconfig wlan0 (to confirm that to get assign IP Address from your router)

1 Like

Try reboot, and confirm whether the issue is resolved without manual
intervention

Ok so i did this:

Login via the command line
Edit the file /etc/apt/sources.list
Add the following line: deb http://apt.osmc.tv jessie-devel main
Run the following commands to update: sudo apt-get update && sudo apt-get dist-upgrade && reboot
Your system should have have received the update.
Please see if the issue is resolved.

I also recommend you edit /etc/apt/sources.list again and remove the line that you added after updating. This will return you to the normal update channel.

Then what i explained turning off and up the wireless.

After reboot and turning kodi off Works well. If you go to get the last update manually you will get back to the wireless issue.

The commands you ran are not persistent, if everything is resolved after a reboot then the problem is indeed solved, and the last update is working as expected.

I’m not an expert but I’m happy to get osmc back :grin::grin::grin:

Indeed. Thanks for testing the update and I’m glad that it’s working for you now.

Sam

@carmen_garcia @mark_dk
While it seems we have no fixed the issue for you I am still a bit confused why it happen the first place. Can we try to collect some more details:

  1. Which dongle are you using for wifi connection?
  2. Did you try to manually reboot your device after loosing the connectivity?
  3. Had you ever before needed to scan and rejoin your wifi?

Appreciate your help to understand the issue a bit better

@fzinken
In reply to your questions:

  1. Standard raspberry3 with no USB wifi dongle, just the standard internal wifi that comes with it. The only other USB device connected is a FLIRC usb dongle (infrared receiver).
  2. Yes, I rebooted many times both from the menu and also by cutting and reconnecting power.
  3. No, Never seen this before.

Bonus info: I have however from time to time seen some instability in general which puzzles me. Usually after a period of time with heavy load such as updating the library. The unit might freeze. It’s a standard Rpi3 with the standard Rpi3 enclosure (no cooloing) and the official Rpi3 power supply. I run no addons. I don’t overclock.
Reducing speeds to 700,400,400 solves the problem and the unit still seems almost just as snappy. I haven’t drilled down to figure out if it’s the voltage or what specific clock is causing the issue since I’m assuming it’s a general heat related issue, or perhaps a unit that somehow falls slightly below spec. I’m in the northern part of Australia and were sitting at 26C (79F) in the middle of winter.
Hope this helps.

Ok, good to know as I have only external dongles and didn’t run into the problem.

That sounds not good. Could be a power supply issue.
You can monitor the temperature with watch vcgencmd measure_temp

This worked for me :blush:

So if you now reboot is it still working with out this “trick”?

I’d just add that the Pi3 is known to run hot and will generally benefit from one of those stick-on heatsinks.

You mean like this Heatsink for Raspberry Pi - OSMC :wink:

I was getting 83deg C when doing a library update. Opening the case took it down to 77deg C. Added a heatsink and dropped to 63 deg C. Lid back on still with heatsink and it climbed back to 81deg C.
I will drill some holes in the enclosure, that and the heatsink should do the trick. I don’t like fans.
Thanks everyone for all your input :slight_smile:

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.