No Zeroconfig option when searching video sources

Hello.

When I try to add a Video source I cannot find anymore the “Zeroconfig” option … and none of the other options finds my QNAP Nas.

Do I have to activate specific services / add-ons on my Vero 4K to enable this video source search option ?

Regards

Hi. Welcome to the forum.

I assume you’re talking about zeroconf. On Linux systems avahi is the zeroconf implementation that’s used. It is installed by default on OSMC and configured to run automatically.

You can see if it’s running with the command:

systemctl status avahi-daemon

That will show something like this:

osmc@osmc:~$ systemctl status avahi-daemon
● avahi-daemon.service - Avahi mDNS/DNS-SD Stack
   Loaded: loaded (/lib/systemd/system/avahi-daemon.service; enabled)
   Active: active (running) since Fri 2017-04-21 00:09:23 CEST; 1 day 10h ago
 Main PID: 225 (avahi-daemon)
   Status: "avahi-daemon 0.6.31 starting up."
   CGroup: /system.slice/avahi-daemon.service
           ├─225 avahi-daemon: running [osmc.local]
           └─236 avahi-daemon: chroot helper

In this case, my OSMC box is named osmc.local. You can then try to ping osmc.local.

Hello. Thank you for the prompt reply.

Please note I am a very basic user, so I would need your help to understand how to / where to type the command you are suggesting.

Can you please help me again ?

Of course!

Here is a brief guide to logging onto your OSMC box and running commands.

https://osmc.tv/wiki/general/accessing-the-command-line/

If you are using a Windows machine, you will probably need to install Putty. It’s explained in the guide.

Thank you so much ! I will look into it straight away

Hello again.

I am trying to access the Vero box via Mac command line, but I get “Connection refused”.

Not sure if I have to enable something in Vero to enable the connection from external devices

Used the USB keyboard connected directly to the vero box. typed the command you suggested. service is ACTIVE (running).

Still I cannot select zeroconf as search option for video sources …

:weary:

Ok, so that’s good to hear. Unfortunately, I’m away from my TV right now.

Do you know if your QNAP NAS is using Samba or NFS? Zeroconf / avahi is just a convenient way of finding other machines on the local network. If you know the IP address of the NAS, you can try one of the other options to connect.

Edit:

Using your keyboard, run these commands:

sudo systemctl enable ssh
sudo systemctl start ssh

Then try to SSH to OSMC again.

Make sure you’re connecting to the right IP address.
Make sure SSH Server is enabled and running in My OSMC → Services.

Do you see Zeroconf browser here?

Hello Sam.

No, I do not see Zeroconf in that list.

I can find my NAS with the UpnP Device option, but it is a workaround that does not allow me to use the feature that identifies movies by their names and downloads all the images, plots and info …

SSH service is up and running

:tired_face:

That’s UPNP / DLNA, so you could add it via UPnP by selecting ‘UPnP Devices’, if you have that option. Can you confirm that:

  • Your device is up to date
  • You’ve tried this with the OSMC skin

I’ll see if I can reproduce this issue shortly.

Sam

Hello Sam.

  1. Yes, I have run the manual updates check and there is no update for my box (I see OSMC March 2017 2017.03-1 in the bottom left corner of the screen when in MY OSMC page

  2. I was using the Confluence skin, so I selected the OSMC and restarted my box. With the OSMC skin in place I go to Videos/Files/Add videos … then … Browse for new Share/UPnP devices… and find nothing … funny enough, now the connection with my Nas (that I could establish previously) does not work anymore …

Any idea?

I will try and reproduce this later today; for now you may want to post a debug log so we can see why the connection to your NAS isn’t working. It could be a variety of different things, such as a IP changing on your network, so it’s best to get some logs

Now you’re successfully using SSH, please log on and run:

grab-logs -A

then let us know the address returned.

Can you now see the Zeroconf option as shown in the above screenshot?

http://paste.osmc.io/lowivatuwi

Hello fzinken.
No I cannot

If it makes you fel any better, I also don’t have the zeroconf option on my Vero 4K menu. I tried both Estuary and OSMC skins.

I’ve taken a look at the log you gave us. I can see that the discovery service of your QNAP NAS is advertising itself and you have aded a link in Kodi to:

upnp://55076f6e-6b79-1d65-a4eb-00089bd6aa70/0%243%2433%2450%2451/

Later in the log, we can see:

14:40:31.118 T:4112855984   ERROR: GetDirectory - Error getting upnp://55076f6e-6b79-1d65-a4eb-00089bd6aa70/0%243%2433%2450%2451/
14:40:31.119 T:4112855984   ERROR: CGUIMediaWindow::GetDirectory(upnp://55076f6e-6b79-1d65-a4eb-00089bd6aa70/0%243%2433%2450%2451/) failed
14:40:36.567 T:4112855984   ERROR: GetDirectory - Error getting upnp://55076f6e-6b79-1d65-a4eb-00089bd6aa70/0%243%2433%2450%2451/
14:40:36.568 T:4112855984   ERROR: CGUIMediaWindow::GetDirectory(upnp://55076f6e-6b79-1d65-a4eb-00089bd6aa70/0%243%2433%2450%2451/) failed
14:41:29.267 T:4112855984  NOTICE: Samba is idle. Closing the remaining connections
14:45:53.158 T:4112855984   ERROR: GetDirectory - Error getting upnp://55076f6e-6b79-1d65-a4eb-00089bd6aa70/0%243%2433%2450%2451/
14:45:53.159 T:4112855984   ERROR: CGUIMediaWindow::GetDirectory(upnp://55076f6e-6b79-1d65-a4eb-00089bd6aa70/0%243%2433%2450%2451/) failed

but that’s not a whole lot of information to go on. The first thing to double check is permissions to the data on the NAS.

Revisiting your first post you said:

What happens if you browse for a new share on either NFS or Samba?

Hello.

A friend of mine added manually a new samba network location (typing the exact NAS tcp/ip address) with user ID and password (not anonymous). This worked.

The network browsing still does not work (OSMC does not “see” anonymous shares … OSMC returns the following error message Error2:share not available) and still the Zeroconf entry is not listed amongst available options.

Please note that from both my raspberry and Mac I can see and access this share in Anonymous mode.

New logs uploaded here: http://paste.osmc.io/lerawateta

Thank you for your support !

Thanks for the follow-up. Good to hear you got it working in the end.

And just to reiterate one thing: I also don’t have the zeroconf option in my 4K menu, so your situation is anything but unique.