Not able to upgrade to Krypton


I’m trying to upgrade to the new build. First I attempted using the OSMC updater. It seemed like it was working but after reboot I found out it was still in the same old version (v16.1).
Then I tried to upgrade with SSH

sudo apt-get update
sudo apt-get dist-upgrade

Checking the putty screen I saw that it was upgrading from v16 to v17. After completion, in my TV the update was stuck with the black screen and some info lines, being the last
OK Started update UTMP about System Runlevel changes. After many minutes it didn’t move forward, so I started Kodi via SSH. Then I could see the new OSMC version. I rebooted the RaspPi and it booted again in the previous version (V16)!

I’ve done this procedure few times and always get the same result.
I grabed the logs so you could check if there is something wrong

Any ideas?


You have previously run the command apt-get upgrade.

You have no option but to reinstall OSMC.

HI, @yknivag,

It may be that, but I’m suspecting of something else. In the log I don’t see all the previous attempts I made this afternoot, just the last one just before grabbing the logs.
It also happens that after writing this message I tried to format the microsd card in order to rescue an OSMC backup image I have in my PC and I got the message ‘the sd card is write protected’. But somehow OSMC got updated few days ago, I’m starting to think that something got wrong.

I’ve been trying to unlock the card and haven´t found the way yet, I keep trying.

If you run, apt-get upgrade, you need to reinstall your system.

It’s not a case of it may be the cause, it’s the cause.

Some cards go faulty (RO) when they fail. We were recently discussing this on OSMC Slack.

The card seems broken, no way to unlock it. I’ll try with the OSMC SD card, hopefully will last longer than this Samsung Evo. I don’t know when but for sure it crashed before I attempted the upgrade to Krypton as the first times I used the own OSMC updater without success, and then moved to ssh.

Just a question, I looked in the log for apt-get upgrade and found out a entry… A year ago. Can it make problems something done so long ago?

Thanks for your help.

Yes as it breaks dependencies which may only surface when certain packages are updated.

Understood, time for new, fresh install then.
Many thanks!