Not sure what I am doing wrong

I purchased a number of Vero 4k’s a while ago. The main one is no longer playing video files without stuttering and stopping. Playing the same videos on Kodi on an old Pi works fine.

Decided to get another Vero 4k working but it does not want to play ball. It powers on and then does nothing. I find the documentation somewhat lacking but it would appear that it is not attempting to boot. I assume OSMC boots off the microsd card but it does not appear to be doing that.

My first question is - should the microsd card go all the way in the slot? Should it click in?

Next question is - can I use a USB flash drive instead of microsd? If so, what size can be used.

I’m confused as to why the Vero 4k has suddenly stopped playing videos.

I would love to see much of the wiki information moved to a PDF so that the instructions are clear and in one document. Please can this be considered?

The OS runs off the internal storage, not a micro SD. A micro SD could be used for formatting (reinstalling the software).

The micro SD goes fully in and should be inserted so the pins are facing you and the logo (SanDisk etc) is pointing down.

When you say the device doesn’t work anymore, do you mean that the menus etc are coming up, it’s just playback not working?

You could reinstall OSMC as the quickest solution, but some logs would likely reveal the issue. It could be network related, if you’re trying to access files from a NAS.

That’s the plan for the long term but the Wiki system needs a revamp presently. Then I’d have an option like ‘Download All’ which gives you a big PDF and a table of contents.



The menus are all displaying but when I go to play a video (on a file server) it is like it is constantly buffering but I don’t see how it can be since it plays on a Pi which is slower and running the same video. I often get that but a reboot fixes it. But not anymore.

So are you saying I don’t need a microsd card in the Vero 4k?

Why do you think I’m not getting anything displayed? I’m setting it up on my monitor before moving it to the TV. But I get no display and the monitor says it has no signal.

I get a red power light. That goes out but I get nothing on the display.

No need at all.

Usually when this happens, it’s because a user has set a higher resolution than supported on the monitor / TV they’re switching to. Recently I had a user reporting no signal – but it’s because he’d set the resolution to 4K, but moved it to a bedroom TV which only supported 1080p.

I’d recommend the following (after re-reading your posts):

  • For the Vero where nothing plays, try and play something, and upload a log.

To get a better understanding of the problem you are experiencing we need more information from you. The best way to get this information is for you to upload logs that demonstrate your problem. You can learn more about how to submit a useful support request here.

Depending on the used skin you have to set the settings-level to standard or higher, in summary:

  • enable debug logging at settings->system->logging

  • reboot the OSMC device twice(!)

  • reproduce the issue

  • upload the log set (all configs and logs!) either using the Log Uploader method within the My OSMC menu in the GUI or the ssh method invoking command grab-logs -A

  • publish the provided URL from the log set upload, here

Thanks for your understanding. We hope that we can help you get up and running again shortly.

OSMC skin screenshot:

  • For the Vero where you don’t see anything, connect it to the display you used it on last where it was working. If no joy, use that micro SD card and follow instructions here: Reinstalling OSMC - Vero 4K - OSMC.



Hi Sam, I understand what you are saying about the resolution being set to high but this is the first time it has been powered on so I haven’t set anything. My monitor is 2560x1440. Does the Vero 4K not detect that?

In order to know what your Vero us and isn’t doing logs are needed. I suggest grab-logs -A, when the Vero is running but the screen is black.

Do you have another display you can quickly test it on to rule out an issue there?

I have got a web interface to display but I’m not sure what it is. It is not something I have seen before. I scanned my network to see if it was on the network. Clicking on it showed this interface. But I don’t have an option to change the default screen resolution.

In the interface I see a section on API keys. One of them is for Yourube. How to I use those?

Everyone always asks for logs but I have no idea how to find them.

There are very clear instructions that have been provided to you above, you must simply read them.

If you can’t see anything on screen, you’d need to login using SSH to get the logs. This is covered in the Wiki.

You may however just find it quicker to reinstall the OS.

There are very clear instructions that have been provided to you above, you must simply read them.

That was very rude. I did not see any instructions on accessing the logs until Sam said to use SSH. But then I don’t know how to use SSH.

Re-installing OSMC worked and I got output on the screen.

One of the reasons that I would like a PDF is that I am partially sighted so it is very difficult to read the wiki. With a PDF I can zoom in and search for things. I am totally aware that I have no idea what I am doing with OSMC. It appears to read the media but makes a complete mess of it which is why I just browse the files and play them that way. I am sure there is a way to fix this but I have no idea what it is.

There seems to be pre-determined classifications of media types but it is nothing like what I want but I have no idea how to fix it. For example, it seems to only have a concept of documentary and it puts all of my travel programmes in that group.

Have you done any YouTube videos? When I have searched for them in the past I’ve only found videos about watching illegal content.

Can anyone recommend any good YouTube videos on how to create a skin?

Kodi allows you to split videos in to Films and TV Shows, but no further classification than that. See

Kodi skinning is quite complex, and I’m not sure this is what you want to achieve


The reason that I wanted to investigate writing a skin is that none of them seem to cater for partial sighted people. What I really want is the ability to change the font size. Most of the screen is taken up with things I don’t need to see but the things I do want to read the font is too small.

I was just watching a programme I recorded and it had subtitles but I couldn’t read the subtitles.

With Kodi I often play a video just to find out what it is because I can’t read the name.

I tried the zoom option but I didn’t really understand what it was for. It made some things disappear from the screen. I expected it to just make the font bigger.

Can I just change a font file or something?

BTW, you are a VERY good support person.

@Chillbo, our skinner for the OSMC skin, might be able to advise regarding some options here


You should be able to control the font size of subtitles easily enough. I don’t have it in front of me, but it’s somewhere under Settings/Player/Language, I think.

Correct it is Settings - Player - Language.
@DLD-UK there you can change Position/Font/Size/Style/Color/Background Color/Opacity as required
Under Accessibility you also can choose which Audio Track to prefer.

Unfortunately, the Kodi skinning engine doesn’t cater for this case… Don’t sizes are fixed within each skin and can only be changed by basically resorting the skin. Changing them on-the-fly trivially is not possible, I’m afraid.

Are we talking about the same thing? I don’t know if I am missing something here, but if I understand it correctly, the subtitle options apply when you turn subtitles on and then all words spoken are displayed. Is that correct?

The programme I was watching was a recording filmed in Japan with an English person and some people talking in Japanese. The programme had displayed the English text of the Japanese people but had done ti too small for me to read.

I was using this just as an example of the issues I have with the Kodi skins. If I understand it correctly I could turn subtitles on and see all words but I don’t think there is anything I can do about the size of text the programme decided to use.

With Kodi I see loads of things on the screen that I do not want to see, but the things I do want to see are too small to read. It is not accessibility when playing a video that I want to adjust. It is accessibility of the user interface that I want to change.

For example, I find it easier to use file names and browse them than using the facilities in Kodi to access TV shows. The reason is that I think Kodi makes a complete mess of the metadata for the programs. The genres built into Kodi are far removed from how I want to classify programmes.

But when I go to file manager the text is too small for me to read. And yet most of the screen is empty. What I want is the ability to choose a font for these things.

It would be even better if Kodi allowed me to define the genres I want to use and the options I want to display. When I use NextPVR to record programmes it knows of loads of genres like Travel programmes, Lifestyle programmes etc. Kodi knows none of this.

At some point it is my intention to use Jellyfin as a backend server. I don’t know whether this is possible and whether it will help with the issues I have. At the moment the files are on a TrueNAS server so nothing is managing the metadata.

However, even if this works I still don’t see how I can fix the skin issues without developing a skin?

Before I became visually impaired I had no idea how difficult it is. Reading options on most TV screens is simply impossible.

I am not criticising Kodi. It is wonderful piece of software. But I have not found a skin that displays things as I would like. Is there a skin that allows me to choose the font size for filenames for example.

There are several different ways in which subtitles can be included in a video.

First, they can be “burned in” - that is, they are actually part of the picture. This kind can’t be turned on and off, because as far as Kodi is concerned it’s all just picture - there’s no version that doesn’t have the text in it.

Then there are image-based subtitle formats - these are what you get from a direct remux of a DVD or blu ray. These are an image that can be overlayed on the picture, or not - i.e. they can be turned on and off. But you can’t control the font, because they’re stored as an image, not as text.

Finally, there are text-based subtitle formats. Video recorded from a TV broadcast often has subtitles in this format; so do streamed internet videos from (for example) YouTube or Netflix; and you can often download text subtitles from providers like as a separate file that can sit next to the video file. Kodi can display these in different fonts, and you can also control the colour and the font size, and various other things about them, including where they appear on the screen.

So, if you’ve got subtitles in text format, you can control the font size, and the setting that controls that is the one I pointed you to before.

1 Like