Not updating, B+ stuck 8-1-2015

I seem to be having a problem updating.

Every day I come home from work to find updates ready on both my Raspberry Pi B+. In the OSMC settings it says OSMC August 2015 2015.08-1

I tell it every day to update, it tells me it needs to reboot, I tell it to, it restarts without any errors. If I recheck for updates immediately it tells me there are updates again…ad nauseum.

Any ideas?

I dont know linux very well but I can access SSH with Putty and run commands, I just dont know what to do at this point. Id love to take advantage of the updates since Aug 1

Thanks!

Please enable debug mode in Kodi then try to reproduce the problem.

Once you have reproduced it use the log uploader in My OSMC to upload all logs.

At the moment it says there are no updates available when I manually check. But I can almost guarantee after its auto update, it will again. I have set it for auto update in 10 minutes and will post back the results right away. Thanks for the prompt response.

The version at the bottom, that says 8-1-2015, is accurate? Or is there another place to see what the current version is?

Kodi System Info Summary says:

Open Source Media Center running kodi 15.1 (compiled aug 30 2015)
Operating System: Open Source Media Center 2015.08-1 (Kernel: linux 4.1.5-1-osmc)

So is it updated to Aug 30 or Aug 1? It looks like Kodi has updated by OSMC hasnt for August?

Will post logs in a few minutes.

Well, it auto checked at 8pm local time, and found nothing.

I will do this again tomorrow afternoon with debug logging enabled and upload. It has happened almost every day for 2 weeks or more so I cant imagine that its “fixed” all of a sudden.

Thanks again, Ill check in tomorrow evening.

Looks like you’re up to date. If you would like us to take a look, please upload some logs

Sam

https://discourse.osmc.tv/t/how-to-obtain-provide-necessary-info-for-a-useful-support-request-includes-current-versions/5507

It looks like the old log gets deleted when you reboot?

Last night I set it to check for updates at midnight, it did, and when I got up this morning, it said there was an update, “downloaded it” and needed a reboot. I rebooted, and uploaded the logs. I guess I should have uploaded the logs before rebooting?

Heres what I uploaded.

http://xbmclogs.com/puj2c3myy

If I need to upload from after the “update” but before the reboot, please advise and I will next time.

Thanks again for your help!

A Kodi log alone is not sufficient for debugging this issue. Please follow the linked instructions for enabling debug and using the MyOSMC log uploader to provide all logs after creating the problematic issue.

Sorry, my mistake.

Device: RPi b+
Installation media: SDcard
Connection: Wired
Power Supply Type: The one that came with the Canakit from amazon
Power specs:
Peripherals: WD 1.8 TB USB hard drive, independently powered.
Storage Device (incl. Network Sharing Protocol): USB drive SMB
OSMC version: 2015.8-01
XBMC version: 15.1
Codecs: Bought all the extra licenses
Audio/Video Output: HDMI
Overclocked: No
Config.txt Extras: Not sure?

Requested logs: Got an error uploading, http://paste.osmc.io/{“message”:"document exceeds maximum length

Gonna try again from a fresh boot -> issue -> upload

Yeah, apparently there was too much log there for the paste

Well I cant get it to have this issue if I manually check for updates, and it hasn’t done it again on automatic checks (obviously, as soon as you take the car to the mechanic it stops making that sound). When it happens again I will update here.