Nov Update OSMC display washed ou

Raspberry PI 4

After the update completed last week, the entire interface including picture viewing is washed out. It looks like the contrast and brightness is turned up. Video playback is fine. Once I start a video, the interface looks fine again. Until the next restart.

I was hoping someone else had seen this and had a suggestion…

Thanks in advance

To get a better understanding of the problem you are experiencing we need more information from you. The best way to get this information is for you to upload logs that demonstrate your problem. You can learn more about how to submit a useful support request here.

Depending on the used skin you have to set the settings-level to standard or higher, in summary:

  • enable debug logging at settings->system->logging

  • reboot the OSMC device twice(!)

  • reproduce the issue

  • upload the log set (all configs and logs!) either using the Log Uploader method within the My OSMC menu in the GUI or the ssh method invoking command grab-logs -A

  • publish the provided URL from the log set upload, here

Thanks for your understanding. We hope that we can help you get up and running again shortly.

OSMC skin screenshot:


Nothing sticks out in your config files.
Have you tried to change resolution to see if that makes a change?
Also you write Skin and Pictures, you mean Pictures under “Pictures” or you main artwork for movies?
Have you tried to change skins if that makes a difference?

yes… Reset, changed skins, etc. This occurred on first boot after the upgrade/update and has been consistent since. My next plan is to collect a bunch of test videos of bit rate, type, and see if they all change the interface back to normal or, if not, which do/don’t…

Thanks for the help…

Scrubbed and reloaded… All fixed…

Hooligan, I am having the same problem with the washed out display. Could you explain what was scrubbed, and how? And, what specifically was reloaded.
Thanks for the assistance

I don’t know what Hooligan did to fix his problem, but probably you can just re-set the gui settings. The easy way to do this would be to SSH into the Pi and run these commands:

sudo systemctl stop mediacenter
mv ~/.kodi/userdata/guisettings.xml ~/.kodi/userdata/
sudo systemctl start mediacenter

This will just reset all of the gui settings to Kodi defaults (a new guisettings.xml will be created when Kodi starts). None of you other settings (like anything you may have in advancedsettings.xml or your sources.xml)

Unfortunately, I gave up trying to fix it… I re-downloaded OSMC and resetup… All good afterwards so as bmillham says, there is probably a setting somewhere. I used the GUI to try and fix it but didn’t seem to have any luck… In the end, I stopped looking and bailed :frowning:

bmillham, thanks for the suggestion to reset the gui settings, but it did not resolve my issue.
Hooligan, thanks for the additional details. I will probably try a few more things before I re-install. I will update this topic if I find another resolution.

I was having this along with a snowflakes effect, which I assume came from the Embruary skin I’m using. Could it be your seeing half a ‘seasonal effect’

Reinstalling the latest OSMC package did not help for me. So, after spending a great deal of time trying different HDMI settings, I realized that I was using the Raspberry PI 4’s 2nd HDMI port (HDMI #1). Once I moved the cable to the 1st port (HDMI #0), everything was working fine. Not such why it started being an issue with the November update, but regardless, it is resolved now.


I’m having problems with my Pi4. Can you post your config and config-user files please? I posted here on the forum, can’t get image after splash…

Since your issue with not getting an image after splash is probably unrelated to the Washed out display, you will probably do better to open up a new post. However, I am including the information requested here.
---- config.txt ----

’ # Warning: do not edit this file, or it could prevent your OSMC system from starting.
’ # If you wish to make changes, you should do so via My OSMC or edit the config-user.txt file in this directory

’ # Any changes that you make here will be overwritten as this file is managed by the OSMC via the update system


include config-user.txt


---- config-user.txt ----