Offered an update and fails with (unknown package)

Raspberry Pi 3 using previously downloaded osmc.

On update, after about 10 minutes, I receive a ‘unknown package’ message. A pity it doesn’t give us the package/s name/s.

On reboot, it then ask’s me to report. So here goes…


Link deleted.

I’m blowing it away and starting over.

Your apt.log looks clean. Therefore my best guess is that the error being caused by the unsupported Kodi Repository interfering.

Which repository ???

One of the unsupported/banned repositories that can not be discussed on this forum.

To get a better idea of our piracy policy, please see this link here FAQ - OSMC Forums

OK - As I was new to OSMC, I added a bunch of repo’s.

I don’t want unsupported/banned repo’s.

Can you PM me so i know which one’s to remove/uninstall.


ADD: Is there a list of ‘approved’ repo’s. So newbies don’t fall into the trap of installing suspect repo’s ?

My addons are now down to 6 repo’s.

I don’t want to post the new list in case There is a ‘bad’ one still there.

I tried to uninstall one of the remaining, and it say’s GlobeTVresolver is being used, but I can’t find that using the search feature.

At the moment, I am considering blowing it away and starting over as I don’t know which of my remaining repositorys are good, or bad.

Well there is no whitelist but at least Kodi has published a blacklist

Thanks again fzinken.

I’m blowing it away and starting over.

Check for updates again and it will work. Just means you had a download issue when fetching the update.

Hi Sam.

I tried a few times over a 3-week period, with the same failure message.

I uninstalled most of the addon repositories, except Six and it then updated successfully.

But I decided to startover with a clean install and be more careful about adding repositories.