Only PCM no True-HD after reinstall of OSMC

I had some trouble with stuttering when streming UHD movies, so I did a reset (reinstall) of the OSMC.
Now the audio shows PCM instead of True_HD when playing movies. My receiver is a Marantz SR 7011, and the Vero 4k is connected to the mediaplayer HDMI with a supra HDMI cable.
Before the reset it showed True-HD

Configure the pass-through on Kodi audio settings.

I have done my best :slight_smile:

Here is the log.

As there are no further options visible under passthrough, the problem is probably the “sync playback to display” setting under settings/player/videos.

Please have a look there and disable that setting. Passthrough will only work with the setting disabled… :+1:t2:

BTW: The audio stream information in your first screenshot is just giving you a hint to which audio stream of the current video file is played. That doesn’t say anything about whether passthrough is turned on or off :wink:

It`s already unchecked. Trier to check it, play a bit and unchecheck. But still the same.

Change settings to Expert and re-visit the passthrough options. You probably haven’t enabled all formats.


Ahh… what a noob mistake :smiley:

Of course that’s it, totally forgot. Will do and test when I get home, but I’m sure thats it.


1 Like

It worked, thanks again :slight_smile:
However, sometimes, very often, there is no sound at all. then I have to go to settings and turn passthrough off/on, and then sound works again. It’s not convenient for the rest of the family members :slight_smile:


I’d appreciate it if you could test this and provide feedback before we potentially release this as an update to other users. To test this update:

  1. Login via the command line
  2. Edit the file /etc/apt/sources.list
  3. Add the following line: deb stretch-devel main
  4. Run the following commands to update: sudo apt-get update && sudo apt-get dist-upgrade && reboot
  5. Your system should have have received the update.

Please see if the issue is resolved.

I also recommend you edit /etc/apt/sources.list again and remove the line that you added after updating. This will return you to the normal update channel.

It did not solve the problem, still no sound.

I have uploaded the log

Found a solution. In settings-system-audio I set Output Configuration to Best match, then I get Dolby True HD and DTS HD Matser :slight_smile:
It also passed the John Wick test, full 4K and True-HD

Thanks for all the replies and help :slight_smile:


What was your setting before you changed it to best match?

Best match is recommended by us and should be used in most scenarios. Especially optimized is very problematic in our experience.

I Tried all three, but Started out With optimized, which gave me no Sound. Then read a thread suggesting fixed, then I had PCM output.