Opening NFS playlist makes OSMC crash


First time writer here, but long time user of OSMC.
After the latest update my OSMC crashes with a very unhappy smily, every time I open a playlist. The share is working fine - and I can play and access the files through the Video menu.
I use the playlists to split the kids movies from ours, so its kinda big feature for us.

I have tried to delete and recreate the playlists, but with the same result.

Have anybody else have similar issues with the playlists?

I have uploaded all logs to here:

And thanks to the OSMC team for a great product!!


14:38:38 54793.648438 T:2631394336  NOTICE: Thread JobWorker start, auto delete: true
14:47:15 55310.546875 T:2833986592   ERROR: SQL: The database disk image is malformed
                                            Query: select * from movie_view  WHERE ((movie_view.playCount IS NULL OR movie_view.playCount < 1))

Your database appears to be corrupted.

1 Like

Hi Sam,

Thanks for the quick response!

Whats the recommened action then?
Remove shares, and start again?



You can delete the .db and just re-scrape. It’s location is /home/osmc/.kodi/userdata/Databases/MyVideos##
or very similar, sorry, not in front of a terminal at the moment.

Excellent - worked perfect.

Thanks for the great support :smile:


1 Like