Openvpn no internet after restart Raspberry

Hi, After following a tutorial creating an openvpn server within Osmc installed on my rapspberry p3
i have established an connection from the rpi server to the client (Android). I can acces the internet in contact within the server, but when i did restart Osmc because of an update and so on after install fail2ban, the internet onnection to the androïd device failed.

Ive hearth about iptables-persistent and just installed the package and excute, the same issue happend, no internet. Then i did iptables-save > /etc/iptables/rules.v4 , iptables-restore < /etc/iptables/rules.v4 it became the same.

Is there something further? kind regards.

How are you determining that you have no internet? If you are relying on the connection details in MyOSMC then you will not always get a real answer there.

How were you able to install iptables-persistent without internet?

Which tutorial did you follow to install OpenVPN and what exactly are you trying to achieve? Are you trying to set up a VPN end point that you can connect back to from outside or are you trying to connect to a commercial VPN service?

Situation: installed openvpn from the playstore at the android device, copied ciënt.opvn, key, ca with sftp to a dir on my androud device. Boot up opnvpn, imported the mentioned files and the app connected as cliënt succesful. So when i started up Firefox i can surfing the internet, but when i restart
the rpi and wanne go through the internet, there’s no connection anymore.
When i finished the build of the openvpn server with
i thought this guide is worth it, i followed every step ad showned. Ufw enabled as explained,opend
up the right ports, porforward 1194 into the modem.
Ive installed iptables persistent and gave me the opurtunity saving the existing ufw rules.
When i reboot the rpi and wanne restore the ufw rules theres still no internet connection.

That’s because OpenVPN doesn’t restart correctly at boot time under systemd (and OSMC uses systemd).

You need to do the following:

sudo nano /etc/rc.local

and insert the following 2 lines just above where it says exit 0

sleep 10
systemctl restart openvpn

That should make it load up every time you boot up.

Woow, thank you so much in advanced, after format the whole sd and reinstall Osmc and so on openvpn, i put in your gaven details into /etc/rc.local and and after an osmc rpi reboot everything works fine.
I do have internet within the android device.

Sleep 10 means 10 seconds wait from the rpi before everything has loaded?

Repeat, thx.

1 Like