Hi guys,

I got a new openvpn server at my remote location and tried to connect to it from V4K. Unfortunately it fails with the error bellow.

I am using a single client configuration file .ovpn which was automatically generated by the server. Certificates and keys are embedded in the .ovpn file.

I use same .ovpn file on my iPad and iPhone, and both connect to the server without problems.
However it doesn’t work on the V4K.

Previously I was using openvpn on V4K without issues to connect to another server.
I am wondering if due the openvpn integration in osmc, some configuration files are copied to another location and they generate conflict with the new configuration files?


RTNETLINK answers: File exists ERROR: Linux route add command failed
: external program exited with error status: 2

It is probably a result of a routing command being pushed from your VPN server.

There should have been a change to the Vero4K kernel in the latest (January) update that added support for multiple route tables, which might have helped. Unfortunately, it doesn’t seem to have made it into the build.

Even on the latest version, adding a separate routing table gives a similar message: RTNETLINK answers: File exists.

I don’t have a choice in changing server configuration, and is working with all other devices, that means is something going on on the V4K side.

Openvpn was also working okay with the previous server.

I am not a specialist, but if the IP tables got stuck with the previous configuration, is there a way to reset them ?

You didn’t provide logs so I’m just guessing as to the cause of your problem. You might require multiple IP tables support in the kernel or the problem might lie elsewhere.

You can learn more about how to submit a useful support request here.

Solved by having to fresh reinstall OSMC.
Not happy!