OSMC 20161031 not working on Raspberry Pi 2

Hello, I’m having issues with OSMC 20161031 on my Raspberry Pi 2 - after the update to this version it will just not start - no screen, no error, no nothing, all black. I tried also reformatting my SD card with the ISO from scratch but only with the same result.

1 Like

Can you still access it via ssh?

Indicates your SD card is broken did you try another one?

Also as always is your power supply still strong enough for OSMC? What are the green/red LED on the Pi2 show?

I have some new information on my issue - I tried to plug video output to my monitor instead of my TV and at least now I see an error message for a few seconds till it restarts again. It states this:
"Waiting for root filesystem device /dev/mcblk0p2
/dev/mcblk0p2 : recovering journal"d above

I wrote the image of OSMC with Win32DiskImager on my SD card and booted in on Raspberry. The installation process went as usual, ended successful and then I started getting the weird error about filesystem stated above.

I tried also another SD card, still the same thing,

Thanks for any help

One more interesting information - with release 2016.09-1 (OSMC_TGT_rbp1_20161003.img.gz) everything works just fine.

This suggests either:

  • a faulty card
  • a bad backup

If the release works fine, the backup may be bad.


Hello, thanks for your answer. What backup have you on mind? I downloaded an official ISO image and wrote it on my SD card (in fact I tried two different cards with the same resullt). It looks like some bug in the new release for me as the previous build works pretty well.

My mistake: I thought you said that restoring a backup did not work, but installing a fresh version did. But it seems you have some potential hardware problem and I’d suggest you check your PSU and SD card.


This sounds like you have a Raspberry Pi 1 rather than a Raspberry Pi 2. First you need to know exactly what you have and then we can work from there.

I’m sorry, I stated the wrong name of file - I meant this one: http://download.osmc.tv/installers/diskimages/OSMC_TGT_rbp2_20161004.img.gz

I definitely have RPI2.

I’m having exactly the same issue on my recently updated RPi2B. Same boot loop, but only after updating to 2016.10-1 - like the OP said 2016.9-1 works flawlessly as well as the previous version I was using from July.

I too, will try another mSD card to rule that out, however it seems strange. I just wanted the poster to know he’s not the only one.

In my case - config.xml became empty after upgrade. You can fix it even under windows by coping proper file into boot (vfat) partition on SD card

gus, thank you for the information. Can you please help me locating config.xml?

Sorry for typo, it was “config.txt” in main directory of boot (vfat) partition

I upgraded OSMC and then looked at boot partition - config.txt was fine, not empty, in fact it looked the same as with the older image. But I could not load OSMC.

Without some kind of logs or other system info, I’m not sure how we can help. Does it still boot when connected to your monitor?

it starts booting, outputs this:
"Waiting for root filesystem device /dev/mcblk0p2
/dev/mcblk0p2 : recovering journal"d above
and then reboots

That’s all I have at the moment.

It sounds like you have corruption of the 2nd partition. You should insert the card into another linux system and fsck it to repair.

I’m having the exact same problem. I recently reformatted the SD card and reinstalled the december release using the Windows installer (as well as trying Win32diskimager and dd). On first boot, the installer runs and I get the installation complete message, but then it just gets into a constant reboot loop where it displays
waiting for root filesystem device /dev/mmcblk0p2
mmcblk0p2: recovering journal
mmcblk0p2: clean, 23969/932064 files, 235199/3727104 blocks
I’ve tried running fsck in linux and it displays the same message (running with -f gives me a number of orphaned inodes which I can fix, but on boot it still displays the same message). I have run badblock on the sd card without a single error and tried a brand new sd card, so don’t think it is the actual sd card, but I don’t know where else to check. Any suggestions for where to look or things to try would be appreciated.

Try a different sdcard.