OSMC 2017.10-1 and 2017.08-1 wont boot

Hi There,

I’ve been trying to install OSMC on a freshly new RPi3 Model B 1GB, using a Sandisk SDHC 16GB.

I’ve tried versions:

Installed both with MacOS installer and dd (with bs=64k, bs=512k, bs=1m)

Raspberry will blink 4 times (last blink is longer) but nothing shows on the TV, I’ve waited for more than 15m.
Nothing happens, I’ve checked the sd afterwards:
2017.10-1, boot partition untouched
2017.08-1, boot partition has files different from the “fresh-install” however won’t start
I’ve tried libreelec, openelec and OSMC 2017.07-1 they all work out of the box.

What the heck am I missing?

Thank you

just an update,

with 2017.07-1 ethernet does not work (is working with libreelec and openelec), wireless gets disconnected very frequently…

Sounds like a power supply issue

Your power supply probably isn’t up to scratch. You can learn more on our Wiki here: Frequently Asked Questions - Raspberry Pi - OSMC

2.5A (2.4A ~ 2.6A tested), 5V ( 5.1v ~ 5.3v tested)

LibreElec works out of the box fully tested,

OpenElec works out of the box fully tested.

2017.07-1 works with dist-upgrade from command line, system is now upgraded.

Ethernet still not working

Not sure then. I think the images are functional or we’d have received other complaints. It seems odd that your system doesn’t boot on two OSMC images.

When you say it doesn’t boot – do you see the installer come up?

If the system isn’t being installed correctly or it’s corrupted then you could have some problems. Unfortunately without more information it’s hard to speculate. Some logs (on SD card) will provide clues.

I know it sounds odd, that’s why I am here :slight_smile:

I’m from the RTFM generation, I thought it may have been wrong config.txt, however not even the installer comes up.

I’ve done extensive tests on the other distributions, not a single hicap.

I don’t understand how can a old version work and the newest doesn’t.

I thought about the sd installation procedure, but if I did something wrong it wouldn’t work with other distributions.

i thought about pal and ntsc issue, but my lg tv supports both.

I’ll investigate the Ethernet issue tomorrow, is 1am in Australia, kinda tired.

Will keep you updated, if anybody has more suggestions I’ll appreciate.

There is anyway to know if the installation is working even if hdmi output is not present?

should I consider the blinking (4 times with the fourth longer), if I did read the specs right should mean unable to load loader.bin. if so why the heck does it work with a 3 versions old release.

What log do you need? just boot? kern? not a fun of systemd so if you can tell me what command I’ll pastbin the results.


grab-logs -A if you don’t have network connection than you can use grab-logs -A -C than the logs will be copied to SD Card and you can upload from PC

Just as a double check, if you dd the 2017.10-1 image (make sure it’s the correct file name: OSMC_TGT_rbp2_20171102.img.gz) to an SD card, you can check if it’s been written correctly by running the command:

sudo cat /dev/<partition> | md5sum

where <partition> is the newly-created FAT32 partition on the card. (I’m assuming that MacOS isn’t too different from other *nixes.) For the 2017.10-1 image, I’m seeing an md5 value of 4172ad523b19d9d5719d090ee0f342b7 before I mount the partition. Once you mount it and list files, etc, that value will change.

Hi All,
I know that this thread is almost 14 days old, but I’m having same issues, with 2017-10 build, the installer shows that the image is burned correctly, but there is only 1 partition (255Mb).
I installed previous builds without issue, but now it’s strange that the image is not booting.

I’m trying now with 2017-07 build. I will update once the installer ends.

As mentioned in the previous post, if you have an operating system that runs the dd command, you can verify that the partition has been correctly written. And, yes, initially it should be around 255 MB.

Hey Man,

I can confirm the behavior.

I’ve 3 Raspberry pi 3, the oldest works out of the box. the other two don’t boot, but I can upgrade them and everything works.

I’m getting different sdcards. I got to believe is some sort of incompatibility between RPi3 and the SDCard, what is the exact model of your card?

What is your RPi3 serial? How long ago have you bought it?

Sorry to ask these questions but if there is some kind of issue may be worth let the community know.


I didn’t reply, sorry.

Yes it is exactly the same md5.

I’m willing to do more tests if needed,


When it boots everything is ok.

Once updated using command line the wireless worked.

No way to get logs on the boot when failed. still trying to retrieve them. but my best guess is that the system hangs during first boot.

In my case I can definitely exclude issues with the dd procedure.

downloaded images have right md5.

As you can imagine, I checked the MD5 of the image and then ensured that it booted up successfully.

It does look like it might be a card issue. As an example, if the card is misreporting its size, as fake cards often do, the creation of the second (root) partition will fail and files will not be copied over.

I always buy original sandisk.

The card I’ve got are al 32GB class 10.

I’ve got little time now to thinker :frowning: