OSMC 4alpha with hifiberry

Hi,

i dont own linux or skills to operate linux… but i would love to update my OSMC alpha 4 or do something to enable hifiberry digi+.

Can someone please help me with that ?

Thank you all very much.
neyoneit

I would suggest that you use the Release Candidate.
https://osmc.tv/download/

downloading, instaling and will let you all know as soon as i finish.

still doesnt work… any other suggestions :frowning: ?

Yes, looking on the HiFiBerry website…

https://www.hifiberry.com/guides/supportedsoftware/

i have found on forum that osmc has cmd line…
EXIT >> esc-key
user:pass
osmc:osmc

so i need to put all line in here, right ? ill try that

or you could use putty and ssh in from your pc.

after ssh -l pi 192.168.10.46
it wants password, and i was hoping it would be osmc but its not and i cannot figure out what password it actualy wants :confused:

login as: osmc
OSMC: Open Source Media Center
osmc@192.168.10.46’s password:

The programs included with the Debian GNU/Linux system are free software;
the exact distribution terms for each program are described in the
individual files in /usr/share/doc/*/copyright.

Debian GNU/Linux comes with ABSOLUTELY NO WARRANTY, to the extent
permitted by applicable law.
Last login: Wed Mar 18 19:10:54 2015
osmc@osmc:~$ ssh -l pi 192.168.10.46
OSMC: Open Source Media Center
pi@192.168.10.46’s password:
Permission denied, please try again.

no.

run putty.
enter the ip address
hit enter
user:- osmc
password:- osmc
sudo apt-get -y update && sudo apt-get -y upgrade
sudo apt-get install -y curl wget binutils alsa-utils
sudo reboot

run putty.
enter the ip address
hit enter
user:- osmc
password:- osmc
sudo bash
cat >/etc/modules <<EOT
snd_soc_hifiberry_dacplus
EOT
reboot

run putty.
enter the ip address
hit enter
user:- osmc
password:- osmc
aplay -l
card 0: sndrpihifiberry [snd_rpi_hifiberry_dacplus], device 0: HiFiBerry DAC+ HiFi pcm512x-hifi-0
Subdevices: 0/1
Subdevice #0: subdevice #0

1 Like

oh my god i am so dumb… i should put the ssh -l etc :frowning: really sorry guys i really apologize for my lack of knowledge here :frowning: i finally got it thanks to you cansa - thank you very very much !!!

What you were doing is ssh-ing back into the same box that you were in.

I’ll let it slide just this once, don’t let it happen again :wink:

seems i have one last problem…

osmc@osmc:~$ sudo bash
root@osmc:/home/osmc# cat >/etc/modules <snd_soc_hifiberry_digi
bash: snd_soc_hifiberry_digi: No such file or directory
root@osmc:/home/osmc# cat >/etc/modules <snd_soc_hifiberry_dacplus
bash: snd_soc_hifiberry_dacplus: No such file or directory

i did try to change dacplus to digi like they have on website, but its not working :frowning: or most likely i did something wrong again, BUT everything went exactly as it should i believe… text was popping when i did the first part…

EDIT:
wanted to check folder if it actualy has these files, but i dont know how to properly use cmd cat /etc/modules :frowning:
can someone please try to help me ? - i am just user of osmc to watch movies i never done or used this kind of comands or even comand line :frowning: i just bought hifiberry to have better sound quality and enjoy it and now i feel totaly lost

Hi Neyoneit,

Are you sure that you need to be doing any of this. In Alpha 4 and RC my hifiberry-digi on a standard Pi B just works. All that you need to do is a) enable it in: My OSMC, Pi Settings b) reboot, c) Select it in Settings, System Audio Output.

Hope that is helpful

Dave

1 Like

it works finally works.
It was faulty hifiberry :slight_smile:

OSMC RC works just fine with hifiberry digi/dac
just follow these simple instructions:

All that you need to do is a) enable it in: My OSMC, Pi Settings b) reboot, c) Select it in Settings, System Audio Output.

BIG THANKS TO YOU ALL and biggest thanks to DaveP who wrote this simple advice :smile:

This topic can be marked as SOLVED !!

neyoneit,

I cannot think of anything obvious that you might have missed. But you may want to consider the following:

  • If you edited any changes into the configuration files then you may
    need to remove those.

  • I assume that you are getting sound through your TV with output set to HDMI

  • Is the hifiberry card new and untested by you or was it working on a
    previous xbmc configuration. Can you see light from its optical
    output.

  • Can you see from your DAC whether it is receiving a signal
    irrespective of whether there is any sound on it.

  • You might want to do a full re-install of the RC, just to be sure everything is clean.

Beyond that I can only suggest that you go back to the command line to see whether you can get sound out of it with aplay.

Sorry but that is all I can think of at the moment. Do persist though as the final configuration performs really well and will be worth the effort.

Dave

it works finally works.
It was faulty hifiberry smile

OSMC RC works just fine with hifiberry digi/dac
just follow these simple instructions:

All that you need to do is a) enable it in: My OSMC, Pi Settings b) reboot, c) Select it in Settings, System Audio Output.

BIG THANKS TO YOU ALL and biggest thanks to DaveP who wrote this simple advice smile

This topic can be marked as SOLVED !!