OSMC Alpha 4 RPI2 with two USB tuners (DVB-T, DVBS-2)


I’ve just swapped an RPI-B running RaspBMC with a brand new RPI-2 OSMC Alpha 4.
Looking great!

I have a second RPi running TVHeadend with 2 USB tuners.
So I just enabled LiveTV on OSMC, and entered the IP address of my second RPi.

That also seems to work well so far (i.e. streaming from the TVheadend server
to the OSMC RPI-2)

My question:
Does OSMC Alpha4 contain TVHeadend server? Can I just take out the two USB
tuners and plug them into my RPi-2, i.e. just use one RPI-2 for everything…?

I originally started with one RPi and Raspbmc, but it couldn’t handle two
tuners, so that’s why I moved TVHeadend to a separate server (another RPi running Raspbian).


OSMC comes with TVHeadend (installable via Application Store)

The new quad core Pi’s ARM chip is capable, but the USB bus may be the limiting factor here

Thanks Sam.

I tried installing TVHeadend using the app-store method, but TVheadend came up with unknown version
So, I’ve installed TVHeadEnd according to this one (which worked fine for me before):
tvheadend install on rasbian

Looks ok, but my ITE9135 DVB-T USB Tuner isn’t properly recognised.
Seems to convert it to Afatech AF9033

Though, I copied across the original working firmware file from my working Tvheadend RaspPi (Raspbian).

Dmesg on OSMC (tuner not working properly)
3.871986] usb 1-1.2: dvb_usb_af9035: prechip_version=83 chip_version=02 chip_type=9135
[ 3.872432] usb 1-1.2: dvb_usb_v2: found a ‘ITE 9135(9006) Generic’ in cold state
[ 3.877275] usb 1-1.2: dvb_usb_v2: downloading firmware from file ‘dvb-usb-it9135-02.fw’
[ 3.948265] FAT-fs (mmcblk0p1): Volume was not properly unmounted. Some data may be corrupt. Please run fsck.
[ 4.009777] usb 1-1.2: dvb_usb_af9035: firmware version=
[ 4.009832] usb 1-1.2: dvb_usb_v2: found a ‘ITE 9135(9006) Generic’ in warm state
[ 4.011472] usb 1-1.2: dvb_usb_af9035: [0] overriding tuner from 00 to 60
[ 4.014123] usb 1-1.2: dvb_usb_v2: will pass the complete MPEG2 transport stream to the software demuxer
[ 4.014303] DVB: registering new adapter (ITE 9135(9006) Generic)
[ 4.048715] af9033 2-0038: firmware version: LINK - OFDM
[ 4.048753] af9033 2-0038: Afatech AF9033 successfully attached
[ 4.048825] usb 1-1.2: DVB: registering adapter 0 frontend 0 (Afatech AF9033 (DVB-T))…
[ 4.069691] it913x 2-001c: ITE IT913X BX successfully attached
[ 4.136852] Registered IR keymap rc-it913x-v1
[ 4.137510] input: ITE 9135(9006) Generic as /devices/platform/bcm2708_usb/usb1/1-1/1-1.2/rc/rc0/input1
[ 4.137550] rc0: ITE 9135(9006) Generic as /devices/platform/bcm2708_usb/usb1/1-1/1-1.2/rc/rc0
[ 4.137581] usb 1-1.2: dvb_usb_v2: ‘ITE 9135(9006) Generic’ successfully initialized and connected
[ 4.137777] usbcore: registered new interface driver dvb_usb_af9035

Dmesg (on working TVHeadend/Raspbian)
7.687333] it913x: Chip Version=02 Chip Type=9135
[ 7.769453] it913x: Firmware Version 52887808it913x: Remote HID mode NOT SUPPORTED
[ 7.921785] it913x: Dual mode=0 Tuner Type=0it913x: Unknown tuner ID applying default 0x60
[ 8.066661] usb 1-1.3.1: dvb_usb_v2: found a ‘ITE 9135(9006) Generic’ in warm state
[ 8.171180] sda: sda1
[ 8.181508] sd 0:0:0:0: [sda] No Caching mode page found
[ 8.196486] sd 0:0:0:0: [sda] Assuming drive cache: write through
[ 8.204375] sd 0:0:0:0: [sda] Attached SCSI disk
[ 8.268844] usb 1-1.3.1: dvb_usb_v2: will pass the complete MPEG2 transport stream to the software demuxer
[ 8.394609] DVB: registering new adapter (ITE 9135(9006) Generic)
[ 8.504361] it913x-fe: ADF table value :00
[ 8.538540] it913x-fe: Crystal Frequency :12000000 Adc Frequency :20250000 ADC X2: 01
[ 8.738408] it913x-fe: Tuner LNA type :60

I’ve tried several versions of ITE9135-02 firmware, but still the same.
The tuner appears to work, i.e. I can create MUX, add services,
define channels, etc.

But when I watch a channel, there are many errors even though the
signal is 100%

Is there something in the new OSMC Kernel that doesn’t agree with
the ITE-9135-02 TV Tuner?

I also have SundTek DVB-S2 … that’s not working properly either.

Best regards,

Hi @anbodearg,

I have a PI2 with a KWorld UB435-Q USB ATSC TV Tuner Stick, and it too was recognized as another brand by Tvheadend. I think the chips used in those tuners are getting more and more generic, and so as long as it works, the name is not quite important :wink:

If by getting “many errors” you mean bad pixelation and choppy sound, then I can confirm that I got that, too, even on channels I can receive flawlessly using the same tuner in Windows.

I have one channel that is not HD, and that one got good image and sound (though not in HD of course), so that led me to believe it might have to do with bandwidth.

Maybe that has got to do with Sam’s comment on USB bus limitations on the Pi 2 ?

…or is there a better suited version of tvheadend somewhere for the Pi 2 running OSMC ?




Actually I have both tuners working now…!
Not entirely sure what was wrong before - I did a few remove/uninstall/re-installs.

I also connected both USB tuners into a powered USB hub.
(not sure if they would have been ok powered directly by RPI2 usb)

So far so good.
Two USB tuners - including some HD channels.

I’m currently watching BBC News (SD) live on my iPhone.
Using VLC on the iPhone to TVHeadend on my OSMC (RPI2).
Some HD channels working ok too on my iPhone.
(it’s not perfect, sometimes a bit of stutter).

Watching ‘top’ on my RPI2, the CPU doesn’t seem to go over
around 30percent (combined top three processes).

I plan to try this config at home over the next week or so …
So I will report back if one RPI2 with OSMC can comfortably support
two USB tuners.

Best regards,

Congrats on this unexpected (?) success :smile:

So, would you blame the USB powered hub (or lack thereof) for the initially disappointing results ?

…because I also happen to not have a powered hub on my PI2 at the moment (but I have a 2.5A supply, so I figured that might be sufficient).

I will definitely try with a hub, if you think that might be the culprit :wink:

Sort of right here. Vendor ID and PID in the kernel still count, but patching that in from dmesg output is very easy

The best performing one will be the one we ship in our App Store.

Sounds like throughput problems

Will fix 0.0.0 issue with TVHeadend version shortly

Thanks Sam,

I actually wonder how many clones of you there are around, so that you can take the time to reply to so many forum posts while managing this great project that OSMC is :slight_smile: .Your outstanding job is much appreciated !

Now with my stupid question: Can one install the tvheadend backend from the main OSMC interface ? In the addons section, I only saw what seemed to me like the frontend side… (Or maybe the term “app store” broadly refers to manually-downloaded *-app-osmc packages ?) Sorry if I missed something here…

You also mention:

…On what level exactly ? USB limitations of the PI / dongle, or something more remediable (network speed, powered hub,… ?)

Thanks in advance :yum:

We will have a GUI shortly to enumerate and install Application Store packages.

Possibly throughput limitations. I’d watch if /proc/interrupts climbs very high too.


ok so I’ve finally got OSMC RPI-2 with 2 USB Tuners TVHeadend.

it has taken me many hours … of install, delete, re-install, plug out,
reboot, plug-in, etc. etc. At one stage I had over 500 channels, and I think
that might have been causing problems. So, I’ve deleted all but around 15
channels which I actually need.

But once it’s all setup, it seems to work ok.
I don’t see any throughput issues, bottlenecks, etc.
The RPI2 isn’t struggling at all. Not yet, anyway.
it’s pretty cool to stream HD channel live to my iPhone.
(even with the odd stutter :smile:
But, I will see how it goes over the next week or so.

I like the possibility of having everything in one RPI.
It means a lot less clutter on the shelf behind my TV.
which is overflowing with bits and bobs.

however, my suspicion is that a more reliable setup would be to have
a dedicated TVH server (i.e. RPI2) with raspbian.
Vero also would be a good ‘one-box’ solution.

Jury is still out though. I’ll see how it behaves ‘in production’ over the next week.

Best regards,

ok, so I’ve had to abandon this one-RPI config.

OSMC + both tuners were working fine this evening.
Tried a couple of hours later, and couldn’t play any channel on the DVB-T tuner.
(channels were still ok on the DBV-S tuner)
TVH was reporting bad signal, no responder, etc.
Tried reboot, reset the tuner, reset TVH, etc, etc.
Eventually, had to revert back to split config (i.e. TVH on separate RPI running Raspbian).

Not sure what, but something is unstable with OSMC + TVH + 2 USB Tuners.
It’s possible to get it all working, and when it works it works well.
But then after a while something stops working. And it takes ages to get everything
working again.

I don’t think this is USB throughput issue, or power issue.
I think there’s something not right with Kernel + TVH + USB Tuners.

Sorry that’s a bit vague.
But after all the hassle, I’m thinking now that it’s good enough
to have a split RPI config when using TVH.

The new RPI2 with OSMC is really nice. Quick and smooth.

Maybe I’ll revisit this sometime again with a later version of OSMC,
in case thats where the issue is.

Best regards,