OSMC and Hyperion

#460

I had to use the installer made by hissing shark back in 2017. After it’s finished just go in and run the install script. You will have to configure using the old Java application and after you’re finished ssh in and add the framebuffer and amlogic to your json file in /etc/hyperion

I had to double check I didn’t have two installations of Hyperion, I can restart it with systemctl restart hyperion. If you want to have both builds (I still have not figured out a way to compile for amlogic on the 4k+, you have to run systemctl disable hyperion and just use the Java applet

0 Likes

#461

I think you may have installed Hyperion rather than Hyperion NG

0 Likes

#462

I´ve tried this installation guide from anthrax on vero4k+ and i am in stuck on the same error.
Floating Point Exception. Any advice??
Thanks

0 Likes

#463

I did, that is all I can get to compile right now. I actually had to use hissingsharks build for Hyperion NG and then run ./install.sh located in the folder. This is the only way to avoid that CPU error when installing classic. I have tried the fix many times with no result.

Sure do wish I could get that web configuration working.

0 Likes

#464

^^

Chaps,

I’m happy to renew investigations in to lag (with hopefully promising results now) if we can get an updated guide on how to build and run Hyperion.

S

3 Likes

#465

Looking forward to seeing Hyperion.ng on the appstore someday :slight_smile: I would be head over heels lol

0 Likes

#466

It will happen – but there are other things to happen before that. The current App Store needs an architectural rework hence the lack of progress.

Sam

2 Likes

#467

Is there a specific reason why the commenting/removing the lines in the cpu check does not work on my Vero 4k+?

I would like to remove everything related to Hyperion on my Vero and start from scratch.

In order for me to get hyperion to work now. I can either start the service via systemctl start hyperion which is using the /etc/hyperion/ config file that was created with my java applet. I can stop the service and decide to start it via the java applet. My problem lies in after sending over the config file from the Hyperion app, I then have to ssh in every time and add in amlogic and framebuffer to the config file and restart it again. I have it working on the menu as well as my videos without much issue. 100% of my video is just 1080p at most on my 4k TV so I don’t even bother, streams fine.

The only way I was able to actually install classic hyperion on my Vero was to install the old installer from hissing shark and go into /root/hyperion-vero4k/bin and and use the compile.sh. After that I was able to install hyperion via the java app and it works but not as I had hoped.

I still continue to try @Anthrax method but I get the same errors when trying to compile amlogic and frame buffer and it ultimately fails. I have tried the build feature on @hissingshark installer but I get numerous errors. I did install the preinstalled version with everything, albeit a new version it does work and gives me a different method to configure Hyperion but it is basically all the same. I have never been able to access the web configuration and ditch the java app but I have had zero luck. 2 fresh starts on the Vero 4k+ with the same results. They are three wire LEDs so I am utilizing #6 on my Arduino. Everything is physically is setup properly, at least to my knowledge.

I tried to switch over to the solder free corner and will be removing the this evening and soldering jumper wire in-between. The connection just isn’t right and I can tell when my whites start looking purple. Anyway, I got a little off topic there.

Is there just something I am missing regarding hyperion.ng install? I am reading up and down this forum and numerous people have gotten this to work. I just want to be able to try out the web based build. It looked so much better on my rPi using Dispmanx. I was still using the Arduino for some reason…I guess I could have avoided that. I did try moving some old parts from @hissingshark build with hyperion-aml into the failed build, that didn’t work because it seems to be outdated. For some reason that installer will let you build everything including amlogic without failures but if I try and create my own from the installer since it does clone from github, I just get errors. I can try and again and post them up if anyone wants to look at them.

I am using the latest FastLED on my Arduino as my sketch, recently updated yesterday. Not sure if this is part of the problem or not but I do have three or four rPi’s laying around.

I’m totally lost when it comes to fowarding Hyperion but before I purchased my Vero 4k+, I was able to successfully compile, build and use hyperion.ng rather than Classic. I just want to be able to do this with my Vero.

Any help is greatly appreciated. I think I have worked on this everyday since receiving my Vero 4k+. Thank you for taking the time to read this to whoever may be of some help :):thinking:

I can build without amlogic with any of the instruction pages scattered about, just doesn’t do me any good on the Vero with only framebuffer. Is there a way for someone who has had luck compiling it and manually adding it into my hyperion.ng build?

This is the sketch I am using on the Arduino. Seems to be pretty stable throughout all Hyperion builds.

Compiling from the @hissingshark installer gives me a lot of depreciated errors, etc.

Mainly at the beginning.

– ENABLE_ZEROCONF = ON
– ENABLE_AMLOGIC = ON
– ENABLE_DISPMANX = OFF
– ENABLE_FB = ON
– ENABLE_OSX = OFF
– ENABLE_SPIDEV = OFF
– ENABLE_TINKERFORGE = OFF
– ENABLE_V4L2 = OFF
– ENABLE_WS2812BPWM = OFF
– ENABLE_WS281XPWM = OFF
– ENABLE_X11 = OFF
– ENABLE_QT5 = ON
– ENABLE_TESTS = ON
– ENABLE_PROFILER = OFF
– Current Version: master (GitHub-40c474c/7684a75-1549667088)
– Found libusb-1.0:
– - Includes: /usr/include/libusb-1.0
– - Libraries: /usr/lib/arm-linux-gnueabihf/libusb-1.0.so
– Looking for pthread.h
– Looking for pthread.h - found
– Looking for pthread_create
– Looking for pthread_create - not found
– Looking for pthread_create in pthreads
– Looking for pthread_create in pthreads - not found
– Looking for pthread_create in pthread
– Looking for pthread_create in pthread - found
– Found Threads: TRUE
– Could NOT find ZLIB (missing: ZLIB_LIBRARY ZLIB_INCLUDE_DIR)
– Looking for dlfcn.h
– Looking for dlfcn.h - found
– Looking for inttypes.h
– Looking for inttypes.h - found
– Looking for memory.h
– Looking for memory.h - found
– Looking for stdint.h
– Looking for stdint.h - found
– Looking for stdlib.h
– Looking for stdlib.h - found
– Looking for strings.h
– Looking for strings.h - found
– Looking for string.h
– Looking for string.h - found
– Looking for sys/stat.h
– Looking for sys/stat.h - found
– Looking for sys/types.h
– Looking for sys/types.h - found
– Looking for unistd.h
– Looking for unistd.h - found
– Protobuf: doing try-compiles for hash map/set headers
– Protobuf: doing try-compiles for pthread test
– Looking for stddef.h
– Looking for stddef.h - found
– Using protobuf compiler: /root/hyperion-vero4k/source/build/bin/protoc
– Found PythonLibs: /usr/lib/arm-linux-gnueabihf/libpython3.5m.so (found version “3.5.3”)
CMake Warning at doc/CMakeLists.txt:31 (message):
Doxygen not found, unable to generate documenation!

– Configuring done
– Generating done
– Build files have been written to: /root/hyperion-vero4k/source/build
Scanning dependencies of target jsoncpp
Scanning dependencies of target hidapi-libusb
Scanning dependencies of target serialport
Scanning dependencies of target getoptPlusPlus
[ 1%] Building C object dependencies/build/hidapi/CMakeFiles/hidapi-libusb.dir/hid-libusb.c.o
[ 2%] Building CXX object dependencies/build/jsoncpp/CMakeFiles/jsoncpp.dir/json_reader.cpp.o
[ 2%] Building CXX object dependencies/build/serial/CMakeFiles/serialport.dir/src/serial.cc.o
[ 3%] Building CXX object dependencies/build/getoptPlusPlus/CMakeFiles/getoptPlusPlus.dir///include/getoptPlusPlus/parameter.include.cc.o
[ 3%] Building CXX object dependencies/build/getoptPlusPlus/CMakeFiles/getoptPlusPlus.dir/getoptpp.cc.o
[ 3%] Linking C static library …/…/…/lib/libhidapi-libusb.a
[ 3%] Built target hidapi-libusb
Scanning dependencies of target tinkerforge
[ 3%] Building C object dependencies/build/tinkerforge/CMakeFiles/tinkerforge.dir/bricklet_led_strip.c.o
[ 3%] Building C object dependencies/build/tinkerforge/CMakeFiles/tinkerforge.dir/ip_connection.c.o
In file included from /usr/include/errno.h:28:0,
from /root/hyperion-vero4k/source/dependencies/build/tinkerforge/ip_connection.c:13:
/usr/include/features.h:148:3: warning: #warning “_BSD_SOURCE and _SVID_SOURCE are deprecated, use _DEFAULT_SOURCE” [-Wcpp]

warning “_BSD_SOURCE and _SVID_SOURCE are deprecated, use _DEFAULT_SOURCE”

^~~~~~~
[ 4%] Building CXX object dependencies/build/serial/CMakeFiles/serialport.dir/src/impl/unix.cc.o
[ 5%] Linking C static library …/…/…/lib/libtinkerforge.a
[ 5%] Built target tinkerforge
[ 5%] Building CXX object dependencies/build/jsoncpp/CMakeFiles/jsoncpp.dir/json_value.cpp.o
[ 5%] Linking CXX static library …/…/…/lib/libgetoptPlusPlus.a
[ 5%] Built target getoptPlusPlus
[ 5%] Building CXX object dependencies/build/jsoncpp/CMakeFiles/jsoncpp.dir/json_writer.cpp.o
Scanning dependencies of target protobuf
[ 6%] Building CXX object dependencies/external/protobuf/src/CMakeFiles/protobuf.dir/google/protobuf/stubs/common.cc.o
[ 6%] Building CXX object dependencies/external/protobuf/src/CMakeFiles/protobuf.dir/google/protobuf/stubs/once.cc.o
[ 7%] Building CXX object dependencies/external/protobuf/src/CMakeFiles/protobuf.dir/google/protobuf/stubs/hash.cc.o
In file included from /usr/include/c++/6/map:60:0,
from /root/hyperion-vero4k/source/dependencies/include/json/value.h:16,
from /root/hyperion-vero4k/source/dependencies/build/jsoncpp/json_value.cpp:7:
/usr/include/c++/6/bits/stl_tree.h: In function ‘std::_Rb_tree<_Key, _Val, _KeyOfValue, _Compare, _Alloc>::iterator std::_Rb_tree<_Key, _Val, _KeyOfValue, _Compare, _Alloc>::M_insert_unique(std::_Rb_tree<_Key, _Val, _KeyOfValue, _Compare, _Alloc>::const_iterator, _Arg&&, _NodeGen&) [with _Arg = std::pair<const Json::Value::CZString, Json::Value>&; _NodeGen = std::_Rb_tree<Json::Value::CZString, std::pair<const Json::Value::CZString, Json::Value>, std::_Select1st<std::pair<const Json::Value::CZString, Json::Value> >, std::lessJson::Value::CZString, std::allocator<std::pair<const Json::Value::CZString, Json::Value> > >::_Alloc_node; _Key = Json::Value::CZString; _Val = std::pair<const Json::Value::CZString, Json::Value>; _KeyOfValue = std::_Select1st<std::pair<const Json::Value::CZString, Json::Value> >; _Compare = std::lessJson::Value::CZString; _Alloc = std::allocator<std::pair<const Json::Value::CZString, Json::Value> >]’:
/usr/include/c++/6/bits/stl_tree.h:1989:7: note: parameter passing for argument of type ‘std::_Rb_tree<Json::Value::CZString, std::pair<const Json::Value::CZString, Json::Value>, std::_Select1st<std::pair<const Json::Value::CZString, Json::Value> >, std::lessJson::Value::CZString, std::allocator<std::pair<const Json::Value::CZString, Json::Value> > >::const_iterator {aka std::_Rb_tree_const_iterator<std::pair<const Json::Value::CZString, Json::Value> >}’ will change in GCC 7.1
_Rb_tree<_Key, _Val, _KeyOfValue, _Compare, _Alloc>::
^~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
/usr/include/c++/6/bits/stl_tree.h:1989:7: note: parameter passing for argument of type ‘std::_Rb_tree<Json::Value::CZString, std::pair<const Json::Value::CZString, Json::Value>, std::_Select1st<std::pair<const Json::Value::CZString, Json::Value> >, std::lessJson::Value::CZString, std::allocator<std::pair<const Json::Value::CZString, Json::Value> > >::const_iterator {aka std::_Rb_tree_const_iterator<std::pair<const Json::Value::CZString, Json::Value> >}’ will change in GCC 7.1
[ 7%] Linking CXX static library …/…/…/lib/libserialport.a
/usr/include/c++/6/bits/stl_tree.h: In member function ‘Json::Value& Json::Value::operator’:
/usr/include/c++/6/bits/stl_tree.h:950:65: note: parameter passing for argument of type ‘std::_Rb_tree<Json::Value::CZString, std::pair<const Json::Value::CZString, Json::Value>, std::_Select1st<std::pair<const Json::Value::CZString, Json::Value> >, std::lessJson::Value::CZString, std::allocator<std::pair<const Json::Value::CZString, Json::Value> > >::const_iterator {aka std::_Rb_tree_const_iterator<std::pair<const Json::Value::CZString, Json::Value> >}’ will change in GCC 7.1
return M_insert_unique(__pos, std::forward<_Arg>(__x), __an);
^
[ 7%] Built target serialport
Scanning dependencies of target protobuf-lite
[ 8%] Building CXX object dependencies/external/protobuf/src/CMakeFiles/protobuf-lite.dir/google/protobuf/stubs/common.cc.o
/usr/include/c++/6/bits/stl_tree.h: In member function ‘Json::Value& Json::Value::resolveReference(const char*, bool)’:
/usr/include/c++/6/bits/stl_tree.h:950:65: note: parameter passing for argument of type ‘std::_Rb_tree<Json::Value::CZString, std::pair<const Json::Value::CZString, Json::Value>, std::_Select1st<std::pair<const Json::Value::CZString, Json::Value> >, std::lessJson::Value::CZString, std::allocator<std::pair<const Json::Value::CZString, Json::Value> > >::const_iterator {aka std::_Rb_tree_const_iterator<std::pair<const Json::Value::CZString, Json::Value> >}’ will change in GCC 7.1
return M_insert_unique(__pos, std::forward<_Arg>(__x), __an);
^
[ 8%] Building CXX object dependencies/external/protobuf/src/CMakeFiles/protobuf.dir/google/protobuf/extension_set.cc.o
[ 8%] Building CXX object dependencies/external/protobuf/src/CMakeFiles/protobuf.dir/google/protobuf/generated_message_util.cc.o
[ 9%] Linking CXX static library …/…/…/lib/libjsoncpp.a
[ 9%] Built target jsoncpp
Scanning dependencies of target test_qregexp
[ 10%] Building CXX object test/CMakeFiles/test_qregexp.dir/TestQRegExp.cpp.o
[ 11%] Building CXX object dependencies/external/protobuf/src/CMakeFiles/protobuf.dir/google/protobuf/message_lite.cc.o
[ 11%] Building CXX object dependencies/external/protobuf/src/CMakeFiles/protobuf-lite.dir/google/protobuf/stubs/once.cc.o
[ 11%] Building CXX object dependencies/external/protobuf/src/CMakeFiles/protobuf-lite.dir/google/protobuf/stubs/hash.cc.o
[ 11%] Building CXX object dependencies/external/protobuf/src/CMakeFiles/protobuf.dir/google/protobuf/repeated_field.cc.o
[ 11%] Linking CXX executable …/bin/test_qregexp
[ 12%] Building CXX object dependencies/external/protobuf/src/CMakeFiles/protobuf-lite.dir/google/protobuf/extension_set.cc.o
[ 12%] Built target test_qregexp
Scanning dependencies of target test_qtscreenshot
[ 12%] Building CXX object dependencies/external/protobuf/src/CMakeFiles/protobuf.dir/google/protobuf/wire_format_lite.cc.o
[ 12%] Building CXX object test/CMakeFiles/test_qtscreenshot.dir/TestQtScreenshot.cpp.o
[ 13%] Building CXX object dependencies/external/protobuf/src/CMakeFiles/protobuf.dir/google/protobuf/io/coded_stream.cc.o
[ 14%] Linking CXX executable …/bin/test_qtscreenshot
[ 14%] Building CXX object dependencies/external/protobuf/src/CMakeFiles/protobuf.dir/google/protobuf/io/zero_copy_stream.cc.o
[ 14%] Built target test_qtscreenshot
[ 14%] Building CXX object dependencies/external/protobuf/src/CMakeFiles/protobuf.dir/google/protobuf/io/zero_copy_stream_impl_lite.cc.o
[ 15%] Building CXX object dependencies/external/protobuf/src/CMakeFiles/protobuf.dir/google/protobuf/stubs/strutil.cc.o
[ 15%] Building CXX object dependencies/external/protobuf/src/CMakeFiles/protobuf.dir/google/protobuf/stubs/substitute.cc.o
[ 15%] Building CXX object dependencies/external/protobuf/src/CMakeFiles/protobuf.dir/google/protobuf/stubs/structurally_valid.cc.o
[ 16%] Building CXX object dependencies/external/protobuf/src/CMakeFiles/protobuf.dir/google/protobuf/stubs/atomicops_internals_x86_gcc.cc.o

ends up failing at the end with amlogic again. I have fully installed Hyperion classic and all remnants on the Vero 4k+ before trying to install hyperion.ng again. I have the urge to try again this afternoon…maybe it’ll work if I cross my fingers. I actually do everytime lol

0 Likes

#470

I wonder if there is a way for me to switch out my Arduino for an rPi, compile hyperion.ng on it with the web UI and forward the information onto the Vero4k+?

Does anyone use an rPi w/ a Vero 4k+ to be able to utilize hyperion.ng? I do not own a USB grabber, they aren’t cheap!

At least a temporary fix. I notice running hyperion.ng off OSMC with an rPi actually produces better color results than running Hyperion classic on the Vero. Big big difference.

An updated guide for the Vero would be amazing. I really would like to get this to work and make it easier for everyone else to install/compile.

Perhaps someone is knowledgeable enough to make a Vero4k/Vero4k+ installer for people who wish to test out hyperion.ng. Having to compile and build it is just not working. I’m sure a lot of us have the same platform here, one installer should suffice for the whole crowd, minus the rPi folks. I have no issues compiling/building and using Hyperion.ng running OSMC on an rPi. Vero4k+ is a different story. It’s hellish to get something up and going. I think I have installed some hybrid of 4 different versions, it works as classic should but it shouldn’t have to be that hard to get it installed.

If anyone wants to use what I have here as a testing platform, I am more than happy to help. I am comfortable navigating Linux through command line, etc. Figuring out things such as this though are beyond my capabilities.

I’m just trying different forked versions of hyperion.ng at the moment. That’s all we really need here with the appropriate changes made to it so we can compile it without any issues.

0 Likes

#471

I can re-run the installer soon and document what’s needed to get it to install properly.

Sam

2 Likes

#472

That would be awesome. I only have luck using the @hissingshark installer he provided a couple years ago in this forum. It seems to just override everything and amlogic installs properly and everything. It’s just an old version and cannot be updated as far as my knowledge.

I have tried taking parts of his out and mixing it in with the new one via SFTP, doesn’t work of course.

Holy crap, it built with no errors. I used:

git clone --recursive -b entertainment-api https://github.com/SJunkies/hyperion.ng.git hyperion.ng
cmake -DPLATFORM=amlogic -DENABLE_AMLOGIC=ON -DENABLE_DISPMANX=OFF -DENABLE_FB=ON -DENABLE_OSX=OFF -DENABLE_SPIDEV=OFF -DENABLE_TINKERFORGE=OFF -DENABLE_V4L2=ON -DENABLE_WS281XPWM=OFF -DENABLE_X11=OFF -DENABLE_TESTS=ON -DENABLE_PROFILER=OFF -DCMAKE_BUILD_TYPE=Release ..

I’m actually trying to compile the API based installer mentioned on here Anthrax OSMC Vero 4k steps and I actually ran systemctl stop mediacenter while compiling to see if having Kodi running while compiling is making things harder.

Scanning dependencies of target hyperion-remote
[ 93%] Building CXX object src/hyperion-remote/CMakeFiles/hyperion-remote.dir/hyperion-remote.cpp.o
[ 93%] Building CXX object libsrc/webconfig/CMakeFiles/webconfig.dir/webconfig_automoc.dir/qrc_WebConfig_NXBAIHQSQM5QBD.cpp.o
Scanning dependencies of target hyperion-aml
[ 93%] Building CXX object src/hyperion-aml/CMakeFiles/hyperion-aml.dir/hyperion-aml.cpp.o
[ 93%] Building CXX object src/hyperion-aml/CMakeFiles/hyperion-aml.dir/AmlogicWrapper.cpp.o
[ 94%] Building CXX object src/hyperion-aml/CMakeFiles/hyperion-aml.dir/hyperion-aml_automoc.cpp.o
[ 95%] Building CXX object src/hyperion-remote/CMakeFiles/hyperion-remote.dir/JsonConnection.cpp.o
[ 95%] Building CXX object src/hyperion-remote/CMakeFiles/hyperion-remote.dir/hyperion-remote_automoc.cpp.o
Scanning dependencies of target hyperion-v4l2
[ 95%] Building CXX object src/hyperion-v4l2/CMakeFiles/hyperion-v4l2.dir/hyperion-v4l2.cpp.o
[ 95%] Linking CXX executable …/…/bin/hyperion-aml
[ 95%] Built target hyperion-aml
Scanning dependencies of target hyperion-framebuffer
[ 96%] Building CXX object src/hyperion-framebuffer/CMakeFiles/hyperion-framebuffer.dir/hyperion-framebuffer.cpp.o
[ 96%] Linking CXX executable …/…/bin/hyperion-remote
[ 96%] Built target hyperion-remote
[ 96%] Building CXX object src/hyperion-framebuffer/CMakeFiles/hyperion-framebuffer.dir/FramebufferWrapper.cpp.o
[ 96%] Linking CXX static library …/…/lib/libwebconfig.a
[ 96%] Built target webconfig
Scanning dependencies of target hyperiond
[ 96%] Building CXX object src/hyperion-framebuffer/CMakeFiles/hyperion-framebuffer.dir/hyperion-framebuffer_automoc.cpp.o
[ 96%] Building CXX object src/hyperiond/CMakeFiles/hyperiond.dir/hyperiond.cpp.o
[ 97%] Building CXX object src/hyperiond/CMakeFiles/hyperiond.dir/systray.cpp.o
[ 98%] Linking CXX executable …/…/bin/hyperion-framebuffer
[ 99%] Building CXX object src/hyperion-v4l2/CMakeFiles/hyperion-v4l2.dir/ScreenshotHandler.cpp.o
[ 99%] Built target hyperion-framebuffer
[ 99%] Building CXX object src/hyperion-v4l2/CMakeFiles/hyperion-v4l2.dir/hyperion-v4l2_automoc.cpp.o
[ 99%] Building CXX object src/hyperiond/CMakeFiles/hyperiond.dir/main.cpp.o
[ 99%] Building CXX object src/hyperiond/CMakeFiles/hyperiond.dir/hyperiond_automoc.cpp.o
[ 99%] Linking CXX executable …/…/bin/hyperion-v4l2
[ 99%] Built target hyperion-v4l2
[100%] Linking CXX executable …/…/bin/hyperiond
[100%] Built target hyperiond
root@osmc:~/hyperion.ng/build#

0 Likes

#473

Okay, it looks like you can compile and build hyperion.ng verion 2 but anything after that fails. I have classic and hyperion.ng installed on my Vero 4k+

I had to compile this one even though I use my amblight on my Arduino straight to the Vero so I need amlogic. This one seems to build with it but I am unable to install the newer version. Does anyone know a way I can change the source so when I run git pull origin it will pull from the non API version of hyperion? That would be cool as it appears on the webserver (which I can see!) I ran ```
/root/hyperion.ng/build/bin/hyperiond -v


I had to manually copy the webconfig folder over to the root hyperion.ng directory as it was asking me to provide a -r argument for the copy so I just used SFTP and dragged it over. 


git clone --recursive -b entertainment-api https://github.com/SJunkies/hyperion.ng.git hyperion.ng

0 Likes

#474

edit: I have basic hyperion functions with and old version of classic. All this troubleshooting can be shelved as we are going to have a successful way to install hyperion.ng just as easy as it is on an rPi. Updated to 18 today with a few issues, mainly due to having a large library. I believe I had a couple thermal shutdowns. Fresh start fixed that problem.

I do however notice hyperion classic runs like crap on kodi 18.

0 Likes

#475

@nbraunstein @sam_nazarko
As far as I can tell my installer is still working fine for building Hyperion “classic”. I’m not clear what if anything has been an issue there.

I built Hyperion.ng last night just fine from its devs own instructions. My TV luminaire is currently dismantled due to decorating, so I’ve only tested up to running hyperiond from the commandline and then:

  1. Accessing the webUI on port 8090;
  2. Connecting the android app (still very alpha)

The only build failure was for one of the test programs. So building without tests enabled is the workaround in the first instance, by removing any -DENABLE_TESTS=ON when invoking cmake

I encountered the floating point error at runtime as others have done. This is fixing by specifying the CPU type prior to starting the build with:

export CFLAGS="-I/opt/vero3/include -L/opt/vero3/lib -O3 -march=armv8-a+crc -mtune=cortex-a53 -mfpu=neon-fp-armv8 -mfloat-abi=hard -ftree-vectorize -funsafe-math-optimizations"
export CPPFLAGS=$CFLAGS
export CXXFLAGS=$CFLAGS

Adding Hyperion-NG to the installer would be trivial. I did offer to do this last year, but as I’m not using it and there was no interest here I stuck to what I was doing (the RetroPie port to Vero4k).
I’ll add this to my to-do list

1 Like

#476

@hissingshark

I compiled and built from https://github.com/SJunkies/hyperion.ng.git hyperion.ng with amlogic platform. Works and on old hyperion.ng version 2.0

git remote set-url origin https://github.com/hyperion-project/hyperion.ng.git
then git pull origin and it updated from the non-api vesion.

0 Likes

#477

I can start hyperiond server in /root/hyperion.ng/build/bin/./hyperiond

I can never get past the cmake portion, it always fails at amlogic and framebuffer. I was using your old installer and the java applet then going in and adding amlogic and framebuffer to my config files.

I’m afraid to uninstall the old version of hyperion via the java app as it will mess with however I managed to get hyperiond working.

root@osmc:~/hyperion.ng# git remote -v
origin https://github.com/hyperion-project/hyperion.ng.git (fetch)
origin https://github.com/hyperion-project/hyperion.ng.git (push)
root@osmc:~/hyperion.ng# git pull origin
remote: Enumerating objects: 199, done.
remote: Counting objects: 100% (199/199), done.
remote: Compressing objects: 100% (9/9), done.
remote: Total 268 (delta 189), reused 196 (delta 189), pack-reused 69
Receiving objects: 100% (268/268), 65.88 KiB | 0 bytes/s, done.
Resolving deltas: 100% (205/205), completed with 88 local objects.
From https://github.com/hyperion-project/hyperion.ng

ba2a7fb0…48aee890 master -> origin/master (forced update)
Your configuration specifies to merge with the ref ‘refs/heads/entertainment-api’
from the remote, but no such ref was fetched.
root@osmc:~/hyperion.ng#

obviously the api isn’t there…I never required it. It was the only build that actually finished to 100% on my vero4k+

looks like its still on oldest version

trying to pull from master

root@osmc:~/hyperion.ng/build/bin# git pull origin master
From https://github.com/hyperion-project/hyperion.ng

  • branch master -> FETCH_HEAD
    Auto-merging libsrc/webserver/WebSocketClient.cpp
    Auto-merging libsrc/webserver/WebJsonRpc.h
    Auto-merging libsrc/webserver/WebJsonRpc.cpp
    Auto-merging libsrc/webserver/StaticFileServing.h
    Auto-merging libsrc/webserver/StaticFileServing.cpp
    Auto-merging libsrc/webserver/QtHttpClientWrapper.h
    Auto-merging libsrc/webserver/QtHttpClientWrapper.cpp
    Auto-merging libsrc/webserver/CgiHandler.h
    Auto-merging libsrc/webserver/CgiHandler.cpp
    Auto-merging libsrc/webserver/CMakeLists.txt
    Removing libsrc/webconfig/WebConfig.cpp
    Removing libsrc/webconfig/QtHttpServer.h
    Removing libsrc/webconfig/QtHttpServer.cpp
    Removing libsrc/protoserver/ProtoConnectionWrapper.cpp
    Removing libsrc/protoserver/ProtoConnection.cpp
    Auto-merging libsrc/leddevice/dev_net/LedDevicePhilipsHue.h
    CONFLICT (content): Merge conflict in libsrc/leddevice/dev_net/LedDevicePhilipsHue.h
    Auto-merging libsrc/leddevice/dev_net/LedDevicePhilipsHue.cpp
    CONFLICT (content): Merge conflict in libsrc/leddevice/dev_net/LedDevicePhilipsHue.cpp
    Auto-merging libsrc/leddevice/LedDeviceSchemas.qrc
    Auto-merging libsrc/leddevice/CMakeLists.txt
    Auto-merging libsrc/jsonserver/JsonClientConnection.h
    Removing libsrc/hyperion/hyperion-icon_32px.png
    Removing libsrc/hyperion/ImageProcessorFactory.cpp
    Auto-merging libsrc/api/JsonAPI.cpp
    Auto-merging libsrc/api/JSONRPC_schemas.qrc
    Auto-merging libsrc/api/JSONRPC_schema/schema.json
    Auto-merging libsrc/api/JSONRPC_schema/schema-serverinfo.json
    Auto-merging libsrc/api/JSONRPC_schema/schema-effect.json
    Auto-merging libsrc/api/JSONRPC_schema/schema-create-effect.json
    Auto-merging libsrc/api/JSONRPC_schema/schema-color.json
    Auto-merging libsrc/api/JSONRPC_schema/schema-clear.json
    Auto-merging libsrc/api/JSONRPC_schema/schema-adjustment.json
    Auto-merging include/webserver/WebSocketClient.h
    Removing include/webconfig/WebConfig.h
    Removing include/protoserver/ProtoConnectionWrapper.h
    Removing include/protoserver/ProtoConnection.h
    Auto-merging include/hyperion/MultiColorAdjustment.h
    Removing include/hyperion/ImageProcessorFactory.h
    Auto-merging include/effectengine/EffectModule.h
    Auto-merging include/api/JsonAPI.h
    Removing effects/schema/running_dots.schema.json
    Removing effects/running_dots.json
    Removing doc/hyperion-stylesheet.css
    Removing doc/hyperion-header.html
    Removing doc/hyperion-build-doc.in.sh
    Removing bin/scripts/setup_hyperion_forward.sh
    Removing assets/webconfig/server_scripts/demo.py
    Auto-merging assets/webconfig/js/content_leds.js
    CONFLICT (content): Merge conflict in assets/webconfig/js/content_leds.js
    Auto-merging assets/webconfig/i18n/en.json
    Auto-merging HyperionConfig.h.in
    Auto-merging CompileHowto.md
    Auto-merging CMakeLists.txt
    Auto-merging .gitignore
    Automatic merge failed; fix conflicts and then commit the result.
    root@osmc:~/hyperion.ng/build/bin#
[hyperiond AMLOGICGRABBER] (INFO) VPU mode
[hyperiond AMLOGICGRABBER] (ERROR) AMSTREAM_EXT_GET_CURRENT_VIDEOFRAME failed.
[hyperiond AMLOGICGRABBER] (WARNING) GE2D capture interface not available! try Amvideocap instead
[hyperiond Smoothing] (INFO) set smoothing cfg: 25, interval: 0 ms, settlingTime: 40 ms, updateDelay: 0 frames
[hyperiond LedDevice] (DEBUG) (LedDeviceAdalight.cpp:80:receivedData()) >>received 4 bytes data
[hyperiond Core] (DEBUG) (Hyperion.cpp:536:bonjourRecordResolved()) found hyperion session: osmc.local.:8090
[hyperiond Smoothing] (INFO) set smoothing cfg: 0, interval: 0 ms, settlingTime: 50 ms, updateDelay: 0 frames
0 Likes

#478

I’ve been finding it very hard to follow what you are doing.

Even as I type you are re-editing and re-editing your reply to me and spamming the thread with more logs, screen shots and snippets. Please try to be concise.

Why are you not just building from the master branch of https://github.com/hyperion-project/hyperion.ng.git as it’s their project? What are the other repos and cross git pulls all about?

Are these not issues relating to your specific lighting setup or the alpha state of the software?

All I can establish is that:

  1. My evenings efforts were not helpful;
  2. You are successfully building and running it yourself.
  3. I not need to add Hyperion.ng to the installer.
  4. I can go back to bed for another hour now on this bank holiday before I really have to be up…
1 Like

#479

It’s been a long day, I apologize.

My main and only goal is to have hyperion.ng on my Vero4k+. Thus far I have been unable to do so. The way I have it working now is odd, I compiled from the entertainment-API repo, which is an older version. It does grab amlogic but not well, webconfig is showing version 2.0

Prior to figuring out that I could build/compile from the samsung hue-api based repo that is in the osmc vero 4k instructions that Antrax posted up awhile ago. I was only able to use your installer and edit that json file after editing my config file, adding framebuffer and amlogic.

Can your installer package the newest hyperion.ng with the webconfig? I get the same build errors regarding amlogic and framebuffer right around 80%. Compiling as amlogic of course, fb on, amlogic on, etc.

Sorry for all the scattered posts. I hope this clarifies things a bit.

Every time I build from the master branch, I see those errors and it never finishes. I think multiple folks have had these amlogic errors. I’ve posted them a few pages up in this channel. It just doesn’t work for the life of me. Following the instructions to a tee, making sure I’m not compiling for an rPi or anything. So I figured I’d try the entertainment-api repo mentioned in Anthrax’s instructions and then maybe just change the source so I can update from the original repo.

0 Likes

#480

Ok, well as I reported that worked for me on the Vero4k just by using the official repository


As above the only build error I encountered was avoidable:

I assume it’s the same error, but regardless it’s the only one. For comparison my error was:

Scanning dependencies of target test_blackborderprocessor                                                            
[ 85%] Building CXX object test/CMakeFiles/test_blackborderprocessor.dir/TestBlackBorderProcessor.cpp.o                                      
/home/osmc/hyperion.ng/test/TestBlackBorderProcessor.cpp: In function ‘int main()’:                
/home/osmc/hyperion.ng/test/TestBlackBorderProcessor.cpp:53:39: error: no matching function for call to ‘hyperion::BlackBorderProcessor::BlackBorderProcessor(QJsonObject&)’
  BlackBorderProcessor processor(config);

I’m not sure which of the Anthrax instructions you followed but the ones I see on his github are essentially the official dev ones with some local tweaks. Looks like following those should be fine. And they are building from the master official branch as I did above.

BUT first you’ll need to run:

This is to avoid the “floating point exception” when you run ‘hyperiond’.


If you mean does the webUI work on port :8090 then yes, as above the webUI and the alpha android app were essentially the only way I could test the build for now.


This really should be it. It’s essentially what I’ll be automating with my installer/builder, along with some housekeeping. Please read all of this and make a clean start of it.

1 Like

#481

What options should I use when I am compiling after making my build directory? I’m going to give it a shot tonight. Old version of classic isn’t working so well for me.

Also, what commands if any, should I run to make sure I have completely removed hyperion and hyperion.ng before proceeding with another attempt?

Thank you for your response by the way. Very kind of you working with me on this.

Should I just do cmake dbplatform=amlogic64 and framebuffer and just leave everything else out?

0 Likes