OSMC and Hyperion

Can anybody please post a working config for hyperion on vero4k and a hue bridge? I installed with @hissingshark s installer but the leds never turn on. I get no error except for “no carrier”, so i think my config for the framegrappe/amlgrabber is wrong, but i can’ find a complete example. Thanks in advance.

Here is my config for the grabber part:

    "amlgrabber" :
            "width" : 64,
            "height" : 64,
            "frequency_Hz" : 3.0,
            "priority" : 890
    "framegrabber": {
            "frequency_Hz": 10,
            "height": 45,
            "pixelDecimation": 8,
            "type": "amlogic",
            "width": 80

“No carrier” is seemingly normal. I think it eventually sounded like a QT thing going on in the background but it wasn’t very easy to Google for.

I don’t think people need to be sharing config files any more because with NG we aren’t suppose ot edit them. All configuration should work through the webGUI on port 8090.

To be clear, you built the experimental version with Hue support?
That’s built using:
sudo ./install hue

Yes. I can configure via gui, lamps are working via gui. But nothing is turned on when running kodi. It’s on a vero4k, so I guess it’s something with the grabbing stuff.

I thought the second grabber is not configurable via gui?

Looks like grabbing works fine, as i can view the preview in the Web-GUI. Why do the Leds do not turn on/change color?

I take it you are testing them in the Remote Control section?
For them to respond to the grabber you would need “Platform Capture: (AmLogic)” to be marked in green as “Source active” under Remote Control->Source Selection. It might not be if you’ve tried setting colours or effects prior.

No sorry, i was talking just about the identifying the lamps and turning them simply blue.

But nevertheless, i got it working now. I did use “phillips hue” as led type, which i did not manage to get work. But i got them working via “phillips hue entertainment” type.

Thank you very much, @hissingshark . The installation was a charm, i wouldn’t have managed it without you installer. I just struggled at configuration. Sorry.

Not a problem. That’s what we do here. It’ll be useful to the next user!

Hi Anthrax, do you have a video or picture of this awesome setup? I would love to see the 160 Led together with the Nanoleafs.

Also (being a newbie) how can you run different instances. Or better could you make as short guide/input how to run a main hyperion instance and another instance for the Nanoleaf?

I would love to do something similar

Hi @Peter_1969,

It’s not easy to film with my mobile without blowing out the colors but this should give you a pretty good idea about what’s in store :wink:

Link to video

I suggest you go with the new hyperion.ng by using @hissingshark s awesome installer. Once installed it’s configured via an easy web interface that should get you up and running with multiple instances/device in a heartbeat. An official hyperion.ng release might also be around the corner…



I am…have no words.
Thanks mate … much appreciated :wink:

Here’s another one with a rgb test sequence to show the extreme :wink:

Link to Video: http://streamable.com/d0ll1

Good luck with your project. And remember to show us when finished :wink:



Thank you for the Video. Real something special…OR BETTER AWESOME…I have many question but for now I will save the video for inspiration…and start to study

The journey is half the fun :wink:

Hyperion is not working anymore - i need some advice and suggestion how to debug

The Hyperion setup was working until an OSMC upgrade this June. The setup was Vero4K+, 107 Led WS2801, ArduinoR3, Adalight sketch and Hyperion.ng compiled according to the guidelines from Anthrax.

I have been abroad for a while and had no time to try to fix the issue until this weekend.
My HW setup has not changed so far. For the SW I did a clean install of OSMC October 2019 (uname -r 3.14.29-156-osmc) and used the installer of hissingshark (Install from binary) and imported my old config file.

The install seem to be OK but …my setup does not work any more and after several controls and checks do not know how to proceed.


  • on Reboot of OSMC I can see all led turn on with a white color which change to blue for 2 seconds. This happens again on restart. The same effect can be seen when I change the USB cable from port white to port black on Vero4K+.
  • cannot get any effects to work
  • tried also the config file of nbraunstein with my Led setup. Not solving my issue.

Of course it can be my HW but not sure what can be broken…Arduino? With my tester I have continuity on GND, and controlled all cables which seems to be fine.

What I do not understand is the short flash of light on all led on reboot
Can it be the Aduino? should it be reprogrammed? Which sketch is recommend?
i am using this adalight.ino adjusted to my WS2801

below verbose log file on reboot:
[hyperiond EFFECTFILES] (INFO) 36 effects loaded from directory :/effects/
[hyperiond EFFECTFILES] (INFO) 19 effect schemas loaded from directory :/effects/schema/
[hyperiond EFFECTFILES] (INFO) 0 effects loaded from directory /home/osmc/.hyperion/custom-effects
[hyperiond SettingsManager] (INFO) Selected configuration file: /home/osmc/.hyperion/config/hyperion_main.json
[hyperiond SettingsManager] (DEBUG) (SettingsManager.cpp:73:SettingsManager()) Settings database initialized
[hyperiond BLACKBORDER] (DEBUG) (BlackBorderProcessor.cpp:65:handleSettingsUpdate()) Set mode to: default
[hyperiond ComponentRegister] (DEBUG) (ComponentRegister.cpp:67:componentStateChanged()) Blackborder detector: enabled
[hyperiond FLATBUFCONNECTION] (INFO) Connecting to Hyperion:
[hyperiond ComponentRegister] (DEBUG) (ComponentRegister.cpp:67:componentStateChanged()) LED device: enabled
[hyperiond LEDDEVICE] (DEBUG) (LedDeviceAdalight.cpp:53:init()) Adalight header for 107 leds: Ada 0x00 0x6a 0x3f
[hyperiond LEDDEVICE] (INFO) LedDevice ‘adalight’ configured.
[hyperiond ComponentRegister] (DEBUG) (ComponentRegister.cpp:67:componentStateChanged()) Smoothing: enabled
[hyperiond EFFECTENGINE] (INFO) run effect Atomic swirl on channel 0
[hyperiond HYPERION] (DEBUG) (PriorityMuxer.cpp:153:registerInput()) Register new input ‘System/EFFECT’ with priority 0 as inactive
[hyperiond HYPERION] (INFO) Inital foreground effect ‘Atomic swirl’ started
[hyperiond EFFECTENGINE] (INFO) run effect Warm mood blobs on channel 254
[hyperiond HYPERION] (DEBUG) (PriorityMuxer.cpp:153:registerInput()) Register new input ‘System/EFFECT’ with priority 254 as inactive
[hyperiond HYPERION] (INFO) Inital background effect ‘Warm mood blobs’ started
[hyperiond HYPERION] (DEBUG) (PriorityMuxer.cpp:153:registerInput()) Register new input ‘System/GRABBER’ with priority 250 as inactive
[hyperiond ComponentRegister] (DEBUG) (ComponentRegister.cpp:67:componentStateChanged()) Framegrabber: enabled
[hyperiond BOBLIGHT] (DEBUG) (BoblightServer.cpp:24:BoblightServer()) Instance created
[hyperiond DAEMON] (INFO) Hyperion initialized
[hyperiond DAEMON] (INFO) set screen capture device to ‘amlogic’
[hyperiond AMLOGICGRABBER] (DEBUG) (Grabber.cpp:33:setVideoMode()) Set videomode to 0
[hyperiond FRAMEBUFFERGRABBER] (DEBUG) (Grabber.cpp:33:setVideoMode()) Set videomode to 0
[hyperiond FRAMEBUFFERGRABBER] (INFO) Display opened with resolution: 1920x1080@32bit
[hyperiond AMLOGICGRABBER] (DEBUG) (AmlogicGrabber.cpp:31:AmlogicGrabber()) constructed(160 x 160), grabber device: /dev/amvideocap0
[hyperiond DAEMON] (INFO) AMLOGIC grabber created
[hyperiond JSONSERVER] (DEBUG) (JsonServer.cpp:23:JsonServer()) Created instance
[hyperiond JSONSERVER] (INFO) Started on port 19444
[hyperiond LEDDEVICE] (INFO) Opening UART: /dev/ttyACM0
[hyperiond LEDDEVICE] (DEBUG) (ProviderRs232.cpp:182:tryOpen()) Setting baud rate to 115200
[hyperiond LEDDEVICE] (DEBUG) (ProviderRs232.cpp:198:tryOpen()) Device blocked for 1500 ms
[hyperiond FLATBUFSERVER] (INFO) Started on port 19400
[hyperiond AMLOGICGRABBER] (INFO) FB mode
[hyperiond HYPERION] (DEBUG) (PriorityMuxer.cpp:231:setInputImage()) Priority 250 is now active
[hyperiond HYPERION] (DEBUG) (PriorityMuxer.cpp:330:setCurrentTime()) Set visible priority to 0
[hyperiond PROTOSERVER] (INFO) Started on port 19445
[hyperiond WEBSERVER] (DEBUG) (WebServer.cpp:96:handleSettingsUpdate()) Set document root to: :/webconfig
[hyperiond WEBSERVER] (INFO) Started on port 8090 name ‘Hyperion Webserver’
[hyperiond HYPERION] (DEBUG) (PriorityMuxer.cpp:231:setInputImage()) Priority 0 is now active
[hyperiond HYPERION] (DEBUG) (PriorityMuxer.cpp:192:setInput()) Priority 254 is now active
[hyperiond LEDDEVICE] (DEBUG) (ProviderRs232.cpp:216:writeBytes()) 26 frames dropped
[hyperiond LEDDEVICE] (DEBUG) (LedDeviceAdalight.cpp:80:receivedData()) >>received 2 bytes data
[hyperiond WEBSOCKET] (DEBUG) (WebSocketClient.cpp:32:WebSocketClient()) New connection from ::ffff:
[hyperiond WEBSOCKET] (DEBUG) (JsonAPI.cpp:916:handleLoggingCommand()) log streaming activated for client ::ffff:


I’m away, so not tried the update myself yet (got my Vero4K with me, but not my lights :wink:). Will do upon my return.
In the meantime it might be that the version of Hyperion you’ve built is different since what you were using in June. It’s always possible that old config files won’t work if the devs change something significantly. Have a try at configuring manually/fresh through the web GUI.

Cool. I will start with the default file

mean while i tried to change setting level to “Expert” and get this error in my Log file
[hyperiond HYPERION] (ERROR) setInputImage() used without registerInput() for priority '250', probably the priority reached timeout

and this

[hyperiond AMLOGICGRABBER] (ERROR) Read of device failed: 61 - No data available

On google this seem to be same issue as i have

Sorry, to clarify are you saying the June update broke your setup?

Yes the OSMC update in June for sure did not work anymore with the compile I had done of Hyperion.ng following the advice of Anthrax in January 2019.

For this reason I did a fresh install of OSMC (october build) and used your easy installer. (THX for this easy way to install!).

Ah, the June update broke it for everyone because it included the fixes I’d submitted for the long-standing A/V sync bug. But you needed a newer version of Hyperion.ng to go with the fixes. Guess you missed the post as the time.

Installing the pre-built binaries from my installer should work with current OSMC. Starting afresh with the configuration is a good idea. And that means NO config file at all. There is no “default file” you should be copying into anywhere, if you meant that literally. Start from scratch in the webGUI.

Just a heads up guys…

Hyperion.ng had made some breaking changes on how it stores its settings. What used to be loose json files are now a dedicated settings database.

But fear not - the videos I made were made with the latest and greatest osmc october update and thel latest hyperion.ng master branch (actually LordGreys bleeding edge fork dueto the nanoleaf fixes).

I’d suggest rebuild from source using hissingsharks installer (I hope this will get you to latest master and not an old commit anymore by default) and just reconfigure your devices… the new webgui makes this a breeze.