OSMC and OPEN VPN : not able to install

Hi all,

new to this forum so a quick presentation :
Raspberry fan, I’m already running a Rasp 1 with raspbmc (thank you so much @sam_nazarko)
I’m the new owner of a brand new rasp pi 2 :slight_smile: . I would like to run OSMC on it and clone my current features
in order to utilize my rasp 1 as an arcade emulator for my kids.


I’m facing a problem with OSMC and OpenVPN installation and I need your support to solve it :
let me explain quickly :

I’m using open vpn to connect my rasp to the cyberghost VPN.
following that tutorial :

already done that on raspbmc before, it worked fine.
now, I’m trying to set it up on osmc and i’m facing a problem with apt-get :
it seems that @sam_nazarko put some special repo to let us get sw compatible with OSMC (not sure but this is what i’m thinking). when i do the following command (from the cyberghost tutorial) :

osmc@osmc ~ $ sudo apt-get install openvpn openssl openresolv

My rasp answers me :

Reading package lists… Done
Building dependency tree
Reading state information… Done
Package openresolv is not available, but is referred to by another package.
This may mean that the package is missing, has been obsoleted, or
is only available from another source
E: Package ‘openresolv’ has no installation candidate

it seems that OSMC special repo is not including openresolv package that is needed for Cyberghost ?

  • what is the workaround ? specifiying other repo to be able to get that package ? if so, can you explain me how to do it ?
  • @sam_nazarko : is it possible to add that package to your local repo in order to solve this problem

thank you all for your time and help


Things to check:

  • Did you run sudo apt-get update first?
  • Did you check that the tutorial is for Debian Jessie


thank you for such a quick anwser.

(1) : yes : i’ve done apt-get update the apt-get dist-upgrade before (maybe a mistake ?)
(2) the tuto is called “How to set up OpenVPN for CyberGhost on a Raspberry (Raspbian/RaspBMC)”
so must be OK with raspberry (already done it successfully with raspBMC)
don’t know about jessie compliance (i assume it’s the last version of debian distro ?)

Raspbmc is based on Debian Wheezy

OSMC is based on Debian Jessie


An update :

I’ve tried to run the tutorial without making an apt-get of openresolv
So i’ve just done sudo apt-get install openvpn openssl

everything runs fine and my rasp seems to be well connected to the VPN provider.
I’m doing more tests and will give an update.
if it works correctly, I will ask cyberghot to update their tuto.

@sam_nazarko, can you please explain me if you 've connected OSMC to a special repo (that is not providing all the packages) or is it relying on standard repo of debian ?


OSMC allows the full packages that Debian does (and more on Pi2 than Pi1, as it is based completely on upstream Debian instead of Raspbian)


Looking further in to the matter the issue seems to be the openresolv has been removed from Debian (the package has been orphaned);