OSMC automount after rebout

My external HDD was always mounted in /media/Elements, but once I pulled mistakenly usb cable and inserted it again, and HDD automatically mounted into /media/Elements_. I re-mounted it manually to /media/Elements (as no movies was found due ti reason that library is looking at /medial/Elements). But now after each reboot it’s automatically mounted to /media/Elements_ and I can’t find any settings that I can change this behaviour.

Please advise.


To get a better understanding of the problem you are experiencing we need more information from you. The best way to get this information is for you to upload logs that demonstrate your problem. You can learn more about how to submit a useful support request here.

Can you also please show the output of the following 2 commands:

sudo blkid
sudo mount

Thanks for your understanding. We hope that we can help you get up and running again shortly.

Well I’ve tried to upload logs and got this :
root@osmc:/home/osmc# grab-logs -A
Logs successfully uploaded.
Logs available at https://paste.osmc.tv/
No proper url was returned.
So I copied kodi.log manually : https://paste.osmc.tv/iporubafey.coffee
I enabled logs in kodi settings, and rebooted the system, HDD was automounted to /media/Elemeents_

As for sudo blkid:

/dev/mmcblk0: PTUUID="a0d13c40" PTTYPE="dos"
/dev/mmcblk0p1: UUID="9345-7DA2" TYPE="vfat" PARTUUID="a0d13c40-01"
/dev/mmcblk0p2: UUID="dd6c01a5-6a87-482a-bfa3-671c04db05d6" TYPE="ext4" PARTUUID="a0d13c40-02"
/dev/sda1: LABEL="Elements" UUID="A4C45E13C45DE856" TYPE="ntfs" PARTUUID="00123d72-01"

sudo mount :
devtmpfs on /dev type devtmpfs (rw,relatime,size=377792k,nr_inodes=94448,mode=755)
proc on /proc type proc (rw,relatime)
sysfs on /sys type sysfs (rw,relatime)
tmpfs on /run type tmpfs (rw,relatime)
/dev/mmcblk0p2 on / type ext4 (rw,relatime,stripe=1024,data=ordered)
tmpfs on /dev/shm type tmpfs (rw,nosuid,nodev)
devpts on /dev/pts type devpts (rw,nosuid,noexec,relatime,gid=5,mode=620,ptmxmode=000)
tmpfs on /run/lock type tmpfs (rw,nosuid,nodev,noexec,relatime,size=5120k)
tmpfs on /sys/fs/cgroup type tmpfs (ro,nosuid,nodev,noexec,mode=755)
cgroup on /sys/fs/cgroup/systemd type cgroup (rw,nosuid,nodev,noexec,relatime,xattr,release_agent=/lib/systemd/systemd-cgroups-agent,name=systemd)
cgroup on /sys/fs/cgroup/cpu,cpuacct type cgroup (rw,nosuid,nodev,noexec,relatime,cpu,cpuacct)
cgroup on /sys/fs/cgroup/blkio type cgroup (rw,nosuid,nodev,noexec,relatime,blkio)
cgroup on /sys/fs/cgroup/memory type cgroup (rw,nosuid,nodev,noexec,relatime,memory)
cgroup on /sys/fs/cgroup/devices type cgroup (rw,nosuid,nodev,noexec,relatime,devices)
cgroup on /sys/fs/cgroup/freezer type cgroup (rw,nosuid,nodev,noexec,relatime,freezer)
cgroup on /sys/fs/cgroup/net_cls type cgroup (rw,nosuid,nodev,noexec,relatime,net_cls)
systemd-1 on /proc/sys/fs/binfmt_misc type autofs (rw,relatime,fd=21,pgrp=1,timeout=300,minproto=5,maxproto=5,direct)
mqueue on /dev/mqueue type mqueue (rw,relatime)
debugfs on /sys/kernel/debug type debugfs (rw,relatime)
systemd-1 on /boot type autofs (rw,relatime,fd=33,pgrp=1,timeout=300,minproto=5,maxproto=5,direct)
configfs on /sys/kernel/config type configfs (rw,relatime)
fusectl on /sys/fs/fuse/connections type fusectl (rw,relatime)
/dev/sda1 on /media/Elements_ type fuseblk (rw,nosuid,nodev,relatime,user_id=0,group_id=0,default_permissions,allow_other,blksize=4096,uhelper=udisks)
/dev/mmcblk0p1 on /boot type vfat (rw,noatime,fmask=0022,dmask=0022,codepage=437,iocharset=ascii,shortname=mixed,errors=remount-ro)
tmpfs on /run/user/1000 type tmpfs (rw,nosuid,nodev,relatime,size=76584k,mode=700,uid=1000,gid=1000)


What is the output of ls -la /media?


umount /dev/sda1
sudo rmdir /media/Elements
sudo rmdir /media/Elements_

Then unplug and replug the hard drive.

Plug-off then plug-in , HDD is not mounted automatically.
sudo blkid:
/dev/mmcblk0: PTUUID=“a0d13c40” PTTYPE=“dos”
/dev/mmcblk0p1: UUID=“9345-7DA2” TYPE=“vfat” PARTUUID=“a0d13c40-01”
/dev/mmcblk0p2: UUID=“dd6c01a5-6a87-482a-bfa3-671c04db05d6” TYPE=“ext4” PARTUUID=“a0d13c40-02”
/dev/sda1: LABEL=“Elements” UUID=“A4C45E13C45DE856” TYPE=“ntfs” PARTUUID=“00123d72-01”

But after reboot this solved the issue.