OSMC causes Bluray/surround decoder to power off

I’ve had this problem for a long time now, it’s rather annoying.

I have a Sony TV, with a Sony Bluray & Surround decoder, along with a Pi B+ running latest OSMC, all are connected to the TV via HDMI. The Raspberry Pi is powered up all the time, the TV & Bluray are in standby when not being used.

So, with everything switched on and I’m watching TV with the sound from the bluray decoder. All working well.

I switch the TV input to the Raspberry Pi, and OSMC appears, as expected.

But then, the Bluray player switches to standby! Powering it back up takes several minutes as the Bluray player boots annoyingly slowly. Meanwhile there is no audio until it’s started up.

This doesn’t happen every time I switch to the Raspberry Pi AV input, but happens most times.

Sometimes, if the Bluray player is already in standby, switching to the Raspberry Pi AV input will cause the Bluray player to switch itself on, although this is less common.

OSMC in my setup has done this for a long time, though possibly didn’t originally do it on early releases of OSMC.

I’ve had this setup for a good while now, I used to run Raspbmc on it, and under Raspbmc I didn’t have this problem - it worked as expected with nothing switching itself off or on at the wrong time.

Any thoughts as to what I could do?

Thanks

Ian

Check settings -> Input -> CEC there you can controll any point of CEC (towards OSMC and from OSMC to other devices).

Hi,

Thanks for that. I looked at the CEC settings, and didn’t see anything obviously wrong there, but I reset to defaults (and didn’t notice anything change).

However, since doing that, I can’t make the fault re-occur, so perhaps resetting CEC to default has cleared the problem.

Thanks!

Ian

Unfortunately, resetting CEC settings didn’t fix the problem.

I’m still getting the problem that, when I select the HDMI AV input for OSMC on my TV, the Surround Sound/Blu Ray player powers down.

I’ve just tried a clean fresh install of OSMC onto a different SD card for my Raspberry Pi, and without changing any settings except configuring location of TV shows and Movies, I get the same problem.

It’s very annoying. And didn’t happen under Raspbmc. But started sometime after migrating to OSMC.

[Edit : I’ve just installed OpenELEC. And it exhibits the same problem. With the same hardware setup, it used to work ok around the time of the switch from Raspbmc to OSMC. Disabling CEC isn’t really an option, I need CEC as I use the TV remote to work OSMC. Any thoughts as to what I can do?]

Ian