OSMC crash when pairing bluetooth


I’m using OSMC on Raspberry Pi 2.

My goal is to use it as media player + audio bluetooth receiver (i.e. send audio from my smartphone or laptop through bluetooth and play the audio through the raspberry jack output).

I’m using the Bluetooth CSR 4.0 usb dongle. For more infos about the usb dongle.

Here is my problem :

When I go in OSMC and turn on the bluetooth adaptator everything seems to be fine. But when I try to pair with my smartphone or my laptop, my device receive the bluetooth code for authentification but OSMC don’t show it. And then OSMC seems to crash. OSMC is stuck on the bluetooth menue and don’t seems to respond to my command even if I still can navigate in the differents category of the bluetooth menue.

Thank by advance for your help.

PS : As I understood A2DP isn’t supported yet but I was thinking that it was a good idea to solve this problem to be ready to go when the function will be supported.

Have you checked for and installed updates recently ? There were some bluetooth fixes in a recent update to fix crashing when pairing with some devices.

If you have already done that and it is still crashing, please enable debugging in Settings in Kodi, reproduce the pairing problem, then upload your Kodi log with the log uploader.

Thanks for your answer, I’ll search how to do the update (I have the last release I only have to do an update, right ? No need to reinstall the whole system ?) and try again.

If it still not work, I’ll upload the log uploader.

Did you ever get this figured out? I’m having the same problem.

Have you updated to RC3 today ? There should be a number of bluetooth fixes in todays updates.

Hi guys, sorry I didn’t gave any news because I was very busy (exams). I’ll do the update to RC 3 this week-end and I’ll tell you if the problem have been fixed. Thanks for answers.

Story of my life. By the time flash a new rom or finally put osmc on my pi, a new update is up before I hit enter. Violin please. :wink: Will try tonight. Thanks for the quick reply.

Did it work, bobg1231 ?

No. I tried to update and it did something but I’m still showing version 0.9.9 so I’m assuming I am still on rc 2? Going to try again tonight.

I think the best is to do a complete reinstallation with the RC3 and not only an update (muss be possible but I think the easiest is to reinstall completely exept if you have done a lot of changes in the settings etc.).

The version is still 0.9.9 in RC3 but it will say Release Candidate Three after 0.9.9. If you can’t read it you have far too much overscan on your TV!

Any install from RC1 onwards should upgrade to RC3 absolutely fine .If you are having problems or errors when trying to upgrade please use the log uploader to upload your logs - if there are any problems with the upgrade process we want to know about it and fix it.

Making a more robust and reliable upgrade system was one of the key design goals of OSMC over Raspbmc and we have worked hard to ensure the upgrade process is as reliable and safe as possible.

1 Like

On RC3 and still have the problem. Tried another device and same thing. Will upload debug file tonight.

I uploaded the log files last night. I guess that will include the debug file? If not, I have the file and can upload some other way.

The wiki contains the method for obtaining and providing logs, as well as many other useful info links.