OSMC crashes while browsing records RaspberryPi2B

I am really pleased with Kodi running on my Raspberry Pi 2 Model B. But really strange thing is happening causing the osmc to crash. When I try to scroll through my records on USB plugged NTFS HDD (2.5" HDD plugged into Transcend USB hub) it crashes. The HDD was clean and all records were made on this particular Raspberry. Doesn’t seem to happen when browsing throught the file manager… More to see in provided video link.

OSMC Kodi 15.2 (Compiled Nov. 22 2015)
PVR backend : HTS Tvheadend 4.0.7 (HTSPv20)
CPU: ARMv7 Processor rev 5 (v7I)
Revision: a01041
Running default frequencies

Log file : [url=http://paste.osmc.io/gerizoviru]http://paste.osmc.io/gerizoviru[/url]
Video showing the problem : [url=https://youtu.be/GKEJoZHVCaA]- YouTube

Thanks everyone in advance!

I suspect you may have a corrupt file, and Kodi tries to extract thumbnail or video properties from the file and crashes. Try disabling ‘Extract video information from files’ in Settings and seeing if this persists.


Thanks a lot for your fast reply!
I tried to disable “extract video information from files” and “extract thumbnails from video files” and no luck, still the same. :confused: Also it seems to NOT happen at one particular file. For instance I tried to scroll from the bottom to the top and it crashes at a different file than from the top to the bottom.


Do you have another Kodi install that you can attach the drive to?

I couldn’t see anything wrong in your log file, aside from some potential connectivity issues with TVHeadend.


So I tried to connect the disc to Kodi installed on my laptop but I couldn’t see the records in the library like they used to be. I must click on the drive and it opens the file structure… It has the same view as I would have opened it in system->file manager (I can see the files, in which name is time, tvchannel nad even the file extension)…
It was fragmented a lot though so I defragmented it and plugged back to TV - it didn’t help.
When I plugged it back to Raspberry the library showed up as it should be - I don’t know why it doesnt on my PC.

I even tried to delete a file which it seemed to get stucked on, but no luck it just gets stucked few files lower in the list…

Also those connectivity issues - how can I get rid of them? Sometimes the system crashes while I am recording something and reading something(watching a record) at the same time. Could it be somehow connected?

I am sorry for being so noobie but this whole thing is pretty new to me. :smiley:

Here is the old log file if it can help anybody. http://paste.osmc.io/otewohikeg.dos
Have a nice day.

Sounds like several corrupted files in your library as Sam suggested…

Ok so, I have no idea how it got corrupted but you were right. After I moved a few files from the HDD it stopped.
Anyway thanks a lot guys! :smile: