OSMC Dongle not seen on latest OSMC (noobs) Pi Rev 00010

Got the OSMC Dongle device today, been struggling all day with CLI and other such black magic to get OSMC to see it, no joy.

Some outputs below. If you need further info please just monkey me though the commands, I’m no Linux guru.
Fresh (several) OSMC installed via noobs. I’m using the version for Pi v1.

Many thanks


osmc@osmc:~$ sudo cat /var/lib/connman/settings

[global]
OfflineMode=false

[Wired]
Enable=true
Tethering=false
osmc@osmc:~$

strong textosmc@osmc:~$ dmesg

[ 1.305953] usb usb1: New USB device found, idVendor=1d6b, idProduct=0002
[ 1.305979] usb usb1: New USB device strings: Mfr=3, Product=2, SerialNumber= 1
[ 1.305997] usb usb1: Product: DWC OTG Controller
[ 1.306013] usb usb1: Manufacturer: Linux 3.18.10-1-osmc dwc_otg_hcd
[ 1.306030] usb usb1: SerialNumber: bcm2708_usb
[ 1.307179] hub 1-0:1.0: USB hub found
[ 1.307298] hub 1-0:1.0: 1 port detected
[ 1.307953] dwc_otg: FIQ enabled
[ 1.307977] dwc_otg: NAK holdoff enabled
[ 1.307987] dwc_otg: FIQ split-transaction FSM enabled
[ 1.308049] Module dwc_common_port init
[ 1.308601] usbcore: registered new interface driver usb-storage
[ 1.309066] mousedev: PS/2 mouse device common for all mice
[ 1.310281] bcm2835-cpufreq: min=700000 max=850000
[ 1.310817] sdhci: Secure Digital Host Controller Interface driver
[ 1.310840] sdhci: Copyright© Pierre Ossman
[ 1.311107] DMA channels allocated for the MMC driver
[ 1.350714] Load BCM2835 MMC driver
[ 1.351066] sdhci-pltfm: SDHCI platform and OF driver helper
[ 1.351776] ledtrig-cpu: registered to indicate activity on CPUs
[ 1.352000] hidraw: raw HID events driver © Jiri Kosina
[ 1.352324] usbcore: registered new interface driver usbhid
[ 1.352343] usbhid: USB HID core driver
[ 1.352709] TCP: cubic registered
[ 1.352737] Initializing XFRM netlink socket
[ 1.352787] NET: Registered protocol family 17
[ 1.352998] Key type dns_resolver registered
[ 1.355673] registered taskstats version 1
[ 1.361410] vc-sm: Videocore shared memory driver
[ 1.361443] [vc_sm_connected_init]: start
[ 1.365736] [vc_sm_connected_init]: end - returning 0
[ 1.370359] Waiting for root device /dev/mmcblk0p6…
[ 1.399424] mmc0: host does not support reading read-only switch, assuming wr ite-enable
[ 1.402754] mmc0: new high speed SDHC card at address aaaa
[ 1.403594] mmcblk0: mmc0:aaaa SL08G 7.40 GiB
[ 1.406644] mmcblk0: p1 p2 < p5 p6 > p3
[ 1.485175] EXT4-fs (mmcblk0p6): mounted filesystem with ordered data mode. O pts: (null)
[ 1.485277] VFS: Mounted root (ext4 filesystem) readonly on device 179:6.
[ 1.494898] devtmpfs: mounted
[ 1.496180] Freeing unused kernel memory: 324K (c08ef000 - c0940000)
[ 1.501028] Indeed it is in host mode hprt0 = 00021501
[ 1.690922] usb 1-1: new high-speed USB device number 2 using dwc_otg
[ 1.691143] Indeed it is in host mode hprt0 = 00001101
[ 1.901329] usb 1-1: New USB device found, idVendor=0424, idProduct=9514
[ 1.901368] usb 1-1: New USB device strings: Mfr=0, Product=0, SerialNumber=0
[ 1.902700] hub 1-1:1.0: USB hub found
[ 1.902909] hub 1-1:1.0: 5 ports detected
[ 2.180929] usb 1-1.1: new high-speed USB device number 3 using dwc_otg
[ 2.281242] usb 1-1.1: New USB device found, idVendor=0424, idProduct=ec00
[ 2.281279] usb 1-1.1: New USB device strings: Mfr=0, Product=0, SerialNumber =0
[ 2.284569] smsc95xx v1.0.4
[ 2.362553] smsc95xx 1-1.1:1.0 eth0: register ‘smsc95xx’ at usb-bcm2708_usb-1 .1, smsc95xx USB 2.0 Ethernet, b8:27:eb:af:05:bf
[ 2.440987] usb 1-1.2: new full-speed USB device number 4 using dwc_otg
[ 2.558841] usb 1-1.2: New USB device found, idVendor=04ca, idProduct=006f
[ 2.558878] usb 1-1.2: New USB device strings: Mfr=1, Product=2, SerialNumber =0
[ 2.558896] usb 1-1.2: Product: Wireless Device
[ 2.558912] usb 1-1.2: Manufacturer: Lite-On Technology Corp.
[ 2.582366] input: Lite-On Technology Corp. Wireless Device as /devices/platf orm/bcm2708_usb/usb1/1-1/1-1.2/1-1.2:1.0/0003:04CA:006F.0001/input/input0
[ 2.582999] hid-generic 0003:04CA:006F.0001: input,hidraw0: USB HID v1.11 Key board [Lite-On Technology Corp. Wireless Device] on usb-bcm2708_usb-1.2/input0
[ 2.609907] input: Lite-On Technology Corp. Wireless Device as /devices/platf orm/bcm2708_usb/usb1/1-1/1-1.2/1-1.2:1.1/0003:04CA:006F.0002/input/input1
[ 2.621178] hid-generic 0003:04CA:006F.0002: input,hiddev0,hidraw1: USB HID v 1.11 Device [Lite-On Technology Corp. Wireless Device] on usb-bcm2708_usb-1.2/in put1
[ 2.642307] input: Lite-On Technology Corp. Wireless Device as /devices/platf orm/bcm2708_usb/usb1/1-1/1-1.2/1-1.2:1.2/0003:04CA:006F.0003/input/input2
[ 2.643057] hid-generic 0003:04CA:006F.0003: input,hidraw2: USB HID v1.11 Mou se [Lite-On Technology Corp. Wireless Device] on usb-bcm2708_usb-1.2/input2
[ 3.762767] random: systemd urandom read with 92 bits of entropy available
[ 3.834802] NET: Registered protocol family 10
[ 4.494355] systemd[1]: Cannot add dependency job for unit display-manager.se rvice, ignoring: Unit display-manager.service failed to load: No such file or di rectory.
[ 4.495081] systemd[1]: Found ordering cycle on basic.target/start
[ 4.495152] systemd[1]: Found dependency on sysinit.target/start
[ 4.495212] systemd[1]: Found dependency on kbd.service/start
[ 4.495271] systemd[1]: Found dependency on remote-fs.target/start
[ 4.495319] systemd[1]: Found dependency on remote-fs-pre.target/start
[ 4.495369] systemd[1]: Found dependency on connman.service/start
[ 4.495416] systemd[1]: Found dependency on basic.target/start
[ 4.495467] systemd[1]: Breaking ordering cycle by deleting job kbd.service/s tart
[ 4.495520] systemd[1]: Job kbd.service/start deleted to break ordering cycle starting with basic.target/start
[ 4.809382] fuse init (API version 7.23)
[ 5.030954] EXT4-fs (mmcblk0p6): re-mounted. Opts: (null)
[ 5.544141] random: nonblocking pool is initialized
[ 5.961160] systemd-udevd[102]: starting version 215
[ 9.784037] Installing knfsd (copyright © 1996 okir@monad.swb.de).
[ 11.819318] systemd-journald[81]: Received request to flush runtime journal f rom PID 1
[ 12.113458] smsc95xx 1-1.1:1.0 eth0: hardware isn’t capable of remote wakeup
[ 12.114335] IPv6: ADDRCONF(NETDEV_UP): eth0: link is not ready
[ 13.451402] Bluetooth: Core ver 2.19
[ 13.453247] NET: Registered protocol family 31
[ 13.453274] Bluetooth: HCI device and connection manager initialized
[ 13.453326] Bluetooth: HCI socket layer initialized
[ 13.453350] Bluetooth: L2CAP socket layer initialized
[ 13.453414] Bluetooth: SCO socket layer initialized
[ 13.533153] smsc95xx 1-1.1:1.0 eth0: link up, 100Mbps, full-duplex, lpa 0x5DE 1
[ 13.543769] IPv6: ADDRCONF(NETDEV_CHANGE): eth0: link becomes ready
[ 13.564551] Bluetooth: BNEP (Ethernet Emulation) ver 1.3
[ 13.564587] Bluetooth: BNEP filters: protocol multicast
[ 13.564658] Bluetooth: BNEP socket layer initialized
[ 15.263521] EXT4-fs (mmcblk0p3): mounted filesystem with ordered data mode. O pts: (null)
[ 19.925827] Console: switching to colour dummy device 80x30

When you say the latest Noobs install of OSMC, that is actually quite out of date, and support for that adaptor was only added very recently.

So temporarily plug your Pi into an Ethernet connection and check for and install updates in My OSMC Updater, once updated it should detect the adaptor.

Indeed, NOOBS OSMC is still on RC3. We are trying to update things but we are waiting for the maintainer to do so.

Sam

Excellent thank you! worked a treat. Thanks so much.

(I’ll not expand on how I spent 20 minutes after the updating trying to get it to work, only to notice the dongle sat on the sideboard)

Thanks again (apologies for not trying the obvious also)