OSMC failed install: Segmentation fault - brand new 4k+ playerer

Ran into constant crashes of a brand new OSMC 4k+ player. Decided to reinstall the OSMC operating system. It refuses to install:

Install failed: Segmentation fault.

What to do … am wondering to return the player, as it seems incredibly unstable.

Sorry to hear that you are having a problem.

That doesn’t seem right. It would’ve been tested before dispatch

Can you confirm the device is plugged directly in to the wall and if you have any additional peripherals attached to the device?

Seemed to have bricked the player. As I restarted the player, to retry the installation. It now refuses to start even up. Following message in the screen:

Waiting for root filesystem device /dev/vero-nand/root
/dev/vero-nand/root: recovering journal
/dev/vero-nand/root: Superblock last mount time is in the future.
(by less than a day, probably due to the hardware clock being incorrectly set)
/dev/vero-nand/root: clean, 3995/930240 files, 100697/3716096 blocks
switch_root: can’t execute ‘/sbin/splash_early’: Exec format error

Please help!

It is directly plugged in the wall- only a keyboard attached .

re-downloaded the operating system and re-installed it on the USB stick … trying a second time installing the operating system.

Same error: Install failed: Segmentation fault.
Cannot install OS from USB it seems.

Tried with another USB stick. Same results.
Unfortunately you have to reformat and reinstall the Install-OS each time or it gives the error exec format error.

At this moment the player has become useless - haven’t tried with an sd-card, have to look for one.

Stop for now, let’s establish some facts.

Did it boot earlier and did you set it up and use it, or has it not worked at all?


It booted earlier, but had random resets and sad faces.
Could install the addon for TV Mosaic, it would crash and loop as soon as it was installed and tried to start.
Changing from the standard OSMC skin to the standard Kodi skin would crahs and loop the player (eventually even crashing OSMC core).

I haven’t really been able to use the player as it would crash and loop (restarting, sad face, restarting, sad face, etc.)

Erased each time .kodi/ folder to start new. But would crash either after adding advancedsettings.xml with mysql connection.
Or the next time after deleting .kodi enabling the add-on for MosaicTV would cause the crash.
Again after deleting .kodi couldn’t install other skins (getting an unknown error and then reset of Kodi with the standard OSMC skin).


Do you have a USB A to USB A cable or another 5V, 2A power supply? Post a picture of the PSU before using so we can check it’s OK


It’s the standard power supply that comes with the OSMC 4K+ player.
5v, 2a, not usb.

I haven’t got a USB-A to USB-A cable. Have to look for a 5v 2A PSU … not sure if I have one.
So you think it is the brand new power supply?

It’s worth testing an alternate method of powering the device, yes.

The device itself would have been tested several times before dispatch

If I use the USB cable, which USB port should be used to power it?

Either. The device powering should be a PC or laptop. Phone chargers etc aren’t reliable.

Looked around - no USB A to USB A cable. Not a very regular cable, wouldn’t even have a clue which device would use such a cable.

We can send another power supply.

So there is a limit of replies I can give … Just created a new account to respond to this. If you think this will solve the issue then, yes please.
I don’t have the before mentioned cable and I checked my PSU’s but don’t have anything of 5v 2A in combination with connector.

You can return the device if you would prefer; but I would be surprised if the device was problematic.

Let’s try the PSU first. Hopefully this will resolve the issue.
If you can send a new one, thank you!