OSMC for Pi Zero DOES WORK on 64GB SDCards

Brand new tested and working Pi Zero. (I have several Pi Zero’s)

Downloaded the download utility and used to:
Download and install 2016.10-1 copied onto Pi Zero - Doesn’t work
Download and install 2016.09-1 copied onto Pi Zero - Doesn’t work

Tested on another fully functional Pi Zero - Doesn’t work

Repeated above procedure on another fully working and tested slightly older (slower) SDCard - Doesn’t work

Tried above process on another old and shitty and slow 16GB SDCard - BOOM! Straight in - No problem whatsoever.

Conclusion:
OSMC doesn’t like new/fast/64GB SDCards

Go figure.

OSMC works just fine on 64GB cards. I have a Samsung Evo 64GB card in my Pi 2 and have done for over a year.

Most likely you have tried to write the card with an SD card reader that is not SDXC compliant - unless a reader supports SDXC you cannot write to a 64GB card. The previous spec was SDHC which is limited to 32GB.

Please see the following chart:

https://www.sdcard.org/consumers/choices/file_system/index.html

I’m pretty sure we have users using 64GB cards. Are you sure the card you tried simply is not compatible with Raspberry Pi or your card reader? Did you try another distribution with your card? There won’t be anything OSMC specific re. cards here.

Thanks for the replies.

@DBMandrake: Interesting.My SD card reader I only bought 2 weeks ago. It has written to a 64GB card copies of both Ubuntu as well as Raspbian both of which work just fine. It’s was just OSMC which doesn’t work, maybe the other OS’s create a partition which then gets ‘expanded’ once in the system which would explain why they work.

I’ve looked at the link you provided and indeed, even though brand new it doesn’t have the SDXC logo only the SDHC, so I guess you’re spot on.

Many thanks.

@sam_nazarko

Thanks for the reply. No cards def compatible I think DBMandrake nailed it.

Many thanks

What does confuse me though is one of the 64GB cards I tried has an SDHC logo on it. According to the reply by @DBMandrake SDHC cards are limited to 32GB therefore my card that is most definitely SDHC shouldn’t be possible.

To be honest things really just don’t add up. I have a 64GB SDHC card which shouldn’t exist but works perfeftly with other OS’s - Everything in fact - except OSMC.

There is no such thing as a 64GB SDHC card. The SD card specification states this. It could be a labelling error or non-genuine card. I’d be surprised if a vendor mislabelled the card.

Perhaps it’s an SD card that is not compatible with the old mmc driver, and requires SDHost. The installer still uses the mmc driver. If this is the case, then backing up the 16GB card and restoring it to the 64GB after installation should work. Try that out – would be interesting to know.