OSMC freezes when loading from NAS

I’ve been using OSMC for about a year with usb drives but recently got an ASUS-N56 which supports NSF, FTP, and SMB. I started with a 8GB USB drive just to test which worked at first. Then I tried a 3TB Toshiba Canio Desk setup using FTP but then things got really wierd, I could only see one of the two main folders on the drive. So I switched to NFS which showed both folders but froze when I tried to open either. I wasn’t able to get SMB to work at all. The interesting thing is if I go to the file manager and try to load them it works fine, i’m not sure what protocol it was using.

I’m wondering if there’s a limit to

Any help with this or NAS in general would be appreciated since I’m new to it, I was also wondering from those with experience what protocol would be best for this setup and whether multiple devices would be able to stream from it at the same time.

I was going to SSH into it because I read a thread with a similar issue but I didn’t know the username/pw off the top of my head but it did let me access the page so it isn’t completely frozen. Is there a log for OSMC?

Also how do I delete all the extra configs?

Thanks
Original Pi Latest OSMC

To get a better understanding of the problem you are experiencing we need more information, including logs from you. Please see http://osmc.tv/wiki/general/how-to-submit-a-useful-support-request/ for advice on how to help us.

http://paste.osmc.io/pecuruyivu.vhdl

NFS sources must have the share name appended to the location. Are you adding via GUI or editing sources.xml directly?

Are you trying to create library sources or simply access via Kodi’s File Manager? If you are adding for library, you have separated TVSeries and Movies into different folders right? This is necessary for building library.

To remove incorrect sources from GUI go to Videos>Files>use the "c"ontext menu to remove old/broken sources.

I was trying to add to the library, eventually I ending up using DLNA by flashing a new custom firmware to router, my original problem actually ending up being that the drive had errors. Thanks.