OSMC Hardware upgrade (rp2 -> rp3) question

I know there is a rp3 image of OSMC now available but I’d prefer not to have to re-install / re-setup. Just swapping the uSD card worked fine but I know it’s not operating optimally due to the clock settings, etc. Is there a way to do an in-place update of the OS? If not, will I lose any benefits by not moving to the rp3 image and just tweaking the clock speeds manually? I’d also like to enable BT. I don’t need WiFi as I use a wired connection. Thanks!

An in-place update is as good as the install from the image. Just go into MyOSMC -> Overclocking afterwards and choose the normal profile to ensure that the setting in config.txt are adapted. The internal BT of the RPi3 is currently not supported in OSMC.

Thank you for the quick feedback fzinken. I tried updating both from within OSMC and via

sudo apt-get update  
sudo apt-get dist-upgrade  

and I rebooted multiple times but the overclock screen still shows 900MHz for normal and 1000MHz for turbo.

Doing something wrong?

Did you go into MyOSMC -> Overclocking -> choose the Normal Profile? If yes try to click Turbo Profile than normal Profile. If that doesn’t make it right enable debug logging and upload logs.

Yes, I tried toggling and rebooting a couple times each. I did notice that when normal profile is selected the system info shows ARM is running at 1200MHz (even though Overclocking config says 900MHz). When turbo is selected it runs as 1000MHz.

Logs are here:
http://paste.osmc.io/ofodogones

1 Like

I appreciate your help. Actually in the meantime I got confirmation that just a quick fix was applied to ensure that the normal/default profile works on the PI3 as you indicated. But the update for the Turbo mode and the display of correct values at normal is outstanding for various reasons.
Anyhow as you wrote choosing normal/default and verify via system settings is the way to go for the time being.

1 Like

Hey, you helped me more! Thank you again for all the good info. Peace!

1 Like