OSMC HIFi Sound?

Hi ,

My open-elec distribution for my Raberry Pi 3 died after an update. It was crashing so bad during playback that I thought maybe the memory was bad. After several days of messing with it I gave OSMC a try and it works perfectly!!

Here’s the funky issue, I send my audio out via HDMI to an splitter that separated the audio into optical audio that feeds my stereo head. Previously with open-elec it would read 24/96 flac >PCM files just perfect. The amps on board DAC would signal 96k to let me know it was seeing the hi def signal. THis worked flawlessly for a long time, so I know it’s not a hardware issue. What am I missing to get OSMC to put out the correct pcm for audio?

ps - it’s doing 5.1 perfectly just not the 25/96 files.


Lake Hiawatha NJ

Presumably you’ve tried all the options in Settings-System-Audio-Output configuration?

Yeah first thing I did was run through all the options there… here’s the RUB on that though. under setings>System>Audio the “Passthrough output device” section is greyed out.

So I can’t mess with that. It’s locked on HDMI so I think it’s ok.

So if you set it to Fixed and 96kHz it still doesn’t work?

I set it to fixed, but where would I set it to fixed at 96?

I’m not sure I have that ? … when I get home from work i’ll jump on …hmmmmm

HI … so I didn’t realize there was a basic, advanced AND expert system settings. So I played with setting fixed to 96K and didn’t get anywhere. Still doesnt seem to show up on my amp. I tested my broken install of open-elec and it’s working fine.

Any thoughts?

I don’t know how kodi talks to sound devices but suppose it uses alsa. OSMC doesn’t use pulse by default. I would start by digging around in the alsa configuration files in your OE and seeing if anything is obviously different in OSMC.

As I understand it, alsa asks each sound device what bitrates etc it supports and should send a signal at a supported bitrate rather than re-sampling it. Could be there’s a lack of communication between your amp and OSMC (through the HDMI/optical switch). Some pitfalls in this process are explained here.

Having said that, maybe HDMI is handled differently. I can’t get any sense out of /proc/asound/card0/pcm1p/sub0/hw_params where normally one would get some useful information.

Conquering linux audio is not for the faint-hearted - I’m only at base camp in that area - and interested in finding out more but it might take me a while.

I got the feeling it was using something other than alsa. Using alsa sound vs hdmi sound is a choice in audio settings.

This works perfect in open-elec Kodi, Everything over here on OSMC is way better than open-elec except this one issue.

Somebody must have had the same issue.


Only those who think 96k is at all different from properly reconstructed 44.1/48k. But lets not go there. :wink:

Somebody in here must know how kodi talks to Pi HDMI. On my laptop HDMI is through alsa and pulse. I can’t test as I don’t have any HDMI devices which can accept 96k, only soundcards where we would be back to alsa. Could @sam_nazarko give us a quick steer?

“Only those who think 96k is at all different from properly reconstructed 44.1/48k.”

I won’t necessarily disagree with you, I do think there is something to HI-Def audio with the right equipment, but at this point it’s more of an annoyance, looking up and not seeing the 96k on my stereo.


Just a thought: you have selected HDMI only for sound output? Kodi reports the analog[ue] output supports only 48k so if you select both it may be choking the HDMI to the same bitrate.