OSMC Initial Release for ATV1, Installation Help Thread

No I haven’t any internal hard drives. I’ve disconnected it and use ssd disk via usb. and this try of installation was without any hard drives, only 8G usb flash drive created with windows.

Edit: will wait it very much.

Also I have a question. When I install osmc via windows I can install it to usb flash drive only and not to usb hard drive. is it normal?

installing to an internal drive is not currently supported. That should come in later releases.
The installer currently doesn’t allow changing the type of device, even though the menu is there and disabled. That should also come in later releases.

ok, I’ve understand. waiting for a new. 20151118.img.gz release
thanx!

Thanks for the netcat log. That helps a lot !

I too am experiencing the “Install failed, unable to mount bootfs” error.

Installing with the official OSMC installer.
No internal hard drive (I removed my drives ages ago)

Created the install media on Windows 7, Windows 8, and Windows 10 with the same result.

This is the same USB stick that previously had CrystalBuntu Installed.

Hi again mr. Spinner, I’m asking about not installing internal hard drive. I’m telling that windows installer doesn’t see a usb hard drive in disk list, but see usb flash drive.

Ok sorry, I thought you were putting your previously removed one back in.
I suspect that it’s because the device type portion of the installer is currently disabled when installing on ATV1.

As Sam has said, he’s looking into it.
It’s only a smaller developer team, and there are a bunch of things that need to be done.

@sam_nazarko my netcat log : http://pastebin.com/vxVhCzEV

System - Yosemite 10.10.5

Tried both official OSMC installer for Windows (VM) and Apple-PI Baker

Yes, Crystalbuntu was working fine before with all USB devices.

Hope that it helps!

After imaging, your Mac is mounting the HFS partition and setting the dirty bit…

Until we add hfsprogs (if we can add it) to the installer, you need to fsck.hfsplus the device after unmounting, then remove it from your PC and re-run the installer. I suspect Windows installer would have had different netcat output.

Avoid using ApplePiBaker, use dd for now.

Hi mr. Nazarko.
Will you publish today release with fix for installation on ATV1 without internal hdd?

I don’t have the original apple remote. Under atvflash it was paired to my onkyo rc-803m but in osmc the remote doesn’t work. What can I do to control at least to finish setup?

It’s been updated already. Try the latest build from the website.

Sam

I’m pretty sure you can hook up a usb mouse or keyboard, you would need a usb hub though

I’ve youtubed my @$$ off trying to ssh control it but everything is for pi and doesn’t seem to like the ATV IR system

Is that the only option? I don’t have one on hand.

Download a Kodi remote app from the App Store, Play Store or go to http://IP-address-of-AppleTV and you can control it from your browser.

Sam

The http://download.osmc.tv/installers/diskimages/OSMC_TGT_appletv_20151118.img.gz doesnt exist yet. It is showing up in the disk images page but its not actually on the server.

EDIT: Nevermind, it just showed up

AWESOME! Thanks Sam. Spent hours last night and this morning trying to figure this out. Can’t believe it was that easy. Oh well learned a lot about using putty and terminal especially on the atv.

@sam_nazarko so this is really weird, I tried to use dd on Ubuntu and right now my netcat doesn’t show anything at all! The only message I see that there’s an incoming connection and nothing else.

The TV screen shows up like it would boot into the verbose mode and the last message is something about either a starting or maybe resolving DNS because first letters are cut and all I see is “ing DNS”

Link on image gives 404 Error
http://singapore.mirror.osmc.tv/osmc/download/installers/diskimages/OSMC_TGT_appletv_20151118.img.gz

Edit:
This mirror works: ftp://ftp.fau.de/osmc/osmc/download/installers/diskimages/OSMC_TGT_appletv_20151118.img.gz