OSMC issue on boot - Raspberry Pi 2

Hi All,

Hoping someone may be able to point me back in the right direction. I bought my RP2 approx 9 months ago, instead of buying one ‘pre-loaded’ I decided to try and install everything myself and learn something. It went reasonable well…!

In the past 2 months, I’ve had the attached error code on boot. I’ve tried formatting the SD card and reinstalling OSMC to no prevail, the same error message comes up on boot and the Pi seems to load the previous OSMC I had running (i.e. the one I thought I had formatted) rather than the ‘fresh’ one. This is the main bit i’m struggling on, how if I have formatted the card is it still loading the previous version?!

Can anyone here set me on the right path? I have attached the below pictures showing an error message on boot - the first one comes on first, followed by the second image, followed by the ‘previous’ version of OSMC.

I’m openly not brilliant at this sort of thing - i’m pretty much following tutorials and reading some of the threads on this forum is very much out of my comfort zone. But i’m willing to learn and understand!




It seems like your SD card may be problematic.

Some SD cards are not genuine or have a lower capacity than advertised. Some simply fail over time.

Symptoms of SD cards not working correctly are:

  • Read-only behaviour, or changes made not persisting
  • A filesystem corruption error

Symptoms of counterfeit SD cards are:

  • Writing works until a certain filesystem size is reached, thereafter, writes seem to cause issues where existing data is lost or newly written data is not preserved.
  • SD card fails after a short amount of time.

Counterfeit cards are usually found on Amazon and eBay.

SD cards have a limited lifespan. I recommend you change SD card and suspect that issues will no longer persist with a good card. If you would like to be a good quality SD card purpose manufactured for OSMC, then you can find one in the Store.

Thanks Sam, i’ve just bought a new SD card based on this.