Osmc login fail

Hi
Please I’m new to OSMC and i have tried to install it in my Ubuntu 10.04 , if i do ssh osms@myIp_address using password:osms , i’m getting a message ’ Permission denied (publickey,password).’ What is the solution of this ?

Thank you

Well I am not sure if just your thread failed, because either you have made a typo in this thread or you use the wrong credentials. The right approach is ssh osmc@myIp_address using password:osmc

Also, Ubuntu 10.04 is really old. It’s possible it’s trying to use an SSH keying scheme that is no longer secure and thus not accepted by OpenSSH on OSMC. (Debian)

You might want to look at bringing your Ubuntu install up to date, and make sure you have the latest security fixes installed.

Oooh that was a typing error i meant osmc@myIp_address.Thanks

Let me update my Ubutu, then will let you Know then.

Thanks

I have tried to install Ubuntu 14.04 LTS but still when i run ssh osmc@my_ip still i’m get getting a message ’ Permission denied (publickey,password).’

Try if you locally can access it with osmc/osmc

Details regarding how to access the command line interface can be found here on our Wiki: https://osmc.tv/wiki/general/accessing-the-command-line/

Thank you for the quick response,

I have tried but still i get ‘Permission denied (publickey,password).’ message

I ment trying directly on the console not via SSH

Oooh i just run this command osmc@10.140.1.96 on console. It show this message 'osmc@10.140.1.96: command not found ’

I am not sure where we are misunderstand each other. I am refering to “Logging in locally” of https://osmc.tv/wiki/general/accessing-the-command-line/

If you do that you will see a login prompt and if you enter osmc as user and osmc as password can you login?

What you are saying is true. I have followed all the instructions as shown in
https://osmc.tv/wiki/general/accessing-the-command-line/
But It is not allowing me to login by using username osmc and password osmc. It print message ''Permission denied, please try again".
i dont know why.

Which means either you have changed the password for osmc or you have a broken file system.
Either upload logs from within Kodi that may allow us to understand what is wrong or do a clean new install.

This is how i have been trying to login into osmc.

Have you tried the “Logging in locally” method (without SSH)? If yes and the result is the same then my previous message is the final comment.

if i run without ssh , It seems like the machine is not recognizing osmc command

Have you read the linked page? To ssh you need to use ssh in the command. To log in locally you only need to use osmc/osmc as user/pass.

Can you please read what I write!!!

Yes, let me repeat to read well

What are you trying to install OSMC onto? An appleTV? Raspberry Pi or directly onto your Ubuntu machine?

The command that is being run is trying to SSH in to another machine, are you sure this other machine is alive and well? Can you ping it?

Can you walk us through the steps you’ve taken so far from the very beginning.

What is 10.140.1.96 the ip address of? Your Ubuntu machine or something else?

1 Like