OSMC NFS Install Rasperry Pi 2 no Internet

I have installed OSMC via NFS but cannot get it to connect to the internet.

I have tried both manual network config and auto config - both have the same effect.

I can get an IP address and I can SSH into OSMC from my PC on the same network. However, when I ping anything it just times out.

my cmdline.txt looks like below

root=/dev/nfs nfsroot=192.168.0.15:/osmc ip=dhcp rootwait quiet osmcdev=rbp2

I’ve tried to change it with a few other settings I have found but still can’t get it to connect. I have a Raspberry Pi 1 on the same network with NFS setup which is working fine.

OSMC itself works fine and I can connect to my NAS ok - I just can’t connect to the internet.

Any advice?

Thanks

Check

route

osmc@osmc:~$ sudo ip route
default via 192.168.0.1 dev eth0
192.168.0.0/24 dev eth0 proto kernel scope link src 192.168.0.15

osmc@osmc:~$ route
Kernel IP routing table
Destination Gateway Genmask Flags Metric Ref Use Iface
default 192.168.0.1 0.0.0.0 UG 0 0 0 eth0
192.168.0.0 * 255.255.255.0 U 0 0 0 eth0

I have posted the route info - but not sure if I should set up a permanent route or try something else?

i have this same issue. did you ever find a solution to this?