OSMC not booting

I tried the image file named “OSMC_TGT_rbp1_20150304.img.gz” and installed it using the latest installer. However, on turning on the pi I was presented with the large multi-coloured splash screen and then a blank, grey screen indefinitely, any ideas of what I’m doing wrong?

Raspberry Pi B+

A “release candidate” has not been released yet.

What you have there is a test image that isnt working.

Go back to Alpha 4

I’m on OSMC_TGT_rbp2_20150304.img.gz on Rpi2. Works very well :slight_smile:
Even installed Samba server with success from the apf store.

Keep up the good work :+1:

We aren’t providing any support for this image as it’s a test build and things are changing at a fast pace.


How did you install ? Me too tried but didn’t work ?

Same here :frowning:

Try using an image loading software package. On windows: download the image and unzip with 7zip, then use win32diskimager to install the .img onto an SD card.

throw that into your rpi and let OSMC go through it’s installation process.

It does work… though be forewarned it is a pre-release build. better to be patient and wait for the RC unless you have a decent idea of what you’re doing. also, i would imagine you’ll still have to do another fresh install once the actual release is ready. This means all of your mounts, configurations, codec keys, etc… take time to consider whether you really want to go through the process of configuring your device several times over the next week or two.

OSMC has a ‘use local version’ option in its installer which will let you install these images



Did you try on rip 2 ?

yes, I have it working on rpi2.

I will say that it seems to default to 1080p after the initial installation boot.

i.e. - very first boot (what I’m calling the installation boot) you’ll see an osmc splash screen with a progress bar at the bottom of the screen while the osmc install is running (takes a minute or two). after install is complete the rpi will reboot and at that point it seems to lock in on 1080p.

that’s been my experience at least, i have an older 720p tv that would only ever come up with a black screen after that initial install… switch over to a 1080p screen without cycling power and the osmc skin reveals itself instantly.

I used the Windows installer, and used the ‘use local version’ as Sam also pointed out.

I have tried it on RBPi 1 and same result as you, RBPi 2 works… notice that right after the colored screen disappears there is error message for about 0,5 sec, that it is replaced by cursor that never disappear

Anyways, I would say that current state is worse than Alpha 4. I cannot launch OSMC Settings app on OSMC skin or Confluence… only error… I have no idea why my WiFi dongle is not working on OSMC… but I still believe that they get it booting and configurable once really released…

Known issue.

There’s a reason we aren’t shipping public builds yet


Link to download image file. pls

Thread title edited since NO release candidate has been released.

Just a quick, constructive, remark:

Every second Sam has to spend to answer posts like these, is the second the next Version of OSMC, we all are so waiting for, will be released later.

Just have this in mind, next time you fidget with a nightly build which wasn’t build for “you” (to whom it may concern :wink: )



I just tried to install to USB on an RP2 using the RC for OSMC.
The installation goes fine I get the message OSMC installed successfully. A reboot happens, i see the screen save popup. Then i get that upside down frownyface.

I formatted the USB and Micro SD using the Raspmbc installer. Did a format under windows.
Put both drives in my laptop.
I select RP2
USB intallation
and install.

Tried it 3 times redownloaded the image, nothing works. What do i do wrong?
The USB worked fine using Raspbmc.

There will be an install.log on the SD card. Please upload that.

yesterday I have downloaded the RC version and i try to install it on my RaspberryPi2: not works. The green (or yellow) light stay turned on.
So I try with the downloader with linux, but I had the same result.

What should be wrong?


I have done numerous installs on Pi2 using the installer, it works every time.
Are you choosing the right device (Pi2 and NOT Pi)?