OSMC not work properly on the appletv1

Hey, I have recently tried usb version of OSMC on the appletv1, it booted up okay, went to formating ur device then to installing files and stayed there for hours and never passes that point. I then tried the hdd version and it installed fine then started to move sluggish, I have a crystal hd card install and it’s not reading it. Can anyone advice me?

CrystalHD acceleration is no longer supported in Kodi Krypton. It will behave sluggishly because the device is 10 years old.


1 Like

Fine,thanks for that Sam, so why write a program for a device that doesn’t support accelerator? So what do you have to say about the usb version of the program its not working.

You don’t need CrystalHD to watch some content, so it still has some use for people, but I do agree that AppleTV is dead now (we will end the support soon).

We had CrystalHD support for Kodi v16 (Jarvis) and those images are still available on our website. But it wasn’t possible to get the card to work well on Kodi v17. As there are few users and the platform is quite old, it’s better to focus our efforts elsewhere.

As for the USB issue: did you try another USB?

Yes, four, they all boot and they all stuck at installing files. I am using openelec version 6.0. 2 made by chewit on the appletv and it works. I just wanted to try something new.

How big is the USB?
Can you take a photo of what you see on screen? The installing files bit should only take 5 minutes or so.


Uploading… Uploading… Uploading… Uploading… Uploading… Uploading… Uploading… Uploading… Uploading… Uploading… Uploading… Uploading…
Sorry about the quality. I have two 16gb and two 4gb flash drives.

I don’t see any image


That’s odd.

Only thing I can think of is you are using the wrong image (USB and HDD are different); or you have multiple USB drives / HDDs attached when you perform the install.

Are you using the official OSMC installer (recommended)? If so, what device are you using (PC or Mac or Linux based machine?)


Sam, come on I using OSMC usb image, clearly marked “USB” when it didn’t worked I tried the OSMC hdd image which worked but it was moving sluggish. I I used the OSMC official installer. Have u tried it on the appletv

Your attitude is not helping your cause here. You are lucky enough to be receiving personal attention from the creator of this distro. Such a poor attitude and disrespect will quickly get your thread ignored or locked. Just some advice…

1 Like

What attitude are you referring to, I was asked a question and outlined my actions very clearly. Sam if I have offended you in any way, shape or form, I am very sorry.

Well, as I read this, these comments caught my attention

and especially this comment

I have offended you, sir its clear now. The conversation was based on now sluggish the OS runs on the appletv and the crystalhd card would eliminate that sluggishness. Will I must say I apologize for my statements. I will leave now. Thanks again Sam for trying to assist me.


Try an older image if in doubt.

What machine? A Windows PC?

The CrystalHD card only accelerates video. It does not accelerate the interface or overall system performance, so it won’t improve things. However – I find that if you use a light skin and leave things 5-10 mins after install, it does settle down and will be usable .

I’m not offended. I just want as much information as possible to try and help.
However – we need to be realistic. The AppleTV is a bit old now, and we can’t work miracles. But I am sure we can get OSMC booting from a USB for you.

In case it helps…

I have an AppleTV. Works. Like. A. Charm. Can’t thank you enough Sam for having built this distro. All the kids stuff is loaded in it, transcoded to H.264 1080p (Handbrake rules!) and the thing handles it fine. Waiting a few seconds for things to happen is a great way for the kids to learn the ancient art of patience, and once video is going it’s flawless.

To get it working if using CrystalHD get the 2017-01-01 version:
USB: http://download.osmc.tv/installers/diskimages/OSMC_TGT_appletv_20170129-USB.img.gz
HDD: http://download.osmc.tv/installers/diskimages/OSMC_TGT_appletv_20170129-HDD.img.gz

If you don’t have a CrystalHD you can get the last OSMC for AppleTV. I don’t see any real differences, but it looks nicer.

USB version starts with no issues, but it does take time and a reboot to resize the data partition (lots of time for a bad USB stick). HDD version has to restart a couple of times.

USB version should work no matter what unless the AppleTV or the USB stick is damaged. HDD version should work unless the AppleTV hardware is busted including the HDD being dead.

The AppleTV is very easy to crack open to replace the HDD. If having issues, take the disk out, plug it to a computer and check for bad blocks or just replace with a different one.

Amazon sells this bridge:

It is small enough to fit in the case and works with a SATA HD or SDD. It even lets smartctl through! (smartmontools can be installed from debian repositories).

TL;DR? The AppleTV works great as a small video storage / player. For a device that’s 13 years old, that is f*cn-awesome.

1 Like

Duh - sorry. I thought last reply was July 17th, 2020. Sorry for reviving a dead thread.