OSMC on raspberry pi3 TvHeadend frequency error

I have searched the web and the forums and i just cant find an answer to my problem. Ive purchased an Raspberry pi 3 osmc with a Hauppauge WinTV-HVR-950Q. Below is some info for the OSMC running along with proof that my raspberry pi can see my WinTV-HVR-950Q

[ 0.000000] Booting Linux on physical CPU 0xf00
[ 0.000000] Linux version 4.4.27-5-osmc (root@vero2a) (gcc version 4.9.2 (Debian 4.9.2-10) ) #1 SMP PREEMPT Tue Nov 22 02:23:12 UTC 2016
[ 2.062157] usb usb1: Manufacturer: Linux 4.4.27-5-osmc dwc_otg_hcd
[ 5.603416] media: Linux media interface: v0.10
[ 5.642319] Linux video capture interface: v2.00

USB info:

[ 2.148382] usbhid: USB HID core driver
[ 2.437276] usb 1-1: new high-speed USB device number 2 using dwc_otg
[ 2.637589] usb 1-1: New USB device found, idVendor=0424, idProduct=9514
[ 2.637615] usb 1-1: New USB device strings: Mfr=0, Product=0, SerialNumber=0
[ 2.917278] usb 1-1.1: new high-speed USB device number 3 using dwc_otg
[ 3.017620] usb 1-1.1: New USB device found, idVendor=0424, idProduct=ec00
[ 3.017647] usb 1-1.1: New USB device strings: Mfr=0, Product=0, SerialNumber=0
[ 3.080850] smsc95xx 1-1.1:1.0 eth0: register ‘smsc95xx’ at usb-3f980000.usb-1.1, smsc95xx USB 2.0 Ethernet, b8:27:eb:88:e3:77
[ 3.157251] usb 1-1.5: new high-speed USB device number 4 using dwc_otg
[ 3.279663] usb 1-1.5: New USB device found, idVendor=2040, idProduct=7200
[ 3.279690] usb 1-1.5: New USB device strings: Mfr=1, Product=2, SerialNumber=10
[ 3.279703] usb 1-1.5: Product: WinTV HVR-950
[ 3.279714] usb 1-1.5: Manufacturer: Hauppauge
[ 3.279724] usb 1-1.5: SerialNumber: 4032694906
[ 6.887486] usb 1-1.5: DVB: registering adapter 0 frontend 0 (Auvitek AU8522 QAM/8VSB Frontend)…
[ 7.177916] input: au0828 IR (Hauppauge HVR950Q) as /devices/platform/soc/3f980000.usb/usb1/1-1/1-1.5/rc/rc0/input2
[ 7.180468] rc0: au0828 IR (Hauppauge HVR950Q) as /devices/platform/soc/3f980000.usb/usb1/1-1/1-1.5/rc/rc0
[ 7.219049] usbcore: registered new interface driver au0828
[ 7.364172] usbcore: registered new interface driver snd-usb-audio
[ 23.720805] usb 1-1.5: DVB: adapter 0 frontend 0 frequency 0 out of range (54000000…858000000)

I’ve installed tvheadend with the latest version “Build: 4.0.9”

I’ve configured TVheadend per suggestions configured on the net and i cant seem to get past the follwoing message. “scan no data, failed” so i’m not getting any of my any of my channels to subscribe. below is the message when scanning through ATSC frequencies.

2016-12-17 23:00:28.001 mpegts: 653.028MHz in HauppaugeTv_ATSC_center_frequencies - tuning on Auvitek AU8522 QAM/8VSB Frontend : ATSC #0

2016-12-17 23:00:28.002 subscription: 01B1: “scan” subscribing to mux “653.028MHz”, weight: 2, adapter: “Auvitek AU8522 QAM/8VSB Frontend : ATSC #0”, network: “HauppaugeTv_ATSC_center_frequencies”, service: "Raw PID Subscription"

2016-12-17 23:00:33.000 mpegts: 653.028MHz in HauppaugeTv_ATSC_center_frequencies - scan no data, failed

2016-12-17 23:00:33.000 subscription: 01B1: “scan” unsubscribing

I hope that this is enough information to get a quick solution. Ultimately i would like to connect to existing Comcast cable, but would be happy with getting overt the air channels. Ive gone through updating drivers to trying different distributions with the same outcome so im leading to belive that i’m missing something but i cant figure what. So any helpful suggestion would really be appreciated.

What are you using as a TV signal source?

The tiny stick antenna that came with the 950Q is kind of a joke, and its quite possible that you would not receive any channels unless you are close (less than 10 miles?) to the TV tower.

Check this site for signals in your area …


The “TV Signal Analysis” will give you a list of stations with signal strength.

If you have stations that are shown in green and “Pwr(dBm)” column is in the -25 to -35 range (more negative means worse signal) then you might be able to pick up stations with the toy antenna. If the stations are green, but in the -35 to -45 range, you can probably get a set of rabbit ear antenna for ~$10 that should work. Otherwise you may need an antenna in the attic or on the roof to get enough signal.

If you want to connect to cable, your provider, Comcast, has to still be transmitting Clear QAM in your area. Many (most?) cable companies these days do not transmit a signal that can be received by TVHeadend. You can check by plugging the coax cable from Comcast directly into a TV that has a digital tuner (virtually every TV made in the last ~10 years) and have the TV scan for cable channels (as opposed to OTA antenna channels) and see if it finds anything. If it does then your RPi/TVHeadend should also be able to receive them, but the frequencies are not the same as OTA, so you need to use different settings in TVHeadend for the “network” and “Muxes” (not “ATSC_center_frequencies”).