OSMC on Raspi3, MCU usage very high

Hi all,

I am using OSMC with Kodi on my Raspberry Pi 3 as media centre. I am only a simple user, so I don’t have much knowledge about how OSMC or linux works in general, so I would like to ask for your help. Yesterday I noticed red temperature sign on the screen and I after that I found out that Raspberry’s mcu was running on quite high level and temperature was above 80°C. Via SSH and the “top” command I learned that kodi.bin takes around 300% of CPU (I guess this is due to the multiple cores), almost all the time. I tried to restart the device and right after the start of the system, mcu usage was lower, probably in normal, but after a short while (minutes), it got back to high level.

I should also mention that I had same problem few weeks ago, when I was using Openelec for the same purpose. I though this problem was caused by the system, so in the end I decided to do fresh install and use the OSMC for change. It worked some two or three weeks without issues, but now the problem is back.

Do you think, there is a problem with my system or this might be HW related? I will be glad for every help, since as I have mentioned, I am lost in this area.

I made a log and store it on https://paste.osmc.tv/wevemejole For me it’s more or less Chinese, but perhaps somebody more experienced woud be able to decipher some information that could help and direct me how to solve the problem.

Thanks a lot in advance,

What addons do you have installed or is this a pretty fresh install?

Do you have any inbound firewall ports open to your device for remoe access?

Hi jb2cool,

thank you for your reply. Yes, thanks for reminding, I forget to mention the addons. I have installed Rsync and marcelveldt’s Spotify addon. But I tried to disable the Spotify addon when I noticed the problem and after restart, the behaviour was the same.

Regarding the ports, I am not sure, if you mean that, but I’ve got allowed remote control via HTTP.

Also there is an external HDD connected to the Pi via USB.

You say you have allowed remote control via HTTP, is this just internally within your LAN or have you also port forwarded this so that it’s available from the WAN/Internet?

Oh. No, it’s accessible just within my LAN.

Disable raspotify. Revert to either Estuary or OSMC skin. Disable scan library on boot. Reboot and check CPU usage.

All I could really see in the logs (I’m not great at looking at these logs) was the device scraping and this can be a fairly intensive task. I think @ActionA’s advice is a good place to start.

I was going to suggest installing from scratch and then building up your system one bit at a time till you can identify which process/feature is causing your issues.

Thank you for the tips, guys. I tried what @ActionA recommended, but with no positive effect. I guess, I will have to try a fresh install during the weekend :unamused: