OSMC only mounts EFI partition of ExFat HDD

I recently started using a 3Tb external HDD with my Pi2 as its main media storage. Today for some reason OSMC will not mount the main partition of the HDD, only the EFI partition.

If I connect the same drive to my mac, it mounts just fine. I attempted running the mac’s first aid tool on the HDD, which repaired some errors with the file system, but OSMC still will only mount EFI.

I’ve tried updating OSMC, updating ExFat utilities at the command line, and going through the steps in this guide to manually mount the drive at the command line, and I’m still not having any luck.

The HDD has its own power supply, it’s not drawing power from the Pi, so I don’t think it’s that.

Anyone got any idea what’s going on/suggested fixes? Help would be much appreciated.

provide URLs from

dmesg | paste-log
blkid | paste-log
partx --show /dev/sda1 | paste-log

Sure thing:

Sorry one mistake, last one should be
partx --show /dev/sda | paste-log

No problem:

Ok, checked a bit with @DBMandrake . This might be a know bug with GPT partition tables are not correctly recognised by udisks-glue.

But as a last check please provide grab-logs -J

Sure thing, thank you :slight_smile:

Hi, did it turn out to be that udisks-glue problem? Is there a known solution for it?