OSMC PI1 keeps rebooting after December update

After december update (kodi 15.2 nov 29), osmc keeps rebooting after a few minutes while navigating in any screen.

We need to see logs to have any idea what might be creating the issue.

Thanks. Newbee… Just uploaded logs.

You need to post the URL provided to you when you upload logs here, otherwise nobody can see them.

Of course… I knew that… :relaxed:



You have left out some important logs, such as the apt logs. I can’t see any obvious cause of problems in what you have provided.

Have you tried a different power adaptor ? If you are seeing a spontaneous reboot its pretty unlikely to be a software issue.

Thanks for the quick reply. Ill upload all then.

Its not power, and I start to get the feeling its some incompatibility between addons and the update. It clearly started to have this behaviour just after the update. I just watched a full 2h movie locally (without addon) and it didnt crash.

Straight after surfing menus and as i went into addon section in videos it rebooted again.

Http://paste.osmc.io/ ayikogaruq

Faulty addons might cause Kodi to crash (which will show the sad face) but there is no evidence of that in your logs. Faulty addons will not cause the entire system to crash nor a spontaneous reboot.

While it’s not completely impossible, it is exceptionally unlikely.

You have updated from a very old release (around May) and a LOT has changed since then. There have been changes in the kernel that cause the CPU to run in dynamic turbo mode a lot more often than previously, this will show up an inadequate power supply.

If you have your overclock set higher than “normal” try setting it back to normal. Otherwise it’s my opinion that what you are seeing is unlikely to be a software problem, and is going to be power related.

Any time a Pi spontaneously reboots, especially in response to increased CPU activity, 9 times out of 10 it’s due to excessive voltage drop on the 5v supply.

Ok thanks for the insight. Power I can handle, so ill do some tests to rule one out. I also disabled the latest addon and it still reboots, so i am also ruling out some of the software potentials. Ill post back on the power. Thanks again.

Hi Simon,

I’ve tried two power supplies with higher power output capabilities and the reboots persist. Curiously if i avoid navigating the Video menu where the addons reside, it diesnt seem to boot. Additionally Ive watched 2 full movies with previously downloaded content (ie. without using addons) and no reboot occured.

Considering reinstalling from scratch unless you have any other insights or suggestions.

You can reinstall or you can rename /home/osmc/.kodi directory which will cause Kodi to reset/start fresh with none of your settings/addons


It seems to be stable now. I renamed as you suggested and all seemed well till it rebooted again suddenly. I backtracked the last change i made and it was changing the theme to Confluence… Reverted and it hasnt rebooted since (even with all my addons).

Does that make any sense?

Anyhow, its been working well now.

Thanks for all your quick and valuable support!

Warm regards


VERY DOUBTFUL that Confluence is your problem. Possible that Confluence in combination with some addon may cause a problem.