OSMC RC Can't get TVHEADEND to scan


I have managed to get TVHEADEND installed and I can access it from a web browser. I have added a network and I don’t see how to get the muxes added automatically so I added one manually but I can’t get it to scan.

Does anyone know how to get the muxes added automatically and to get it to scan?

Thank you in advance


In this version of Tvheadend you need to add the muxes manually. I located the mux info for my nearest transmitter, Rowridge, Isle Of Wight and entered the data, when you click Create it starts the scan. You can see the status of the scan and other details by clicking the chevrons in the bottom right of the screen… Unfortunately my set up is not finding any services. However with the older version of Tvheadend with Raspbmc it was working fine.


Thanks @pscriven. I added 8 muxes but I still can’t get it to scan. It says initial scan complete false for all the muxes. I have left this for a couple of hours and still no scanning going on

If I go back to RASPBMC it all works fine

I am so keen to get this working as OSMC should support a new USB stick that I have waiting


I found that eventually all muxes were scanned, leaving me with 2 problems:

(1) No channels were found

(2) I still get the Tvheadend HTSP Client message: “Connection lost”, which would appear to be related to the Tvheadend log having repeated

Mar 16 13:24:42.736 htsp: Got connection from

Mar 16 13:24:42.737 htsp: Welcomed client software: XBMC Media Center (HTSPv8)

Mar 16 13:24:43.012 htsp: [ XBMC Media Center ]: Disconnected

Mar 16 13:24:47.064 htsp: Got connection from

Mar 16 13:24:47.064 htsp: Welcomed client software: XBMC Media Center (HTSPv8)

Mar 16 13:24:47.329 htsp: [ XBMC Media Center ]: Disconnected

messages. How does one prevent these, and are they related to the failure to find channels?

Edit: Latter problem solved by setting Tvheadend HTSP Client username and password each to “osmc” on the Tvheadend HTSP Client general settings page

Same problem here with RC installed today (20-03-2015) from the latest version of the installer. Can’t scan and if I add the muxes manually (copy from a working old raspbmc setup) dont work.

When I start Tvheadend manually rather than using HarryL’s suggestion of /etc/rc.local I get the following error message:

2015-03-24 18:22:27.126 [ ERROR] HTTP: {IP of my PC on local network}: /api/mpegts/input/network_list – 400

which definitely looks wrong - why should my PC have that file at all, never mind in that place?

Can anyone advise where I am going wrong?

Can’t answer your question I am afraid but it appears to me the AppStore Tvheadend has some issues making it unusable. I have been running Tvheadend under Raspbmc without issue. With OSMC I can enter the muxes, it does an initial scan, however it finds no Services. This evening I installed Openelec, installed Tvheadend and had no problem setting it up, Services were found without issue.