OSMC RC Unable to install TVHEADEND

What happens if you restart the service after the time is correct ?

sudo systemctl restart tvheadend

If the problem is the time I would expect it to work after this.

Hi Sam,

If i use my .hts folder, that my own compiled version from git have made, then the package manger is not finishing installation… just braks/exits…

I can se that i don’t have an "/home/osmc/.hts/tvheadend/accesscontrol/1" >1< im running password less… but there is an random named file in there with some of the same infomation… so just check if the folder exists (preferably .hts folder) not the file…

did a new try with the app store version…

here is the error

and in dmesg i finde this:

[64295.380450] usb 1-1.3.3: DVB: adapter 0 frontend 0 symbol rate 6875 out of range (500000..8000000)
[64495.531436] usb 1-1.3.3: DVB: adapter 0 frontend 0 symbol rate 6875 out of range (500000..8000000)

also there is no EPG over-the-air grapper installed:

This is from my on version, and it’s log:

Her is my compile log .config.mk
http://paste.osmc.io/wimetabosa.coffee

Did try to enable more debug, but there where no new infomation…

@DBMandrake - restarting Tvheadend as you suggest did not fix the problem of not finding any services, which probably does not surprise you. However the nearest I have ever come to getting a Tvheadend to work on my Pi 2 was when I started it manually, but presumably this was a coincidence.

The result of running “sudo systemctl status tvheadend -l” after the restart and creating 2 new muxes was:

  • tvheadend.service - TVHeadend Server
    Loaded: loaded (/lib/systemd/system/tvheadend.service; enabled)
    Active: active (running) since Thu 2015-03-26 18:24:30 UTC; 9min ago
    Process: 497 ExecStop=/usr/bin/rm /run/tvheadend.pid (code=exited, status=203/EXEC)
    Process: 500 ExecStart=/usr/bin/tvheadend -f -p /run/tvheadend.pid -C -u osmc -g video (code=exited, status=0 /SUCCESS)
    Main PID: 501 (tvheadend)
    CGroup: /system.slice/tvheadend.service
    `-501 /usr/bin/tvheadend -f -p /run/tvheadend.pid -C -u osmc -g video

Mar 26 18:25:40 osmc tvheadend[501]: linuxdvb: /dev/dvb/adapter0/frontend0 - FE_READ_STATUS error Remote I/O er ror
Mar 26 18:26:00 osmc tvheadend[501]: mpegts: 754000 - initial scan complete
Mar 26 18:27:19 osmc tvheadend[501]: mpegts: 768000 - starting for ‘initial scan’ (weight 1)
Mar 26 18:27:19 osmc tvheadend[501]: mpegts: 768000 - tuning on /dev/dvb/adapter0/frontend0
Mar 26 18:27:33 osmc tvheadend[501]: linuxdvb: /dev/dvb/adapter0/frontend0 - FE_READ_STATUS error Remote I/O er ror
Mar 26 18:27:49 osmc tvheadend[501]: mpegts: 768000 - initial scan complete
Mar 26 18:29:03 osmc tvheadend[501]: mpegts: 658000 - starting for ‘initial scan’ (weight 1)
Mar 26 18:29:03 osmc tvheadend[501]: mpegts: 658000 - tuning on /dev/dvb/adapter0/frontend0
Mar 26 18:29:16 osmc tvheadend[501]: linuxdvb: /dev/dvb/adapter0/frontend0 - FE_READ_STATUS error Remote I/O er ror
Mar 26 18:29:33 osmc tvheadend[501]: mpegts: 658000 - initial scan complete"

Does this indicate a problem in linuxdvb?

HarryL, thank you, thank you, thank you!!!

I followed your instructions to build Tvheadend on OSMC. Having set up the muxes it scanned and found all the Freeview channels in my area. All I had to do was to set it to run at start up and all is working well.

Paul

Hi @HarryL
Thank you very much for the instructions I am now up and running with a smile on my face :smile:

I took a fresh install and tried your instructions but it all failed. I then installed the App Store version and then immediately uninstalled it and your instructions then worked

I have a PCTV 292e USB tuner and when I tried to use it Tvheadend could see it but it would’t find any services. When I looked at DMESG I saw that dvb-demod-si2168-02.fw was not being loaded. I discovered that it was not in /lib/firmware so I downloaded it and put it in the folder and the tuner burst into life.

Thank you again for the instructions

Keith

I am still not finding any channels with either HarryL’s or the latest App Store version of Tvheadend with my Pi 2 + Hauppage WINTV-HR 900H (which appears as a Zarlink ZL 10353 DVB-T).

Have just done a clean install with HarryL’s version, which has the advantage over the App Store version of allowing you to initiate scans. dmesg then gave the following apparent error message:

[ 14.104376] usb 1-1.2.4: DVB: adapter 0 frontend 0 frequency 0 out of range (174000000…862000000)

on start-up.

Using RASBMC on a Pi 1 I had to run:

cd /lib/firmware
sudo wget goo.gl/xZSPH -O dvb_firmware.tar.gz
sudo tar -xzf dvb_firmware.tar.gz

so I tried that and noticed references to Rasbmc while doing so. Are these correct for OSMC & Pi 2?

After running that I still got the above entry from dmesg. However attemting to rescan, I got a series of messages of the form:

[ 28.670875] xc2028 0-0061: Loading SCODE for type=DTV78 DTV8 ZARLINK456 SCODE HAS_IF_4560 (62000300), id 0000000000000000.
[ 28.686029] xc2028 0-0061: Incorrect readback of firmware version.

which looks like confirmation that I am downloading the wrong firmware. Can anyone advise a better link to download the firmware?

Using HarryL’s instructions I have TVHeadend up and running and loading and scanning all the pre-defined Muxes for ATSC and it finds all the channels I’d expect it to using a WinTV-HVR-950Q

I also have enabled the TVHeadend HTSP Client, and it connects to the TVHeadend server.

But I don’t see the “Live TV” tab in the main menu.

Any idea what I might be missing?

@ObvB - have you mapped the channels using the Tvheadend web-type page? If not they will not be visble to Kodi/OSMC.

Check if the addon is enabled, sometimes you have to enable it more than once before it sticks

This was it.

But I’m not finished yet :frowning:

Now the “Live TV” menu appears, and it has the channels that I have mapped in TVHeadend, but when I try and view a channel, all I see is a spinning grid of rainbow colored squares. In the TVHeadend “web-page”, in the status tab, it show a connection that is streaming the expected number of kb/s. Could this be because I don’t (yet) have an MPEG2 hardware license?

(I should also mention that it took quite a bit of “trial end error” to get this far. I had to follow withakw’s method of installing TVHeadend from github using HarryL’s instructions, then install and uninstalling the OSMC App Store version, and then running and configuring the github version. I haven’t yet got it running automatically on startup, I manually start TVHeadend on each reboot … one step at a time :slight_smile: )

Do you have audio? Before I installed the MPEG2 codec I had audio but the screen was black. I get the spinning coloured grid when tuned to a radio station. Are you sure it is not a radio station you are tuned to?

No audio. And definitely not a radio station. In the TVHeadend server status page, I can see that its tuned to and streaming the TV channel I selected in OSMC.

@ ObvB - Your comments on having to install both versions has allowed me to move one step on - I created the “/home/osmc/.hts/tvheadend/accesscontrol/1” in DBMandrake’s post above (I had not installed the App Store version). It now scans immediately and finds all the channels I would expect, but I now get the message:

Tvheadend: No free adapter

and on the web page Configuration/DVB Inputs/TV adapters the adapter has disappeared! I assume, therefore that there is something in the file that is wrong for HarryL’s version of Tvheadend, so will take a closer look at that next.

I had the same message initially. I powered down the tv adaptor and rpi and turned on again and it was fine. It thinks the to adaptor is in use.

[quote]Could this be because I don’t (yet) have an MPEG2 hardware license?[\quote]

Yes

Turns out there was no audio because I forgot I had the HDMI cable going directly into the TV (which has speakers turned off) rather than the usual configuration where everything goes through the AV receiver :flushed:

So now basic functionality of watching Live TV, and recording and playing back is working,

I still have a coupe of issues :

  • the “Thumbnail” view of the channel isn’t being displayed, (Its working in the Raspian+TVHeadend+Kodi that I set up con the same hardware to compare)
  • The “timeshift” functionality works at first after a reboot, but it soon breaks after pausing TV and/or changing channels. This also happens with Raspian+TVHeadend+Kodi, so it may be something in the build of TVHeadend 3.9.2662~ge4cdd3c

Thanks for the help with all my dumb questions/problems!

I have still not succeeded in getting a TV picture with TvHeadend and my WinTV-HVR-900H, but all seems fine bar a few niggles with a PCTV USB tuner. I suspect it is the firmware for the former generated with

cd /lib/firmware
sudo wget goo.gl/xZSPH -O dvb_firmware.tar.gz
sudo tar -xzf dvb_firmware.tar.gz

which is the problem. Have posted on the Pi forums in case anyone there can help.

I have given TVHeadend in the App Store yet another refresh. Hopefully the configuration tab will be available now.

Sam

Starting with a fresh install of RC on a Raspberry Pi 2

I do the updates within OSMC, install the TVHeadend Server from the App Store, install the firmware for 950Q tuner, login to osmc:9981 using user/pw = osmc/osmc and I get stuck here …

When using HarryL’s instructions for building TVHeadend, at this point there is an option to select the standard US ATSC broadcast muxes. It is missing here. This leaves me effectively dead, since even if I knew how to manually create each Mux, I wouldn’t want to do it for every channel.

Edit: I then uninstalled TVHeadend in the App store, and then installed from Github using HarryL’s instructions, and it worked. Previously I think it was necessary to install from Github first, then install/uninstall from App Store … this time it worked installing from Github after the App store.