OSMC Remote

Hi I’ve noticed other threads speak of this but I just purchased the vero 4k+ and noticed the remote control feels rather delayed in rf mode (this is the only mode I use).

I’ve tried the remote on a raspberry pi 3b+ also with same results but if I try the same tests on both boxes with a no voice amazon firetv remote (bluetooth) everything is instant.

I tried the method 2 posted before to remove the repeat filter but this made no difference.

i could ignore the issue as minor fore menu browsing but it becomes more noticeable when using the onscreen keyboard as I use the keyboard rather fast and have no issue with this on the amazon remote but the osmc remote just can’t keep up or just doesn’t register certain clicks when used too fast.

Has there been any more progress or solutions made to improve this or is it just a bluetooth is faster than rf issue

The OSMC remote can only be used as an RF device. There isn’t a Bluetooth mode.

We added a repeat filter to slow down input as users have said that the remote is too fast and they get duplicate presses.

The Bluetooth Amazon remote likely doesn’t have an eventlircd profile on OSMC, so is skipping the repeat filter.


Hi thanks for the reply

I understand the repeat filter is there for a reason but even without it nothing has changed.

The osmc remote isn’t bad or anything it’s just not as fast at key presses as my amazon fire tv remote,
Just not sure if this is an issue with all RF remote controls or if it can be fixed with changing settings in the os.

It would seem the aftvremote has a profile according to the github

Are you sure you disabled the filter?

Hi I think so this is a screenshot of my eventlircd.service file

It looks OK from a quick glance.
I will see if we can disable the repeat filter for just the OSMC remote.


1 Like