OSMC samba issues again

Currently Have a Model Pi 3 connected via Ethernet with Wireless turned off.
I use SMB to connect to another computer with 4 hard drives attached. I can connect to this at any time with any other computer and also with any other XBMC clients that are on other PC’s.
My issue is that When I go into SMB in OSMC everything is blank. If I reset my server PC I am able to see the SMB shared folders. I can generally use it for a few days but at some point the issue comes back again and all the shared folders disappear. I got the following message x 4 for each hard drive everytime I try to access this directory.
ERROR: SMBDirectory->GetDirectory: Unable to open directory : ‘smb://USERNAME:PASSWORD@HOMESEER-PC/Drive%20Echo’
unix_err:‘1’ error : ‘Operation not permitted’
I have tried usernames and passwords and ip addresses and a multitude of other things to get it working with no luck.
When I tried adding a new SMB share not event other PC’s show up… I get this message in the log.
ERROR: Control 18 in window 10129 has been asked to focus, but it can’t
I am 99% sure if I reset my server PC which is basically just 4 hard drivers connected to a computer with a single folder in each hard drive shared to everyone it will work again for some amount of time.
Also I have crawled a lot of forms on this site and other and none seem to have the same type of issues I have although many seem close.
Appreciate any help given.

Maybe try more standard share names without spaces in it.

My problem has just came up again. Seeing as I highly doubt its the server I am assuming it is the OSMC currently running on a PI3. I have just run a network monitor and when I am on it and attempt to load the same set of movies that would otherwise load any other time I get a crap load of data with one main thing sticking out to me. I am running 4 gigs ram with always less than 50% in use.

The message says -

162 5:15:32 PM 6/11/2016 35.2536638 HOMESEER-PC SMB SMB:R; Session Setup Andx - DOS OS Error, (8) NOT_ENOUGH_MEMORY {SMBOverTCP:53, TCP:52, IPv4:5}

Bump as I am still having the same issues. I cannot seem to figure out why turning the PC off and back on causes OSMC to recognize the SMB shares. I also cannot figure out what causes it to stop working. I just get the same unix_err:‘1’ message after a few days or so…

The error is clear that something is out of memory (or at least reporting to be) but it isn’t clear what it is reporting to be out of memory.

Where is this error from? The RPi running OSMC or the Samba Server?

What are the specs of the server?
What OS is it running?
If non-Windows, what version of Samba are you running on the server?

A little googling showed up this bug which may be of interest - especially the solution in post 8